LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 10-28-2006, 07:28 PM   #1
Diagmato
Member
 
Registered: Jul 2005
Location: Cardiff
Distribution: Suse 10
Posts: 59

Rep: Reputation: 15
BCM4318 native kernel drivers FC6 losing packets


Hello there,

I am using Fedora Core 6, with a wireless Broadcom 4318 network card.

I followed a quick guide to getting the bcm43xx drivers working with fwcutter. This worked for a day, even after reboots.

However, it has suddenly stopped working. Its a miracle if it ever connects, and when it does, im getting 90 - 100% packet loss when i try pinging the router, or other computers on the network,

The router is fine - I can access the wireless perfectly using other computers on wireless.

Nothing has been changed or updated since the problem started occurring.

iwconfig --version returns:

Code:
# /sbin/iwconfig --version
iwconfig  Wireless-Tools version 28
          Compatible with Wireless Extension v11 to v20.

Kernel    Currently compiled with Wireless Extension v20.

eth1      Recommend Wireless Extension v18 or later,
          Currently compiled with Wireless Extension v20.
There is an entry in /etc/modprobe.conf for the wireless card (eth1):

Code:
alias eth1 bcm43xx
The card is detected fine, I can configure options for it fine, and so forth. Currently, it is set to automatically obtain an ip address (dhcp), like it was when it was working.

If you can help with this at all, then thank you.
 
Old 10-29-2006, 05:25 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Personally, I would blacklist the bcm43xx module and use ndiswrapper for the wireless Broadcom 4318 network card. In fact that is what I did, the bcm43xx module does seem to have problems.

Visit: https://bugzilla.redhat.com/bugzilla/index.cgi and use the search term bcm43xx
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC6 beta3 upgrade to Final FC6 thyraios Fedora 1 09-18-2006 07:55 PM
update from fc5 last kernel to fc6 test 2 eskuai Fedora 1 09-04-2006 09:18 AM
Help please, native nvida drivers ? KezzerDrix Suse/Novell 3 05-25-2005 03:08 AM
Removing native kernel Gilion Debian 3 09-26-2003 11:26 AM
iptables (netfilter) losing packets! koningshoed Linux - Security 4 06-28-2003 04:09 PM


All times are GMT -5. The time now is 03:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration