Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.


  Search this Thread
Old 05-17-2006, 01:34 AM   #1
LQ Newbie
Registered: Apr 2006
Posts: 25

Rep: Reputation: 15
bash not answering to ndiswrapper, lsusb

Using FC4, and bash isn't recognizing:
Too new to linux to understand what I'm doing wrong (setting up wireless usb). Any direction, greatly appreciated.
Old 05-17-2006, 10:55 AM   #2
Registered: Nov 2004
Location: Arizona
Distribution: Slackware, RHEL, others
Posts: 470

Rep: Reputation: 40
I could be wrong, but I'm guessing you'll need SU for these. What I mean is...I believe these are root commands and therefore Bash is complaining about it.
Old 05-17-2006, 10:30 PM   #3
LQ Newbie
Registered: Apr 2006
Posts: 25

Original Poster
Rep: Reputation: 15
Error received after changing to SU

[Dad@Astro ndiswrapper-1.16]$ ls
AUTHORS driver ndiswrapper.8 NETUSB.SYS utils
ChangeLog INSTALL ndiswrapper.spec PRISMUSB.SYS version
debian Makefile NETUSB.inf README
[Dad@Astro ndiswrapper-1.16]$ su
[root@Astro ndiswrapper-1.16]# ndiswrapper -i NETUSB.inf
bash: ndiswrapper: command not found
[root@Astro ndiswrapper-1.16]#
Old 05-17-2006, 11:02 PM   #4
Senior Member
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Rep: Reputation: 57
Use this:
su -
su just basically switches user, attach the - at the end and it loads their shell settings, $PATH and all the assorted crap that you don't always need. Alternatively you could just log in as root before starting a GUI.

Considered the possibility that ndiswrapper isn't installed properly? Once you've gained root, try modprobe to make sure that $PATH is set properly.
Old 05-18-2006, 11:48 AM   #5
Registered: Jun 2005
Location: CA, USA
Distribution: Gentoo
Posts: 165

Rep: Reputation: 30
I think ndiswrapper installs to /usr/sbin by default (I could be wrong). I don't think you don't wnat to go through the trouble of adding that dir to your $PATH for one command so..

to find the executable

find / -name ndiswrapper
It should be something like /usr/sbin/ndiswrapper

Then, link it to a file that is in a directory that you know is in your $PATH, say, /usr/bin
(assuming that it's /usr/sbin/ndiswrapper)

ln -s /usr/sbin/ndiswrapper /usr/bin/ndiswrapper

Do those as root, and you should be able to execute it with

Old 05-22-2006, 12:48 AM   #6
LQ Newbie
Registered: Apr 2006
Posts: 25

Original Poster
Rep: Reputation: 15
Thanks folks!!
su- actually helped me understand why I couldn't install the berlios wireless driver.
installing ndiswrapper was another attempt. However, armed with ndiswrapper linking will help with next install.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
lsusb shows nothing RVDowning Mandriva 33 04-18-2006 03:03 PM
ndiswrapper bash script novacrasher Linux - Software 3 11-13-2005 09:36 PM
PC hangs on lsusb command Adrian Baker Linux - General 0 07-07-2005 09:52 AM
lsusb with kernel-2.6.11 ccool Linux - General 5 03-16-2005 03:03 PM
What does the output of lsusb mean? linuxRunner Linux - Hardware 1 08-16-2004 12:17 PM

All times are GMT -5. The time now is 04:15 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration