LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   atml0 wlan interface :: 3Com 3CRSHPW_96 (http://www.linuxquestions.org/questions/linux-wireless-networking-41/atml0-wlan-interface-3com-3crshpw_96-a-155727/)

Tero 03-10-2004 02:54 AM

atml0 wlan interface :: 3Com 3CRSHPW_96
 
Hello!

At last I managed to compile kernel and atmelwlandriver module to work together. I have Debian sarge (test release) Linux tdeb2 2.4.24 #2 Tue Mar 9 17:18:47 EET 2004 i686 GNU/Linux.

I have been trying to get 3CRSHPW_96 wlan card to work, but with no success. When I insert card to pcmcia slot, nothing happes at first time, but when I get it off and insert it in second time cardmgr wakes up and tries to configure it:
==== daemon.log ====
Mar 9 14:33:01 tdeb2 cardmgr[600]: socket 0: 3Com 3CRSHPW_96 Wireless LAN
PC Card
Mar 9 14:33:01 tdeb2 cardmgr[600]: executing: 'modprobe pcmf502r3'
Mar 9 14:33:02 tdeb2 cardmgr[600]: executing: './network start atml0'
Mar 9 14:33:03 tdeb2 dhclient: Internet Software Consortium DHCP Client 2.0pl5
Mar 9 14:33:03 tdeb2 dhclient:
Mar 9 14:33:04 tdeb2 dhclient: Listening on LPF/atml0/00:0a:5e:05:fd:0e
Mar 9 14:33:04 tdeb2 dhclient: Sending on LPF/atml0/00:0a:5e:05:fd:0e
Mar 9 14:33:04 tdeb2 dhclient: Sending on Socket/fallback/fallback-net
Mar 9 14:33:04 tdeb2 dhclient: DHCPDISCOVER on atml0 to 255.255.255.255 port 67 interval 6
Mar 9 14:33:10 tdeb2 dhclient: DHCPDISCOVER on atml0 to 255.255.255.255 port 67 interval 8
Mar 9 14:33:18 tdeb2 dhclient: DHCPDISCOVER on atml0 to 255.255.255.255 port 67 interval 15
Mar 9 14:33:33 tdeb2 dhclient: DHCPDISCOVER on atml0 to 255.255.255.255 port 67 interval 19
Mar 9 14:33:52 tdeb2 dhclient: DHCPDISCOVER on atml0 to 255.255.255.255 port 67 interval 12
Mar 9 14:34:04 tdeb2 dhclient: No DHCPOFFERS received.
Mar 9 14:34:04 tdeb2 dhclient: No working leases in persistent database.
Mar 9 14:34:04 tdeb2 dhclient: Sleeping.


Wlan base station is also 3Com product. It's configured to channel 11, and no WEP encyption. Nothing cannot be found from base station's log files.

Here are some more information:
# iwconfig atml0
atml0 ATMEL RFMD ESSID:"TestiVerkko"
Mode:Ad-Hoc Channel:4 Cell: 02:00:FD:BE:7F:40
Bit Rate:11Mb/s
RTS thr=2347 B Fragment thr=2346 B
Encryption key: off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 invalid crypt:0 invalid misc:0
# cardctl ident 0
product info: "3Com", "3CRSHPW_96 Wireless LAN PC Card"
manfid: 0x0101, 0x0696
function: 6 (network)


I think 3com wlan card could be broken or something.
Where should I start to solve this problem? What should I do to make it work?

Tero 03-10-2004 02:56 AM

kern.log
 
I forgot to put part of kern.log file to my post. Here it's:
===== kern.log ========
Mar 10 10:53:21 tdeb2 kernel: pcmf502r3: ATMEL 11Mbps Wireless PCMCIA LAN driver version 1.0.1.0
Mar 10 10:53:21 tdeb2 kernel: -> vnet_attach()
Mar 10 10:53:21 tdeb2 kernel: -> vnet_event(registration complete, 0, 0x00000246)
Mar 10 10:53:21 tdeb2 kernel: -> vnet_event(card insertion, 0, 0x00000246)
Mar 10 10:53:21 tdeb2 kernel: -> vnet_config(0x00000004)
Mar 10 10:53:21 tdeb2 kernel: pcmf502r3: index 0x01: Vcc 3.3, irq 3, io 0x0100-0x011f
Mar 10 10:53:22 tdeb2 kernel: pcmf502r3: Registered netdevice atml0
Mar 10 10:53:22 tdeb2 kernel: Copy Code To Internal Memory (** EEPROM **)
Mar 10 10:53:22 tdeb2 kernel: *** Downloading Firmware to internal memory ***
Mar 10 10:53:22 tdeb2 kernel: --=+>GetFwFile BasicFW : 35184,
Mar 10 10:53:22 tdeb2 kernel: Fw Mapped in : 0xC2750000
Mar 10 10:53:22 tdeb2 kernel: <=- Out of GetFwFile
Mar 10 10:53:22 tdeb2 kernel: **** SCATTER LOADING ****
Mar 10 10:53:22 tdeb2 kernel: ************************************************************
Mar 10 10:53:22 tdeb2 kernel: ***************** BSR = 0x200 *****************
Mar 10 10:53:22 tdeb2 kernel: ************************************************************
Mar 10 10:53:22 tdeb2 kernel: IFACE base = 0x508
Mar 10 10:53:22 tdeb2 kernel: MAC Address: 00 0A 5E 05 FD 0E
Mar 10 10:53:22 tdeb2 kernel: Regulatory Domain = 0x41
Mar 10 10:53:22 tdeb2 kernel: Adapter-REGDOMAIN!!! : 0x41
Mar 10 10:53:22 tdeb2 kernel: Radio ON command completed with SUCCESS (0x1)...
Mar 10 10:53:22 tdeb2 kernel: Configuring WEP (Disabled-Mandatory-Open System)
Mar 10 10:53:22 tdeb2 kernel: WEP Key to use: 0 -0
Mar 10 10:53:22 tdeb2 kernel: NO WEP
Mar 10 10:53:22 tdeb2 kernel: WE ARE INSIDE Scan...
Mar 10 10:53:22 tdeb2 kernel: Start Scanning from Channel 4 - SSID(0):
Mar 10 10:53:22 tdeb2 kernel: Scan Command in Progress...
Mar 10 10:53:22 tdeb2 kernel: -> vnet_open(atml0)
Mar 10 10:53:24 tdeb2 kernel: SCAN Completed...
Mar 10 10:53:24 tdeb2 kernel: 0 Entries in BSS List:
Mar 10 10:53:24 tdeb2 kernel:
Mar 10 10:53:24 tdeb2 kernel: ----------------------------------------------------
Mar 10 10:53:24 tdeb2 kernel: **** BSS List is empty ****
Mar 10 10:53:24 tdeb2 kernel: ----------------------------------------------------

luisgp 04-06-2004 10:00 AM

have you tried to use the lvnet command that installs with the atmelwlandriver?
i see you card is configured as ad-hoc and thus might not be looking for an access point. try changing it to infrastructure mode with lvnet or with the iwconfig command (mode=manager i think).

Good luck

Luis

beyer42 04-06-2004 09:00 PM

http://x.unix.se/stuff/inspiron4k.xml

Tero 04-13-2004 03:21 AM

bought new one
 
Hey!

After I had worked with 3Com card over 40 hours, I decided to boy other card. I bought Siemens Gigaset 54 (uses Broadcom shipset), and in five (5) minutes I got it working!!

Main thing is that my wlan network is working now. Good thing is that Gigaset 54 is faster than 3Com. Bad thing is that I had to spend more money to my wlan network.

jbneu 09-16-2004 03:43 AM

Re: bought new one
 
Hi tero,

Could you please tell me how you install your gigaset 54, I have the same pccard but I'm not able to make it work. I dont know where to find the good driver!

Tero 09-17-2004 01:38 PM

I managed to get it work with this NdisWrapper.
http://ndiswrapper.sourceforge.net/


All times are GMT -5. The time now is 09:21 AM.