LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 08-04-2005, 03:30 PM   #1
mrmcctt
Member
 
Registered: Oct 2004
Posts: 54

Rep: Reputation: 15
Atheros 5004g, MadWiFi and WPA


I have the system (a Toshiba a70-s256) with the integrated wireless (Atheros 5004g) working. That's a start. The system recognizes the wireless card. I can go to Mandrake Control Center>Network & Internet>Wireless Connection and see several wireless networks. I have installed the MadWiFi driver for the Atheros card.

My wireless network uses WPA-PSK for security. I have looked in the WPA_Supplicant file on my system and it contains my ESSID and Key for my network.

What else should I be looking at? I cannot see my gateway and cannot connect to the network via wireless. There was a tutorial (that I unfortunately cannot find again) that explained this. I had this problem on a different system and solved it. I even wrote out notes how to fix it but my daughter decided to use my notes for scratch paper and then threw the book out.

Is there anything in the iwconfig I need to fix?

Any Suggestions are appreciated.

System: Toshiba Satellite A70-S256
Atheros 802.11g 5004G wireless adapter (Integrated)
Mandriva Linux 2005SE

Everything else works fine on default install except sound. My next project.

Thanks
 
Old 08-06-2005, 10:29 AM   #2
mrmcctt
Member
 
Registered: Oct 2004
Posts: 54

Original Poster
Rep: Reputation: 15
Close

I am still trying to get this working. The system recognizes the integrated Atheros card and under the Mandrake Linux Control Center it recognizes up to 8 different available wireless networks.

My network has the essid and correct key listed in the "Known Networks" section. My problem is that under "Status" the network is identified by the correct essid; IP:---.---.---.--- (that's what is listed, I would love to have an IP to hide!!!); Gateway: (no MAC or IP listed, just blank); Mode: Managed (This was the default when I set it up); Encryption: off (Under "Set up a new network interface" I have set this device up to enable WPA but the check box is unchecked the next time I open it); Signal:-

Doing an iwconfig ath0 results in the gateway's mac showing up as 00.00.00.00.00.00 and encryption off.

I guess what I'm seeing is that the system cannot connect to the gateway. If I go to another computer in my network and check for the MAC address of my laptop when it's booted in Linux, it doesn't appear (Under the router's web based setup program). When I boot the laptop into WinXP it does show. For some reason, under Linux, the system won't recognize the WPA key. I have followed instructions from both the SourceForge MadWiFi README and from a site that claims to have gotten the Atheros chipset working with WPA (http://www.munhousing.ca/a60linux.php).

I noticed during boot up that when the system attempts to start the ath0 connection, it takes a long time and finally gives an ath0: 9 device with an off the wall IP address that looks like what Windows would do when it has no connection (the 169.whatever ip).

Are there any ideas on how to set the encryption on for this device and have it recognize my router (Linksys BEFW11S4 ver.4)

I did an "iwlist ath0 scan" and it showed all the wireless access points my card was finding. For my router it showed the proper essid, MAC, mode was MASTER, encryption "on" but the key displayed was not my key.

I should note that I have a 20 digit key (recommended by some web site). Could the key itself be the problem?

Last edited by mrmcctt; 08-06-2005 at 12:34 PM.
 
Old 08-06-2005, 03:53 PM   #3
mrmcctt
Member
 
Registered: Oct 2004
Posts: 54

Original Poster
Rep: Reputation: 15
Anybody got an idea here? All I need to do is connect to the router. I thinkI've got the rest.
 
Old 08-06-2005, 11:31 PM   #4
deww
LQ Newbie
 
Registered: Aug 2005
Posts: 5

Rep: Reputation: 0
Make sure your ESSID matches. It is case sensitive. That is something that has caught me off guard before. You can run wpa_supplicant in verbose mode to see what it is doing, like attempting to associate with your route r.
 
Old 08-07-2005, 01:22 AM   #5
firecat53
LQ Newbie
 
Registered: Jun 2004
Location: Sammamish, WA USA
Distribution: Ubuntu (Hoary), Knoppix Live
Posts: 16

Rep: Reputation: 0
1. Try the wpa_passphrase program to generate your passphrase.
2. Ensure you have a wpa_supplicant.conf file. There are various settings within that you can tweak.
3. Try running wpa_supplicant with and without the -w flag.
4. Run wpa_supplicant without the -B flag (so it runs in the foreground) and with the -dd flag for maximum output to get a better idea of what's wrong.
5. Try downloading and compiling the latest version of wpa_supplicant.

Good luck!
 
Old 08-07-2005, 10:52 AM   #6
mrmcctt
Member
 
Registered: Oct 2004
Posts: 54

Original Poster
Rep: Reputation: 15
I take it these are all part of the wpa_supplicant program? If they are, then I really need to find more documentation for the wpa_supplicant program (or maybe read it as I think all I read was documentation for the MadWiFi driver).

At any rate, thank you very much. I'll look into these and let you know the outcome.
 
Old 08-07-2005, 02:17 PM   #7
mrmcctt
Member
 
Registered: Oct 2004
Posts: 54

Original Poster
Rep: Reputation: 15
Well.....

After reading the wpa_supplicant readme, this is what my wpa_supplicant.conf (under /etc) looks like:

network={
ssid="xxxxxxx"
proto=WPA
key_mgmt=WPA-PSK
pairwise=TKIP
group=TKIP
psk="xxxxxxxxxxxxxxxxxxxx"
priority=2

The ssid and the psk are the same as they are entered in the router. Basically what I am looking at is no signal being received from any of the wireless access points in my area (both secured and unsecured). I stand at a loss as to what to try next.

By looking at the file above, any suggestions? I did gat what I believe is the latest wpa_supplicant file.
 
Old 08-07-2005, 03:19 PM   #8
firecat53
LQ Newbie
 
Registered: Jun 2004
Location: Sammamish, WA USA
Distribution: Ubuntu (Hoary), Knoppix Live
Posts: 16

Rep: Reputation: 0
I guess I should've asked first....did you get the card working without any encryption? That would be the first step...Make sure it's not a driver issue first!
 
Old 08-07-2005, 03:48 PM   #9
mrmcctt
Member
 
Registered: Oct 2004
Posts: 54

Original Poster
Rep: Reputation: 15
That's ok..........

No I haven't.

As I posted earlier, the card is recognized at boot (although I get the ath0:9 claiming address 127.255.255.255 message).

None of the routers in my area (secured or unsecured) show any signal strength. Linux shows several unsecured (5) and my secured router. All have no signal strength. I can see them but cannot connect to any. I ran the wpa_supplicant and get "no essid configured" if that helps.

Could ndiswrapper work for the Atheros chipset? I've read mixed reviews on this.
 
Old 08-07-2005, 06:20 PM   #10
firecat53
LQ Newbie
 
Registered: Jun 2004
Location: Sammamish, WA USA
Distribution: Ubuntu (Hoary), Knoppix Live
Posts: 16

Rep: Reputation: 0
Here's what I'd suggest (keep in mind, I did this under Ubuntu, not Mandriva, but I imagine it should work similarly):

0. Remove the old madwifi drivers
1. Download the latest madwifi source code from their homepage or CVS
2. Get the headers for your kernel from whatever repositories are associated with Mandriva (via apt-get or synaptic or ???).
3. Read the README and installation files from the madwifi file. Make sure you meet all the other prerequisites if there are any.
4. Compile the source (make clean, make)
5. Follow the instructions for installing to the proper location.
6. sudo modprobe ath_pci -- make sure there's no errors. This loads the driver modules. You can usually tell if you put something in the wrong place based on the errors you receive. Move things around if you need to. Type iwconfig to make sure the wireless card is visible.
7. Find an unencrypted wireless connection.
8. sudo ifconfig ath0 up (ath0 is the default for madiwif, I believe)
9. sudo iwconfig ath0 essid NetworkName
10. sudo dhclient ath0

I'm pretty new at this, too!! Some of the steps aren't very detailed, I know! There are a couple of good how-to's in the Ubuntu wiki and forums. Good luck!

Scott
 
Old 08-09-2005, 01:22 AM   #11
mrmcctt
Member
 
Registered: Oct 2004
Posts: 54

Original Poster
Rep: Reputation: 15
OK. Here's what I did...

1. Clean install of Mandriva.
2. On first boot, applied all updates, bug fixes, security patches
3. Set up URPMI at Easy URPMI
4. URPMI kernel-source
5. URPMI madwifi (this gets placed in my home folder)
6. cd to home folder/madwifi directory in terminal logged in as "su"
7. Ran "Make Clean"
8. Ran "Make"
9. Ran "Make Install"
10. Reboot
11. URPMI wpa_supplicant

Now the system won't even recognize the wireless card.

Doing an lspci it shows the card.

If I do an 'ifconfig ath0 up' I get a "No such device message"
Same for 'iwconfig ath0'

If I do a 'modprobe ath-pci' I get 3 warnings and one fatal message stating that ath_hal.ko, wlan.ko, ath_rate_sample.ko and ath_pci.ko are invalid module format.

If I run the wpa_supplicant with the -dd, or any other option/driver I just get a list of drivers and options with the No networks (SSID) configured.

If I go to the Mandrake Linux Control Center and try to establish a new wireless connection I get this message 'insmod'ing module ath_pci failed at /usr/lib/libDrakx/modules.pm line 66.

Looks like I'm worse off now than I was before. At least before I could see the card. (No blame intended to anyone as I do appreciate the help).

I guess it's late and I'll sleep on this. If nothing new here tomorrow, I'll try a fresh install and just do the madwifi setup like I did before so I can at least see the card and try again.

 
Old 08-09-2005, 02:30 AM   #12
firecat53
LQ Newbie
 
Registered: Jun 2004
Location: Sammamish, WA USA
Distribution: Ubuntu (Hoary), Knoppix Live
Posts: 16

Rep: Reputation: 0
Sorry it's not working out for you!! Wish I could help you out more!

Couple more things to think about:

1. Actually download the madiwif source code via CVS so you get the latest version. The versions in the repositories can be behind enough to cause problems. The madwifi version from the Ubuntu repositories didn't work for me!

2. Is Mandriva a 2.4.x kernel or 2.6.x? I've got it working on 2.6.10 and 2.6.11.

3. There should have been roughly 8 or nine *.ko files generated by the make command. ath_pci,ath_hal,ath_rate_sample (I think...I'm doing this from memory), wlan, wlan_wep,wlan_tkip,wlan_xauth,wlan_acl,wlan_ccmp. These get put into (in Ubuntu, at least) the /lib/modules/2.6.11-1-686/kernel/drivers/net/wireless directory. When I did it for the 2.6.10 i386 kernel, each ath_*.ko was in a separate directory, and all the wlan*.ko were in one directory. That tripped me up at first.

4. Don't add on the wpa supplicant until after you get the driver working unencrypted and with WEP!!

Scott
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
madwifi/ndiswrapper on Atheros AR5004G biggjimmy7 Linux - Wireless Networking 7 01-05-2008 01:11 PM
atheros madwifi install problem k4ution Linux - Wireless Networking 3 11-05-2005 05:54 PM
madwifi - atheros - and WPA-PSK , anyone? dimgr Linux - Wireless Networking 1 07-05-2005 06:24 AM
Need help with Madwifi/Atheros on Slack10.1 d4m Linux - Wireless Networking 1 06-26-2005 11:01 AM
Atheros AR5004G and madwifi/ndiswrapper biggjimmy7 Linux - Wireless Networking 1 05-03-2005 03:17 PM


All times are GMT -5. The time now is 03:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration