LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   ASUS U56E-BAL7 Wireless authentication not working (http://www.linuxquestions.org/questions/linux-wireless-networking-41/asus-u56e-bal7-wireless-authentication-not-working-932897/)

wfischer 03-05-2012 06:08 PM

ASUS U56E-BAL7 Wireless authentication not working
 
Hello.I just purchased an ASUS U56E-BAL7

This is a newer model that seems to be a BestBuy exclusive (yes I am not afraid to admit that). It is actually a great PC. I love it. Only thing is, Linux seems not to like the wireless card, and I really want to run Linux as my primary OS.

The symptoms: When I boot into any Live distribution (in this case Ubuntu), the PC sees the various SSIDs in the ether around my home, but the little wifi LED on the actual PC case is not illuminated as it is when I boot into Windows 7.

Back to the OS - so when I click on my home SSID under Ubuntu, I am prompted to authenticate, which I do, and it just hangs. After a few long moments, it prompts me to authenticate again. I am pasting lspci, dmesg and syslog messages below in the hopes that someone can assist.

Many thanks!

================
lspci
================

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1d.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
02:00.0 Network controller: Intel Corporation Centrino Wireless-N + WiMAX 6150 (rev 67)
03:00.0 USB Controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
04:00.0 Ethernet controller: Atheros Communications AR8151 v2.0 Gigabit Ethernet (rev c0)

================
/var/log/syslog
================

. . . . output truncated

Mar 5 17:58:57 ubuntu ntfs-3g[5792]: Global ownership and permissions enforced, configuration type 7
Mar 5 18:01:13 ubuntu NetworkManager[2529]: <info> Activation (wlan0) starting connection 'MYSSID'
Mar 5 18:01:13 ubuntu NetworkManager[2529]: <info> (wlan0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
Mar 5 18:01:13 ubuntu NetworkManager[2529]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Mar 5 18:01:13 ubuntu NetworkManager[2529]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Mar 5 18:01:13 ubuntu NetworkManager[2529]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Mar 5 18:01:13 ubuntu NetworkManager[2529]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Mar 5 18:01:13 ubuntu NetworkManager[2529]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Mar 5 18:01:13 ubuntu NetworkManager[2529]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
Mar 5 18:01:13 ubuntu NetworkManager[2529]: <info> Activation (wlan0/wireless): access point 'MYSSID' has security, but secrets are required.
Mar 5 18:01:13 ubuntu NetworkManager[2529]: <info> (wlan0): device state change: config -> need-auth (reason 'none') [50 60 0]
Mar 5 18:01:13 ubuntu NetworkManager[2529]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Mar 5 18:01:24 ubuntu NetworkManager[2529]: get_secret_flags: assertion `is_secret_prop (setting, secret_name, error)' failed
Mar 5 18:01:24 ubuntu NetworkManager[2529]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Mar 5 18:01:24 ubuntu NetworkManager[2529]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Mar 5 18:01:24 ubuntu NetworkManager[2529]: <info> (wlan0): device state change: need-auth -> prepare (reason 'none') [60 40 0]
Mar 5 18:01:24 ubuntu NetworkManager[2529]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Mar 5 18:01:24 ubuntu NetworkManager[2529]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Mar 5 18:01:24 ubuntu NetworkManager[2529]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Mar 5 18:01:24 ubuntu NetworkManager[2529]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
Mar 5 18:01:24 ubuntu NetworkManager[2529]: <info> Activation (wlan0/wireless): connection 'MYSSID' has security, and secrets exist. No new secrets needed.
Mar 5 18:01:24 ubuntu NetworkManager[2529]: <info> Config: added 'ssid' value 'MYSSID'
Mar 5 18:01:24 ubuntu NetworkManager[2529]: <info> Config: added 'scan_ssid' value '1'
Mar 5 18:01:24 ubuntu NetworkManager[2529]: <info> Config: added 'key_mgmt' value 'WPA-PSK'
Mar 5 18:01:24 ubuntu NetworkManager[2529]: <info> Config: added 'auth_alg' value 'OPEN'
Mar 5 18:01:24 ubuntu NetworkManager[2529]: <info> Config: added 'psk' value '<omitted>'
Mar 5 18:01:24 ubuntu NetworkManager[2529]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Mar 5 18:01:24 ubuntu NetworkManager[2529]: <info> Config: set interface ap_scan to 1
Mar 5 18:01:24 ubuntu NetworkManager[2529]: <info> (wlan0): supplicant interface state: inactive -> scanning
Mar 5 18:01:31 ubuntu wpa_supplicant[3281]: Trying to authenticate with 00:1a:70:**:**:** (SSID='MYSSID' freq=2447 MHz)
Mar 5 18:01:31 ubuntu kernel: [ 268.338847] wlan0: direct probe to 00:1a:70:**:**:** (try 1/3)
Mar 5 18:01:31 ubuntu NetworkManager[2529]: <info> (wlan0): supplicant interface state: scanning -> authenticating
Mar 5 18:01:31 ubuntu kernel: [ 268.537346] wlan0: direct probe to 00:1a:70:**:**:** (try 2/3)
Mar 5 18:01:31 ubuntu kernel: [ 268.741034] wlan0: direct probe to 00:1a:70:**:**:** (try 3/3)
Mar 5 18:01:31 ubuntu kernel: [ 268.940811] wlan0: direct probe to 00:1a:70:**:**:** timed out
Mar 5 18:01:33 ubuntu kernel: [ 270.978153] iwlagn 0000:02:00.0: fail to flush all tx fifo queues
Mar 5 18:01:39 ubuntu wpa_supplicant[3281]: Trying to authenticate with 00:1a:70:**:**:** (SSID='MYSSID' freq=2447 MHz)
Mar 5 18:01:39 ubuntu kernel: [ 276.599758] wlan0: direct probe to 00:1a:70:**:**:** (try 1/3)
Mar 5 18:01:39 ubuntu kernel: [ 276.798613] wlan0: direct probe to 00:1a:70:**:**:** (try 2/3)
Mar 5 18:01:39 ubuntu kernel: [ 276.998351] wlan0: direct probe to 00:1a:70:**:**:** (try 3/3)
Mar 5 18:01:40 ubuntu kernel: [ 277.198127] wlan0: direct probe to 00:1a:70:**:**:** timed out
Mar 5 18:01:42 ubuntu kernel: [ 279.247467] iwlagn 0000:02:00.0: fail to flush all tx fifo queues
Mar 5 18:01:59 ubuntu wpa_supplicant[3281]: Trying to authenticate with 00:1a:70:**:**:** (SSID='MYSSID' freq=2447 MHz)
Mar 5 18:01:59 ubuntu kernel: [ 296.154060] wlan0: direct probe to 00:1a:70:**:**:** (try 1/3)
Mar 5 18:01:59 ubuntu kernel: [ 296.353313] wlan0: direct probe to 00:1a:70:**:**:** (try 2/3)
Mar 5 18:01:59 ubuntu kernel: [ 296.553077] wlan0: direct probe to 00:1a:70:**:**:** (try 3/3)
Mar 5 18:01:59 ubuntu kernel: [ 296.752789] wlan0: direct probe to 00:1a:70:**:**:** timed out
Mar 5 18:02:01 ubuntu kernel: [ 298.822119] iwlagn 0000:02:00.0: fail to flush all tx fifo queues
Mar 5 18:02:02 ubuntu kernel: [ 299.621073] [Hardware Error]: Machine check events logged
Mar 5 18:02:07 ubuntu wpa_supplicant[3281]: Trying to authenticate with 00:1a:70:**:**:** (SSID='MYSSID' freq=2447 MHz)
Mar 5 18:02:07 ubuntu kernel: [ 304.439679] wlan0: direct probe to 00:1a:70:**:**:** (try 1/3)
Mar 5 18:02:07 ubuntu kernel: [ 304.638592] wlan0: direct probe to 00:1a:70:**:**:** (try 2/3)
Mar 5 18:02:07 ubuntu kernel: [ 304.838331] wlan0: direct probe to 00:1a:70:**:**:** (try 3/3)
Mar 5 18:02:08 ubuntu kernel: [ 305.038119] wlan0: direct probe to 00:1a:70:**:**:** timed out
Mar 5 18:02:10 ubuntu kernel: [ 307.111399] iwlagn 0000:02:00.0: fail to flush all tx fifo queues
Mar 5 18:02:15 ubuntu wpa_supplicant[3281]: Trying to authenticate with 00:1a:70:**:**:** (SSID='MYSSID' freq=2447 MHz)
Mar 5 18:02:15 ubuntu kernel: [ 312.701025] wlan0: direct probe to 00:1a:70:**:**:** (try 1/3)
Mar 5 18:02:15 ubuntu kernel: [ 312.899927] wlan0: direct probe to 00:1a:70:**:**:** (try 2/3)
Mar 5 18:02:16 ubuntu kernel: [ 313.099644] wlan0: direct probe to 00:1a:70:**:**:** (try 3/3)
Mar 5 18:02:16 ubuntu kernel: [ 313.299380] wlan0: direct probe to 00:1a:70:**:**:** timed out


======
dmesg
======

. . . . output truncated

[ 79.726506] CPU2: Package power limit notification (total events = 1)
[ 79.726510] CPU3: Package power limit notification (total events = 1)
[ 79.726513] CPU1: Package power limit notification (total events = 1)
[ 79.737510] CPU1: Package power limit normal
[ 79.737518] CPU3: Package power limit normal
[ 79.737522] CPU0: Package power limit normal
[ 79.737526] CPU2: Package power limit normal
[ 268.338847] wlan0: direct probe to 00:1a:70:**:**:** (try 1/3)
[ 268.537346] wlan0: direct probe to 00:1a:70:**:**:** (try 2/3)
[ 268.741034] wlan0: direct probe to 00:1a:70:**:**:** (try 3/3)
[ 268.940811] wlan0: direct probe to 00:1a:70:**:**:** timed out
[ 270.978153] iwlagn 0000:02:00.0: fail to flush all tx fifo queues
[ 276.599758] wlan0: direct probe to 00:1a:70:**:**:** (try 1/3)
[ 276.798613] wlan0: direct probe to 00:1a:70:**:**:** (try 2/3)
[ 276.998351] wlan0: direct probe to 00:1a:70:**:**:** (try 3/3)
[ 277.198127] wlan0: direct probe to 00:1a:70:**:**:** timed out
[ 279.247467] iwlagn 0000:02:00.0: fail to flush all tx fifo queues
[ 296.154060] wlan0: direct probe to 00:1a:70:**:**:** (try 1/3)
[ 296.353313] wlan0: direct probe to 00:1a:70:**:**:** (try 2/3)
[ 296.553077] wlan0: direct probe to 00:1a:70:**:**:** (try 3/3)
[ 296.752789] wlan0: direct probe to 00:1a:70:**:**:** timed out
[ 298.822119] iwlagn 0000:02:00.0: fail to flush all tx fifo queues
[ 299.621073] [Hardware Error]: Machine check events logged
[ 304.439679] wlan0: direct probe to 00:1a:70:**:**:** (try 1/3)
[ 304.638592] wlan0: direct probe to 00:1a:70:**:**:** (try 2/3)
[ 304.838331] wlan0: direct probe to 00:1a:70:**:**:** (try 3/3)
[ 305.038119] wlan0: direct probe to 00:1a:70:**:**:** timed out
[ 307.111399] iwlagn 0000:02:00.0: fail to flush all tx fifo queues
[ 312.701025] wlan0: direct probe to 00:1a:70:**:**:** (try 1/3)
[ 312.899927] wlan0: direct probe to 00:1a:70:**:**:** (try 2/3)
[ 313.099644] wlan0: direct probe to 00:1a:70:**:**:** (try 3/3)
[ 313.299380] wlan0: direct probe to 00:1a:70:**:**:** timed out
[ 315.336764] iwlagn 0000:02:00.0: fail to flush all tx fifo queues
[ 321.003358] wlan0: direct probe to 00:1a:70:**:**:** (try 1/3)
[ 321.201172] wlan0: direct probe to 00:1a:70:**:**:** (try 2/3)
[ 321.400912] wlan0: direct probe to 00:1a:70:**:**:** (try 3/3)
[ 321.600644] wlan0: direct probe to 00:1a:70:**:**:** timed out
[ 323.610035] iwlagn 0000:02:00.0: fail to flush all tx fifo queues

wfischer 03-05-2012 06:24 PM

Resolved
 
Soon after posting this. I found the solution here:

https://bugs.launchpad.net/ubuntu/+s...ux/+bug/876147

Note: 'iwlagn' becomes 'iwlwifi' on kernel >=3.1
For those that did not read the upstream bug, the fix for this issue is to:

sudo modprobe -r iwlagn
sudo modprobe iwlagn bt_coex_active=0

To make the change permanent:
gsku gedit /etc/modprobe.d/iwl.conf

Copy/paste this line into the new file:
options iwlagn bt_coex_active=0

InstantN00dles 03-15-2012 06:21 AM

I noticed after following this, that I am not able to put any card I plug into my machine into monitor mode. Has anyone else run across this issue?

*Update - Apparently this is because the program I used to put the card into Monitor mode (airmon-ng) does not play well with new chipsets
http://www.backtrack-linux.org/forum...ad.php?t=45039

instead of
Quote:

airmon-ng start wlan0
you have to use
Quote:

ifconfig wlan0 down
iwconfig wlan0 mode Monitor
ifconfig wlan0 up
Surprising that it works off the live distro :-\


All times are GMT -5. The time now is 02:17 PM.