LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 08-05-2005, 12:24 AM   #1
accessrichard
Member
 
Registered: Apr 2005
Distribution: Fedora Core (latest version)
Posts: 156

Rep: Reputation: 30
amd64 and broadcom


Hi I am using

Linux localhost.localdomain 2.6.12-1.1398_FC4 #1 Fri Jul 15 00:51:38 EDT 2005 x86_64 x86_64 x86_64 GNU/Linux

and trying to get my broadcom integrated wlan B/G.

The windows driver from the original XP installation is the bcmwl5.inf driver so I figured that
the netbc564 linuxant amd64 wireless driver worked.

lspci indicate

05:02.0 Network controller: Broadcom Corporation: Unknown device 4318 (rev 02)

I installed ndiswraper 1.2


# ndiswrapper -i netbc564.inf
Installing netbc564
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2

and dmesg indicates doesnt indicate anything

when i modprobe ndiswrapper i dont get any errors in dmesg.

lsmod indicates ndiswrapper is loaded and ndiswrapper -l indicates netbc564 is loaded.


Shouldnt this amd64 bit driver work?

What am I doing wrong?

Last edited by accessrichard; 10-23-2005 at 12:41 AM.
 
Old 08-07-2005, 01:11 PM   #2
accessrichard
Member
 
Registered: Apr 2005
Distribution: Fedora Core (latest version)
Posts: 156

Original Poster
Rep: Reputation: 30
Just an update,


I believe the problem that I am having is that the netbc564 driver from linuxant isnt working with my card for some reason which doesn make sense.

When I do an ndiswrapper -l it says driver present and doesnt say anything about hardware which in the past i thought was an indication that the wrong driver was used.

Since this is the only driver I could find for broadcom on amd64 I dont know what to do now, I know others with broadcom cards and amd64 got theirs to work.

Any suggestsions?

Last edited by accessrichard; 10-23-2005 at 12:40 AM.
 
Old 08-08-2005, 02:34 PM   #3
seishi
LQ Newbie
 
Registered: Aug 2005
Location: Greenbelt, MD
Distribution: Mandrake LE 10.2
Posts: 1

Rep: Reputation: 0
I have a similar issue. I was just wondering which Broadcom card are you using? I still haven't gotten the problem completely solved. I was looking at this and everything went fine until I get to "dmesg | grep wlan" and nothing happens. Also when I run iwlist and I have lo, eth0, eth1 and sat0 only. No wlan. For the connections listed, there is no wireless connection.

Almost forgot, running Mandrake LE 10.2 on a m6805 eMachines laptop.

Last edited by seishi; 08-08-2005 at 02:36 PM.
 
Old 08-08-2005, 09:42 PM   #4
accessrichard
Member
 
Registered: Apr 2005
Distribution: Fedora Core (latest version)
Posts: 156

Original Poster
Rep: Reputation: 30
Well, I believe my problem is due to not having the amd64 bcmwl5 driver. The one that is said to work for all broadcom cards on amd64 does not work for me.

I find the bcmwl5 and bcmwl5a drivers on my windows partition.


Well if you installed madrake x86_64 then this guy says it doesnt work
http://skreak.com/m6805/

and this guy says it does and provides a driver

http://greg.primate.net/m6805/

I am guessing that in your search you probably ran into these links. If you didnt give the second link a shot and let me know.
 
Old 10-23-2005, 12:39 AM   #5
accessrichard
Member
 
Registered: Apr 2005
Distribution: Fedora Core (latest version)
Posts: 156

Original Poster
Rep: Reputation: 30
Acer now has the drivers for this wireless card. They are located at

http://www.acerpanam.com/synapse/for...oadcom&pupv=pu

If that link doesn't work search for broadcom and there should be one x64 link for a Acer Ferrari 400 driver.

ATTENTION: This driver did not work with ndiswrapper 1.4 so I had to use 1.3.

Last edited by accessrichard; 02-20-2006 at 03:11 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Difference between amd64 generic and amd64 k8? halfpower Linux - General 6 09-07-2006 06:28 PM
Why is my Broadcom NIC ignored? edrea Linux - Networking 4 06-20-2005 05:46 PM
broadcom wi-fi nasht Linux - Hardware 3 02-24-2005 04:10 PM
Broadcom Wifi spaaarky21 Fedora 8 01-01-2005 12:19 PM
Broadcom on RH 9 danikonig Linux - Hardware 1 04-15-2003 09:13 AM


All times are GMT -5. The time now is 12:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration