LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 09-01-2005, 04:51 PM   #1
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 545

Rep: Reputation: 30
Access problems with Intel PRO/Wireless 2200


I've been having trouble with the embedded wireless card in my laptop. I run Ubuntu Hoary and here are the laptop specs:

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Inspiron 9300 Intel® Pentium® M Processor 730 (1.60 GHz/2MB Cache/533MHz FSB)
Display 17 inch UltraSharp Wide Screen XGA+ Display 17XGA
Memory 512MB Dual Channel DDR2 SDRAM at 533MHz 2 Dimm
Video Card 256MB NVIDA® GeForce Go 6800
Hard Drive 100GB Hard Drive
Network Card Integrated 10/100 Network Card and Modem
CD/DVD Drives 8X Max DVD ROM Drive
Wireless Networking Card Intel® PRO/Wireless 2200 Internal Wireless (802.11 b/g, 54Mbps)
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<


I've gotten this card to work before (although not very well) on my father's wireless network (which used a LinkSys router). Now I'm trying to use the network at UT and I set everything up properly (and checked it twice), and I get 0 signal strength. I borrowed a Linksys Orinoco Gold 802.11b PCMCIA from my labmate and everything works perfectly.


I have no idea what's up with this. Does the embedded Intel wireless just suck or not have good Linux drivers for it? Here's the output of ifconfig and iwconfig when I'm connected with the PCMCIA card. (eth0 = wired network, eth1 = intel embedded wireless, eth2= PCMCIA wireless)

ifconfig
Code:
eth1      Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:1
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:17 Base address:0xc000 Memory:dcffd000-dcffdfff

eth2      Link encap:Ethernet  HWaddr 00:02:2D:61:F8:E0
          inet addr:128.62.89.255  Bcast:128.62.91.255  Mask:255.255.252.0
          inet6 addr: fe80::202:2dff:fe61:f8e0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4530 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3948 errors:3 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3567245 (3.4 MiB)  TX bytes:548745 (535.8 KiB)
          Interrupt:3 Base address:0x100

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:504 (504.0 b)  TX bytes:504 (504.0 b)
iwconfig
Code:
eth1      unassociated  ESSID:"utexas"
          Mode:Managed  Channel=0  Access Point: 00:00:00:00:00:00
          Bit Rate=0 kb/s   Tx-Power=off
          RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth2      IEEE 802.11-DS  ESSID:"utexas"  Nickname:"HERMES I"
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:13:19:C4:11:40
          Bit Rate:11 Mb/s   Tx-Power=15 dBm   Sensitivity:1/3
          Retry limit:4   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=19/92  Signal level=-74 dBm  Noise level=-93 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:12
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Does anyone know what could be wrong here?
 
Old 09-01-2005, 05:18 PM   #2
mimithebrain
Member
 
Registered: Nov 2003
Location: ~
Distribution: Ubuntu 10.04
Posts: 843
Blog Entries: 1

Rep: Reputation: 30
Have you noticed that eth1 reports "unassociated"?
My card reports IEEE 802.11
You Tx-power is set to off, therefore, I would be led to believe you radio is off...

try entering
iwconfig eth1 txpower auto
as root
 
Old 09-02-2005, 01:10 PM   #3
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 545

Original Poster
Rep: Reputation: 30
Thanks. I'm a neophyte when it comes to wireless by the way.

Code:
root@tate:/home/olsen # iwconfig eth1 txpower auto
Error for wireless request "Set Tx Power" (8B26) :
    SET failed on device eth1 ; Input/output error.
 
Old 09-03-2005, 09:16 AM   #4
mlomker
Member
 
Registered: Aug 2005
Location: Saint Paul, MN
Distribution: Kubuntu
Posts: 34

Rep: Reputation: 15
Does your laptop have a button for turning on the wireless card? Mine has one just to the left of the power button, for example.
 
Old 09-03-2005, 10:46 AM   #5
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 545

Original Poster
Rep: Reputation: 30
It does using one of the Fn+ key combinations, but from what I've read about other people with this laptop it doesn't seem to work. I think I might have found the problem though. The card requires the external ipw2200 driver and I may need to do modprobe ipw2200 before it will work correctly. I will test this next time I'm on campus and if it works (or doesn't work) I will report back here. Thanks.
 
Old 09-06-2005, 02:00 PM   #6
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 545

Original Poster
Rep: Reputation: 30
Unfortunately, when I typed lsmod right after booting, I found that ipw2200 module is already loaded. So I'm back to square one. I found the following link though, so maybe I'll be able to get it working after I read through this site.

http://ipw2200.sourceforge.net/
 
Old 09-06-2005, 05:23 PM   #7
mlomker
Member
 
Registered: Aug 2005
Location: Saint Paul, MN
Distribution: Kubuntu
Posts: 34

Rep: Reputation: 15
Quote:
Originally posted by R00ts http://ipw2200.sourceforge.net/ [/B]
Yeah, for some reason the drivers that came with Hoary don't work out of the box. The error that I got in dmesg is a 'transmitting' error that went on forever. I followed those docs and the newly compiled driver works fine. I get a few spurious errors in dmesg but I'm not worrying about it.

You'll need to compile the ieee driver, the 2200 driver, and then copy the firmware files to /lib/hotplug/firmware.

If you want to unload the existing bad driver then rmmod is the command for that.
 
Old 09-07-2005, 04:40 PM   #8
Yoko
LQ Newbie
 
Registered: Oct 2004
Posts: 24

Rep: Reputation: 15
I' m using also Intel® PRO/Wireless 2200 BG, and just also needed to check, how to get the card working. I'm not using Debian, but maybe the following can help you. I got my card working with WEP encryption, but I didn't check WPA.

Check, if the kernel has been compiled with the following options:
- general:
CONFIG_NET_RADIO=y
CONFIG_FW_LOADER=m
- for WEP encryption:
CONFIG_CRYPTO=y
CONFIG_CRYPTO_ARC4=m
CONFIG_CRC32=m
- for WPA support:
CONFIG_CRYPTO_MICHAEL_MIC=m
CONFIG_CRYPTO_AES_586=m

Check, if the the following modules are loaded:
- in general:
ipw2200
firmware_class
iee80211
cls_fw
- for WEP encryption:
arc4
crc32c
- for WPA support:
aes-i586 ?
michael_mic ?

Check, if you have the following firmware files in /etc/firmware or /usr/lib/hotplug/firmware:
ipw-2.2-boot.fw
ipw-2.2-bss.fw
ipw-2.2-bss_ucode.fw
ipw-2.2-ibss.fw
ipw-2.2-ibbs_ucode.fw

Check, if you have hotplug-scripts like /etc/hotplug/firmware.agent

Set the appropriate settings with iwconfig. In my case I only set my essid and my WEP key. You should be able to associate with the access point know, else check, if the radio is turned on. If iwconfig shows Tx-Power=off, then it is either off or something else is wrong.

Set the appropriate settings for card startup and start it. In my case I added the line "iface eth0 inet dhcp" to /etc/network/interfaces and started the card with ifup eth0.

Last edited by Yoko; 09-07-2005 at 04:52 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DISCUSSION: Intel Pro Wireless 2200 + Slackware LinuxAnswers Discussion 1 08-25-2007 09:09 AM
Intel Pro Wireless 2200 lokirulez Linux - Hardware 7 12-05-2005 06:48 PM
firmware -> Intel PRO/Wireless 2200 flyingman Linux - Newbie 12 09-16-2005 03:49 AM
intel wireless pro 2200 detected as atheros wireless card? whf Suse/Novell 5 08-29-2005 06:04 PM
intel pro wireless 2200 bg HELP dhaman3 Linux - Wireless Networking 4 05-13-2005 12:32 PM


All times are GMT -5. The time now is 04:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration