LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Virtualization and Cloud (http://www.linuxquestions.org/questions/linux-virtualization-and-cloud-90/)
-   -   xend.err "Error creating domain: Boot loader didn't return any data!" (http://www.linuxquestions.org/questions/linux-virtualization-and-cloud-90/xend-err-error-creating-domain-boot-loader-didnt-return-any-data-761972/)

mhgee 10-14-2009 10:31 PM

xend.err "Error creating domain: Boot loader didn't return any data!"
 
Hi,

I am using Centos.

All the while my Xen VM is working fine. Then today it can not run.

This is the error message that it shows: -


Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/engine.py", line 514, in run_domain
vm.startup()
File "/usr/share/virt-manager/virtManager/domain.py", line 379, in startup
self.vm.create()
File "/usr/lib/python2.4/site-packages/libvirt.py", line 228, in create
if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: virDomainCreate() failed POST operation failed: (xend.err "Error creating domain: Boot loader didn't return any data!")


Please help.


Thanks
mhgee

mhgee 10-15-2009 03:50 AM

xend.err "Error creating domain: Boot loader didn't return any data!"
 
Error starting domain: virDomainCreate() failed POST operation failed: (xend.err "Error creating domain: Boot loader didn't return any data!")

Details: -

Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/engine.py", line 514, in run_domain
vm.startup()
File "/usr/share/virt-manager/virtManager/domain.py", line 379, in startup
self.vm.create()
File "/usr/lib/python2.4/site-packages/libvirt.py", line 228, in create
if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: virDomainCreate() failed POST operation failed: (xend.err "Error creating domain: Boot loader didn't return any data!")


I check the /var/log/xen , this is what i found.

Normal logs:-
Error starting domain: virDomainCreate() failed POST operation failed: (xend.err "Error creating domain: Boot loader didn't return any data!")

Details: -

Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/engine.py", line 514, in run_domain
vm.startup()
File "/usr/share/virt-manager/virtManager/domain.py", line 379, in startup
self.vm.create()
File "/usr/lib/python2.4/site-packages/libvirt.py", line 228, in create
if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: virDomainCreate() failed POST operation failed: (xend.err "Error creating domain: Boot loader didn't return any data!")
------------------------------------------------------------------------

Problem logs:-

Error starting domain: virDomainCreate() failed POST operation failed: (xend.err "Error creating domain: Boot loader didn't return any data!")

Details: -

Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/engine.py", line 514, in run_domain
vm.startup()
File "/usr/share/virt-manager/virtManager/domain.py", line 379, in startup
self.vm.create()
File "/usr/lib/python2.4/site-packages/libvirt.py", line 228, in create
if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: virDomainCreate() failed POST operation failed: (xend.err "Error creating domain: Boot loader didn't return any data!")


Hope that with this much of findings your all can give me more insights on what needs to be done. Inorder to solve this VM problem.


All times are GMT -5. The time now is 02:52 AM.