LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Virtualization and Cloud
User Name
Password
Linux - Virtualization and Cloud This forum is for the discussion of all topics relating to Linux Virtualization and Linux Cloud platforms. Xen, KVM, OpenVZ, VirtualBox, VMware, Linux-VServer and all other Linux Virtualization platforms are welcome. OpenStack, CloudStack, ownCloud, Cloud Foundry, Eucalyptus, Nimbus, OpenNebula and all other Linux Cloud platforms are welcome. Note that questions relating solely to non-Linux OS's should be asked in the General forum.

Notices

Reply
 
Search this Thread
Old 09-15-2012, 01:16 PM   #1
CrAzYoNi
Member
 
Registered: Sep 2008
Posts: 36

Rep: Reputation: 0
Question Why Qemu-KVM congesting my RAM?


Hi all,
I'm using a Host Based on Fedora 17, I've installed 16GB of RAM on this machine.
This host using KVM, running 2 CentOS 6.3 systems, each virtual guest assigned 2GB of RAM.
Everything is running just fine for couple of days since a reboot... though, after a few days my host OS ram starting to fulfill.
When checking I find several qemu-kvm processes using all of my RAM, why is this?
How can I solve it?

Hope you can assist me.
Attached is a screenshot of htop output.
Attached Images
File Type: jpeg Screenshot from 2012-09-15 21:10:42.jpeg (220.2 KB, 3 views)
 
Old 09-15-2012, 02:40 PM   #2
CrAzYoNi
Member
 
Registered: Sep 2008
Posts: 36

Original Poster
Rep: Reputation: 0
Following some information I was able to retrieve using my friend Google friends...
I've set both guest OS, Virtio and IDE hard drives to work without cache - cache=none.

Hope it will solve my issue.
Will keep update this thread in couple of days.
If you got an idea also, or explanation how come the cache can eat all of my RAM (more than 10Gb) I would like to understand this kind of behavior.

Thanks in advance.
 
  


Reply

Tags
kvm, memoryleak, qemu, ram


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Set up qemu-kvm-1.0+noroms as spice enabled qemu server vs qemu-kvm-spice on Ubuntu Precise LXer Syndicated Linux News 0 05-26-2012 07:41 AM
[Debian/Qemu/KVM] Why qemu --enable-kvm works but not kvm directly? gb2312 Linux - Virtualization and Cloud 2 03-21-2011 02:05 PM
LXer: Attempt of qemu-kvm-0.14 patching via Gerds Hoffmann spice/qxl: locking fix for qemu-kvm on LXer Syndicated Linux News 0 03-14-2011 01:20 PM
Error while installing qemu (qemu-kvm-0.13.0) in rhel 5.3 birla.sunil Linux - Virtualization and Cloud 2 10-19-2010 03:56 AM
On qemu-kvm, qemu-ifup script not found on Slackware 13 AndrewGaven Linux - Virtualization and Cloud 14 01-29-2010 03:36 AM


All times are GMT -5. The time now is 03:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration