LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Virtualization and Cloud
User Name
Password
Linux - Virtualization and Cloud This forum is for the discussion of all topics relating to Linux Virtualization and Linux Cloud platforms. Xen, KVM, OpenVZ, VirtualBox, VMware, Linux-VServer and all other Linux Virtualization platforms are welcome. OpenStack, CloudStack, ownCloud, Cloud Foundry, Eucalyptus, Nimbus, OpenNebula and all other Linux Cloud platforms are welcome. Note that questions relating solely to non-Linux OS's should be asked in the General forum.

Notices

Closed Thread
 
Search this Thread
Old 04-03-2013, 10:40 AM   #1
nates1
LQ Newbie
 
Registered: Oct 2011
Location: OH -wish did not
Distribution: Slackware, Ubuntu, Smoothwall
Posts: 5

Rep: Reputation: 0
VirtualBox.so libSDL-1.2.so.0 undefined symbol _XGetRequest


After upgrading to sdl-1.2.15-x86_64-1 I get failed: /usr/lib64/libSDL-1.2.so.0: undefined symbol: _XGetRequest

Specifically when running /opt/VirtualBox/VirtualBox.so.
Whole error is:
VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/opt/VirtualBox/VirtualBox.so",) failed: /usr/lib64/libSDL-1.2.so.0: undefined symbol: _XGetRequest

Sure enough:
# objdump -T /usr/lib64/libSDL-1.2.so.0 |grep XGetRe
0000000000000000 DF *UND* 0000000000000000 _XGetRequest

sdl-1.2.15-x86_64-1.txz (from slackware64-current)
/usr/lib64/libSDL-1.2.so.0 -> libSDL-1.2.so.0.11.4 (Not work)

sdl-1.2.14-x86_64-5.txz (from slackware64-14.0)
/usr/lib64/libSDL-1.2.so.0 -> libSDL-1.2.so.0.11.3 (works)

Is sdl-1.2.15 missing something or VirtualBox.so ?
 
Old 04-04-2013, 05:55 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Please post your thread in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place. This thread is being closed because it is a duplicate.


http://www.linuxquestions.org/questi...st-4175456708/
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] libSDL-1.2.so.0.11.4 from slackware64-current "undefined symbol" _XGetRequest nates1 Slackware 2 04-08-2013 08:40 AM
recordmydesktop-0.3.8.1/src/rmd_getzpixmap.c86: undefined reference to '_XGetRequest' Denz262 Linux - Newbie 1 10-21-2012 03:14 PM
[SOLVED] symbol lookup error: /usr/sbin/httpd: undefined symbol: apr_file_link bagi Slackware 3 05-17-2011 07:49 AM
./firefox-bin :symbol lookup error:/lib/libgthread-2.0.so.0: undefined symbol: arulupsaras Linux - General 1 11-08-2008 04:48 AM
symbol lookup error: /usr/lib/libgtk-x11.2.0.so.0: undefined symbol:... IamI Slackware 17 02-29-2008 11:10 AM


All times are GMT -5. The time now is 06:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration