LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Virtualization and Cloud (http://www.linuxquestions.org/questions/linux-virtualization-and-cloud-90/)
-   -   Using Bridged Networking in VirtualBox, Fedora 18 Guest not getting an IP Address (http://www.linuxquestions.org/questions/linux-virtualization-and-cloud-90/using-bridged-networking-in-virtualbox-fedora-18-guest-not-getting-an-ip-address-4175452429/)

JockVSJock 03-02-2013 03:49 PM

Using Bridged Networking in VirtualBox, Fedora 18 Guest not getting an IP Address
 
Greetings, I'm using Windows 7 64 bit as the host, and I have the following guests:

-Fedora 18
-Ubuntu 12.04 (64 bit)

I want to get these two guests talking to each other, can ping, SSH to each other. Want to start to work on NFS along with Samba stuff too...

I've referenced VirtualBox networking online here

http://www.virtualbox.org/manual/ch06.html

However from VBManager, I've set both guests to Bridged networking and both guests have the same settings. The Ubuntu box has now the following adddress: 74.204.128.237

Checking my Fedora 18 with ifconfig -a, there is no ip address. I can ping 127.0.0.1 ok.

I'm not sure what I need to do to fix this.

thanks

273 03-02-2013 04:15 PM

You could start by making sure DHCP is configured on your Red Hat VM:
http://docs.fedoraproject.org/en-US/...ng-client.html

frankbell 03-02-2013 08:56 PM

I have found that, when you select "bridged" in VirtualBox, it's a good idea to go to the "Advanced" item directly below that. Often, several different adaptors show in the list; it may take some experimentation to find which is the correct one.

The default selection may not be the best choice.

JockVSJock 03-03-2013 09:57 AM

Quote:

Originally Posted by 273 (Post 4903328)
You could start by making sure DHCP is configured on your Red Hat VM:
http://docs.fedoraproject.org/en-US/...ng-client.html

Looks like switching from NAT to Bridged has changed the NIC from eth0 to p2p1. I don't see any entry for it under /etc/sysconfig/network-scripts.
Nor am I sure how to add it, I don't see any options to add eth0.

I've created a new thread under Fedora:

https://www.linuxquestions.org/quest...ox-4175452511/


All times are GMT -5. The time now is 05:38 AM.