LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Virtualization and Cloud (http://www.linuxquestions.org/questions/linux-virtualization-and-cloud-90/)
-   -   Slackware64 14 not detecting my x86_64 processor VirtualBox (http://www.linuxquestions.org/questions/linux-virtualization-and-cloud-90/slackware64-14-not-detecting-my-x86_64-processor-virtualbox-4175461187/)

markymort 05-08-2013 01:53 PM

Slackware64 14 not detecting my x86_64 processor VirtualBox
 
I am trying to install Slackware64 14.0 on a VM using VirtualBox. When I am trying to install the default kernel it wont install and says:

"This kernel requires an x86-64 CPU, but only detected an i686 CPU. Unable to boot - please use a kernel appropriate for your CPU."

I have an x86-64 CPU, It is an i7. I cannot figure out what the issue is, or even if it is an issue with VirtualBox or something else.

Does anyone have some experience with this or know of a solution?

Thanks

business_kid 05-08-2013 02:24 PM

What is the output of

cat /proc/cpuinfo

jkirchner 05-08-2013 02:49 PM

According to this http://www.virtualbox.org/manual/ch03.html it seems you need to set VirtualBox up with the number of cores (it seems so to me...not an expert). Did you do that part?

markymort 05-09-2013 11:32 AM

Solved
 
Thanks a lot for the help guys, I was able to get it working. I needed to enable hardware virtualization in my BIOS settings in order to install a 64bit OS on a VM.


All times are GMT -5. The time now is 11:42 PM.