LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Virtualization and Cloud
User Name
Password
Linux - Virtualization and Cloud This forum is for the discussion of all topics relating to Linux Virtualization and Linux Cloud platforms. Xen, KVM, OpenVZ, VirtualBox, VMware, Linux-VServer and all other Linux Virtualization platforms are welcome. OpenStack, CloudStack, ownCloud, Cloud Foundry, Eucalyptus, Nimbus, OpenNebula and all other Linux Cloud platforms are welcome. Note that questions relating solely to non-Linux OS's should be asked in the General forum.

Notices

Reply
 
Search this Thread
Old 12-06-2011, 03:27 PM   #1
ratotopi
Member
 
Registered: Dec 2011
Posts: 110

Rep: Reputation: 6
Problem runnig CentOS 6 GUI on VMware ESXi


Trying to run GUI of CentOS 6 on VMware ESXi I have already done yum install vmware-tools-esx-kmod vmware-tools-esx but if inittab is changed to run in level 5 it hangs and if command startx is executed the system give the message
.


X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: c6b6 2.6.32-44.2.el6.x86_64
Current Operating System: Linux 2.6.32-71.29.1.el6.x86_64 #1 SMP Mon Jun 27 19:49:27 BST 2011 x86_64
Kernel command line: ro root=/dev/mapper/vg_vanth-LogVol00 rd_LVM_LV=vg_vanth/LogVol00 rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet
Build Date: 25 June 2011 11:07:18AM
Build ID: xorg-x11-server 1.7.7-26.el6_0.3
Current version of pixman: 0.18.4
Before reporting problems, check https://www.redhat.com/apps/support/
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Dec 6 14:02:12 2011
(==) Using default built-in configuration (30 lines)
(EE) Failed to load module "vmwgfx" (module does not exist, 0)
(EE) vmware: Please ignore the above warnings about not being able to to load module/driver vmwgfx
(EE) open /dev/fb0: No such device
SELinux: Disabled on system, not enabling in X server
GNOME_KEYRING_SOCKET=/tmp/keyring-gqdOEa/socket
SSH_AUTH_SOCK=/tmp/keyring-gqdOEa/socket.ssh
GNOME_KEYRING_PID=2834

** (gnome-panel:2845): WARNING **: panel-applet-frame.c:1288: failed to load applet OAFIID:GnoteApplet:
(null)
^C
waiting for X server to shut down gnome-session: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
gnome-settings-daemon: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
error setting MTRR (base = 0xd8000000, size = 0x02000000, type = 1) Invalid argument (22)


Thank you for your input .
 
Old 12-06-2011, 04:19 PM   #2
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,758

Rep: Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643
Not sure about the naming of your packages and where they came from, but do you have the "xxx-vm-tools-common" package installed?
 
1 members found this post helpful.
Old 12-07-2011, 01:28 PM   #3
ratotopi
Member
 
Registered: Dec 2011
Posts: 110

Original Poster
Rep: Reputation: 6
thanks kbp its working now
 
Old 08-01-2012, 01:02 PM   #4
ratotopi
Member
 
Registered: Dec 2011
Posts: 110

Original Poster
Rep: Reputation: 6
if you google about the GUI problem with the VMware ESxi, this link shows up in the top so I though I need to give details about how I fixed this problem. I take for granted that Vsphere Client is working fine with the commandline on Linux Virtual Machine but the only problem is when issuing init 5 command . Here are the steps

1. rpm --import http://packages.vmware.com/tools/key...PG-DSA-KEY.pub
2. rpm --import http://packages.vmware.com/tools/key...PG-DSA-KEY.pub
3. create vmware-tools.repo edit the file /etc/yum.repos.d/vmware-tools.repo add the following lines
[vmware-Tools]
name=VMware Tools
baseurl=http://packages.vmware.com/tools/esx/5.0/rhel6/x86_64
4.yum update
5.yum install vmware-tools-esx-kmods vmware-tools-esx
6.reboot your ESXi server.
The above solutions might work for most of you but I face the problem with the mouse in GUI so this is how I solved the mouse problem in Vsphere Client. Make sure your Linux Virtual machine is power off.
1.right click on your Virtual Machine on Vsphere Client.
2.Click Edit Setting -->Hardware-->Video Card -->Video Memory Calculator. Give resolution 1024*768
3.Click on tab Options --> General --> Configuration Parameters --> Add Row
4. Add the following two lines
mouse.vusb.enable=false
vmmouse.present=false
Remember to click mouse to use GUI inside the Vsphere Client and to get out use Ctrl+Alt.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Upgrade/Migrate VMware ESX/ESXi 4.x To ESXi 5.0 LXer Syndicated Linux News 0 09-11-2011 03:10 PM
RAID card for vmware esxi, and some other esxi questions JustinHoMi Linux - Enterprise 1 06-04-2010 03:57 PM
Networking doesn't work for CentOS 5 within VMware ESXi RCbeta Linux - Networking 3 07-01-2009 11:06 AM
[SOLVED] Screen Resolution reverts when not root - CentOS guest on VMWare ESXi Sean1e Linux - Software 2 10-22-2008 11:54 AM
Samba, GUI settings wrong, RedHat - W2K, smbclient runnig good, Nautils runnig bad samuel_burg Linux - Networking 1 06-23-2004 07:54 AM


All times are GMT -5. The time now is 01:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration