LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Virtualization and Cloud (http://www.linuxquestions.org/questions/linux-virtualization-and-cloud-90/)
-   -   NetworkManager fails while installing Fedora 12 guest os (http://www.linuxquestions.org/questions/linux-virtualization-and-cloud-90/networkmanager-fails-while-installing-fedora-12-guest-os-914241/)

Ashkan_s 11-18-2011 08:16 AM

NetworkManager fails while installing Fedora 12 guest os
 
3 Attachment(s)
Hi

I'm trying to install Fedora 12 guest on a Fedora 12 host using KVM via virt-install.I want to access the guest from other hosts, so I need a network bridge. When I try to install the guest it shows a message:
Quote:

Waiting for NetworkManager to configure eth0.
After a while it shows an error message:
Quote:

There was an error configuring your network interface.
After selecting the retry button of it, another message is appeared saying that it cannot find the kickstart file, selecting the cancel button I am able to specify network configuration manually. When I set this settings manually NetworkManager is able to configure the network interface. I don't know what goes wrong when I try to install the guest using kickstart file. The file is accessible by the address specified.

Here is the configuration files and commands that I used:

network interfaces:
Quote:

cat ifcfg-eth0

# Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE]
DEVICE=eth0
HWADDR=00:0C:29:60:A0:25
ONBOOT=yes
#IPADDR=192.168.1.1
#BOOTPROTO=none
#NETMASK=255.255.255.0
#TYPE=Ethernet
NM_CONTROLLED=no
#IPV6INIT=no
#USERCTL=yes
#PREFIX=24
#NAME="System eth0"
#UUID=5fb06bd0-0bb0-7ffb-45f1-d6edd65f3e03
BRIDGE=MPM_br0
Quote:

cat ifcfg-MPM_br0

DEVICE=MPM_br0
TYPE=Bridge
BOOTPROTO=none
IPADDR=192.168.1.1
NETMASK=255.255.255.0
ONBOOT=yes
DELAY=0
NM_CONTROLLED=no
Ouput of ifconfig command:
Quote:

MPM_br0 Link encap:Ethernet HWaddr 00:0C:29:60:A0:25
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::20c:29ff:fe60:a025/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:30252 errors:0 dropped:0 overruns:0 frame:0
TX packets:84090 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1582387 (1.5 MiB) TX bytes:127203636 (121.3 MiB)

eth0 Link encap:Ethernet HWaddr 00:0C:29:60:A0:25
inet6 addr: fe80::20c:29ff:fe60:a025/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:34 errors:0 dropped:0 overruns:0 frame:0
TX packets:82 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:5983 (5.8 KiB) TX bytes:14626 (14.2 KiB)
Interrupt:19 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:11224 errors:0 dropped:0 overruns:0 frame:0
TX packets:11224 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:85107145 (81.1 MiB) TX bytes:85107145 (81.1 MiB)

virbr0 Link encap:Ethernet HWaddr 46:9A:2A:8C:7B:6A
inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:36 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:5473 (5.3 KiB)
Contents of sysctl.conf:

Quote:

cat /etc/sysctl.conf

# Kernel sysctl configuration file for Red Hat Linux
#
# For binary values, 0 is disabled, 1 is enabled. See sysctl(8) and
# sysctl.conf(5) for more details.

# Controls IP packet forwarding
net.ipv4.ip_forward = 0

# Controls source route verification
net.ipv4.conf.default.rp_filter = 1

# Do not accept source routing
net.ipv4.conf.default.accept_source_route = 0

# Controls the System Request debugging functionality of the kernel
kernel.sysrq = 0

# Controls whether core dumps will append the PID to the core filename.
# Useful for debugging multi-threaded applications.
kernel.core_uses_pid = 1

# Disable netfilter on bridges.
#net.bridge.bridge-nf-call-ip6tables = 0
#net.bridge.bridge-nf-call-iptables = 0
#net.bridge.bridge-nf-call-arptables = 0
I used the following commands and commented out the last three lines of sysctl.conf:
Quote:

iptables -I FORWARD -m physdev --physdev-is-bridged -j ACCEPT
service iptables save
service iptables restart
The virt-install command that is used:
Quote:

virt-install --name myfed12 --ram 512 --disk path=/home/images/fed12.img,size=8 --network bridge=MPM_br0 --os-type=linux --os-variant=fedora12 -l http://192.168.1.1/fedora -x ks=http://192.168.1.1/ks.cfg
The host os is also a virtual host (vmware guest).

Ashkan_s 11-18-2011 12:59 PM

SOLVED, I had forgotten to configure the dhcp server!:doh:


All times are GMT -5. The time now is 04:28 PM.