LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Virtualization and Cloud (http://www.linuxquestions.org/questions/linux-virtualization-and-cloud-90/)
-   -   LVM BACKUP + KVM : no data after mounted (http://www.linuxquestions.org/questions/linux-virtualization-and-cloud-90/lvm-backup-kvm-no-data-after-mounted-4175459744/)

chengli 04-26-2013 11:55 PM

LVM BACKUP + KVM : no data after mounted
 
Dear All,

I'm trying LVM snapshot back up for my kvm.

The following is my logical volume details:
------------------------------------------------------------------------
ACTIVE '/dev/vg_vmsvr/lv_root' [150.00 GiB] inherit
ACTIVE '/dev/vg_vmsvr/lv_home' [100.00 GiB] inherit
ACTIVE '/dev/vg_vmsvr/lv_swap' [5.84 GiB] inherit
ACTIVE Original '/dev/vg_vmsvr/vm10' [15.00 GiB] inherit
ACTIVE Snapshot '/dev/vg_vmsvr/rootsnapshot' [20.00 GiB] inherit

------------------------------------------------------------------------

I try to create snapshot for vm10 and so far anything work well but when i reach the step 5) ls -l /mnt/vg_vmsvr/rootsnapshot/ (no data inside the folder ). If i try to take snapshot of lv_root, i able to get the data inside in the folder i mounted.

1) lvcreate -L20G -s -n rootsnapshot /dev/vg_vmsvr/vm10
2) mkdir -p /mnt/vg_vmsvr/rootsnapshot
3) mkfs.ext4 /dev/vg_vmsvr/rootsnapshot
4) mount /dev/vg_vmsvr/rootsnapshot /mnt/vg_vmsvr/rootsnapshot
5) ls -l /mnt/vg_vmsvr/rootsnapshot/

Any Suggestion to troubleshoot out the issue?

Thanks


All times are GMT -5. The time now is 12:02 AM.