LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Virtualization and Cloud
User Name
Password
Linux - Virtualization and Cloud This forum is for the discussion of all topics relating to Linux Virtualization and Linux Cloud platforms. Xen, KVM, OpenVZ, VirtualBox, VMware, Linux-VServer and all other Linux Virtualization platforms are welcome. OpenStack, CloudStack, ownCloud, Cloud Foundry, Eucalyptus, Nimbus, OpenNebula and all other Linux Cloud platforms are welcome. Note that questions relating solely to non-Linux OS's should be asked in the General forum.

Notices



Reply
 
Search this Thread
Old 07-17-2013, 02:59 PM   #1
walterbyrd
Member
 
Registered: Apr 2004
Posts: 572

Rep: Reputation: 30
KVM on CentOS 6.4 (x86_64): problems configuring bridge


I am using this as my guide.

Virtualization With KVM On A CentOS 6.4 Server
http://www.howtoforge.com/virtualiza...tos-6.4-server

This is where I am having the problems (end of step 2):

Quote:
Create the file /etc/sysconfig/network-scripts/ifcfg-br0 (please use the IPADDR, PREFIX, GATEWAY, DNS1 and DNS2 values from the file); make sure you use TYPE=Bridge, not TYPE=Ethernet:

vi /etc/sysconfig/network-scripts/ifcfg-br0

Do I need to have a DNS server configured locally?
Do I need to have a static IP address?
Right now, I do not have either.

I have a /etc/sysconfig/network-scripts/ifcfg-eth0 file.
I do not have a /etc/sysconfig/network-scripts/ifcfg-eth1 file.
But my system seems to be using eth1 (see ifconfig below).

BTW: I only have one ethernet port. I am not sure where these other hardward addresses are coming from.


Code:
# ifconfig
br0       Link encap:Ethernet  HWaddr B6:C5:B3:10:5A:DA  
          inet addr:192.168.1.109  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::b4c5:b3ff:fe10:5ada/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:322 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:48926 (47.7 KiB)

eth1      Link encap:Ethernet  HWaddr 94:DE:80:2F:C5:8B  
          inet addr:192.168.1.109  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::96de:80ff:fe2f:c58b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:63958 errors:0 dropped:0 overruns:0 frame:0
          TX packets:41782 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:86165458 (82.1 MiB)  TX bytes:3891678 (3.7 MiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:270 errors:0 dropped:0 overruns:0 frame:0
          TX packets:270 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:22460 (21.9 KiB)  TX bytes:22460 (21.9 KiB)

virbr0    Link encap:Ethernet  HWaddr 52:54:00:E7:DC:BA  
          inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:145 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:23635 (23.0 KiB)

My /etc/sysconfig/network-scripts/ifcfg-eth0 file

Code:
DEVICE="eth0"
#BOOTPROTO="dhcp"
HWADDR="00:30:67:6F:7B:D1"
IPV6INIT="yes"
IPV6_AUTOCONF="yes"
NM_CONTROLLED="yes"
ONBOOT="yes"
TYPE="Ethernet"
UUID="08986b4c-ed59-41f4-b329-f08e3100af28"
BRIDGE=br0
My /etc/sysconfig/network-scripts/ifcfg-br0 file

Code:
DEVICE="br0"
NM_CONTROLLED="yes"
ONBOOT=yes
TYPE=Bridge
BOOTPROTO=none
IPADDR=192.168.1.109
PREFIX=24
GATEWAY=192.168.1.1
DNS1=75.75.75.75
DNS1=75.75.76.76
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME="System br0"
 
Old 07-18-2013, 03:03 AM   #2
Terminator3000
Member
 
Registered: Jun 2012
Distribution: Centos 6 & Fluxbox
Posts: 86

Rep: Reputation: Disabled
You need 1 eth0 file and a br0 file as in this guide to setting up a network bridge. Get rid of the superfluous eth1. You can also rename the eth files if necessary

As gradinaruvasile states below , you don't have any settings in the eth0, they are sent to br0.

Last edited by Terminator3000; 07-20-2013 at 05:33 AM. Reason: Amendment
 
1 members found this post helpful.
Old 07-20-2013, 02:39 AM   #3
gradinaruvasile
Member
 
Registered: Apr 2010
Location: Cluj, Romania
Distribution: Debian Testing
Posts: 515

Rep: Reputation: 102Reputation: 102
You have to remove all configurations from the physical device (eth1) and put all to br0. You cannot have usable network with 2 interfaces with the same ip address.
 
2 members found this post helpful.
Old 07-26-2013, 12:00 PM   #4
walterbyrd
Member
 
Registered: Apr 2004
Posts: 572

Original Poster
Rep: Reputation: 30
Thanks for all the help.

Okay, no more eth1, I fixed that. Here is what I have now.

BTW: the hardward address does not match what I get when I do an ifconfig. Also, I don't understand why I'm getting all the IPv6 stuff, I am not using IPv6.

Code:
# cat /etc/sysconfig/network-scripts/ifcfg-br0
DEVICE="br0"
NM_CONTROLLED="yes"
ONBOOT=yes
TYPE=Bridge
BOOTPROTO=none
IPADDR=192.168.1.109
PREFIX=24
GATEWAY=192.168.1.1
DNS1=75.75.75.75
DNS1=75.75.76.76
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME="System br0"

Code:
# cat /etc/sysconfig/network-scripts/ifcfg-eth0 
DEVICE="eth0"
#BOOTPROTO="dhcp"
NM_CONTROLLED="yes"
ONBOOT="yes"
TYPE="Ethernet"
UUID="08986b4c-ed59-41f4-b329-f08e3100af28"
HWADDR="00:30:67:6F:7B:D1"
#IPADDR=192.168.0.100
#PREFIX=24
#GATEWAY=192.168.0.1
#DNS1=75.75.75.75
#DNS1=75.75.76.76
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME="System eth0"
BRIDGE=br0

Code:
# ifconfig
br0       Link encap:Ethernet  HWaddr 06:E7:70:7E:35:7D  
          inet addr:192.168.1.109  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::4e7:70ff:fe7e:357d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:171 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:25402 (24.8 KiB)

eth0      Link encap:Ethernet  HWaddr 94:DE:80:2F:C5:8B  
          inet addr:192.168.1.105  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::96de:80ff:fe2f:c58b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:58300 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42773 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:81109669 (77.3 MiB)  TX bytes:3873255 (3.6 MiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:81 errors:0 dropped:0 overruns:0 frame:0
          TX packets:81 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:8944 (8.7 KiB)  TX bytes:8944 (8.7 KiB)

virbr0    Link encap:Ethernet  HWaddr 52:54:00:E7:DC:BA  
          inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:74 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:12062 (11.7 KiB)
 
Old 07-26-2013, 12:24 PM   #5
gradinaruvasile
Member
 
Registered: Apr 2010
Location: Cluj, Romania
Distribution: Debian Testing
Posts: 515

Rep: Reputation: 102Reputation: 102
Still not good.

ifconfig should show something like:
Code:
br0       Link encap:Ethernet  HWaddr 94:de:80:00:8b:0c  
          inet addr:192.168.100.100  Bcast:192.168.100.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:681769 errors:0 dropped:0 overruns:0 frame:0
          TX packets:586060 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:597277608 (569.6 MiB)  TX bytes:100011015 (95.3 MiB)

eth0      Link encap:Ethernet  HWaddr 94:de:80:00:8b:0c  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:660545 errors:0 dropped:0 overruns:0 frame:0
          TX packets:547224 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:581100426 (554.1 MiB)  TX bytes:89178646 (85.0 MiB)
- eth0 should NOT have ANY IP address.
- br0 should have the same MAC as eth0.

Whad does the "brctl show" command shows on your computer?
I have (vnet0 is the virtual adapter attached to a running vm):
Code:
# brctl show
bridge name	bridge id		STP enabled	interfaces
br0		8000.94de80008b0c	no		eth0
							vnet0
Also, what does "ifconfig -all" show?
 
Old 07-26-2013, 05:22 PM   #6
walterbyrd
Member
 
Registered: Apr 2004
Posts: 572

Original Poster
Rep: Reputation: 30
Thanks again.

Code:
# brctl show
bridge name	bridge id		STP enabled	interfaces
br0		8000.000000000000	no		
virbr0		8000.525400e7dcba	yes		virbr0-nic
Code:
# ifconfig -a
br0       Link encap:Ethernet  HWaddr 06:E7:70:7E:35:7D  
          inet addr:192.168.1.109  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::4e7:70ff:fe7e:357d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1497 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:241386 (235.7 KiB)

eth0      Link encap:Ethernet  HWaddr 94:DE:80:2F:C5:8B  
          inet addr:192.168.1.105  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::96de:80ff:fe2f:c58b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:258108 errors:0 dropped:0 overruns:0 frame:0
          TX packets:184018 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:323933673 (308.9 MiB)  TX bytes:24384401 (23.2 MiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:81 errors:0 dropped:0 overruns:0 frame:0
          TX packets:81 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:8944 (8.7 KiB)  TX bytes:8944 (8.7 KiB)

virbr0    Link encap:Ethernet  HWaddr 52:54:00:E7:DC:BA  
          inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:736 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:119968 (117.1 KiB)

virbr0-nic Link encap:Ethernet  HWaddr 52:54:00:E7:DC:BA  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:500 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
 
Old 07-27-2013, 01:38 AM   #7
gradinaruvasile
Member
 
Registered: Apr 2010
Location: Cluj, Romania
Distribution: Debian Testing
Posts: 515

Rep: Reputation: 102Reputation: 102
- You dont have any members in br0 so it doesnt work. You need to add eth0 to it then set up the VMs to use it too instead of virbr0.

Here is a simple description on how to set up bridging:

http://www.banym.de/linux/centos/set...vice-on-centos

- You DO NOT need virbr0 - that is an internal bridge set up by kvm. The whole point of this thread is how to get rid of it and instead use ONLY br0 as the only bridge that will have eth0 and every virtual device created by KVM as its members resulting in full communication between all interfaces.
- The ifcfg scripts seem to be wrong - your eth0 has

Code:
HWaddr 94:DE:80:2F:C5:8B
but your ifcfg script reads
Code:
HWADDR="00:30:67:6F:7B:D1"
why? the HWADDR line is there exactly because you want to link your device to a specific MAC address and you specify a non existent one. You should recreate the script using the existing MAC.
You have also
Code:
NM_CONTROLLED="yes"
why do you let network-manager to control it - (this is why you still have a configured address on it)? You either use network manager to configure everything or dont use it at all. In your case (and any fixed computer case) it isnt needed at all if you specify the configurations in the scripts of every interface.
 
1 members found this post helpful.
Old 07-27-2013, 11:40 AM   #8
walterbyrd
Member
 
Registered: Apr 2004
Posts: 572

Original Poster
Rep: Reputation: 30
I the reason that I have two MAC addresses is that I changed my motherboard. I thought I fixed that, but I guess not.

I am going to guess that the MAC address from ifconfig is the true MAC address, and change that in my /etc/sysconfig/network-scripts/ifcfg-eth0 file.

I am thinking about renaming my /etc/sysconfig/network-scripts/ifcfg-eth0 file, and my /etc/sysconfig/network-scripts/ifcfg-br0 file (maybe just use a .bu extension). Then rebooting, and seeing if the system will rebuild the files.
 
Old 07-27-2013, 01:10 PM   #9
walterbyrd
Member
 
Registered: Apr 2004
Posts: 572

Original Poster
Rep: Reputation: 30
Well that could have gone better. Now I have no network at all. Giving the files a .bu extensions and rebooted did not work. So changed the file names back, edited the files, and rebooted again. Still no network. I wonder if that UUID could be messing things up? Maybe I should get rid of IPv6 stuff (not sure how to).

FWIW: here is the configuration information:

Code:
# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 94:DE:80:2F:C5:8B  
          inet6 addr: fe80::96de:80ff:fe2f:c58b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:501 errors:0 dropped:0 overruns:0 frame:0
          TX packets:149 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:164813 (160.9 KiB)  TX bytes:17971 (17.5 KiB)



# ifconfig br0
br0       Link encap:Ethernet  HWaddr 94:DE:80:2F:C5:8B  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:122 errors:0 dropped:0 overruns:0 frame:0
          TX packets:145 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:49730 (48.5 KiB)  TX bytes:17651 (17.2 KiB)




# cat ifcfg-eth0
DEVICE="eth0"
#BOOTPROTO="dhcp"
#NM_CONTROLLED="yes"
ONBOOT="yes"
TYPE="Ethernet"
UUID="08986b4c-ed59-41f4-b329-f08e3100af28"
HWADDR="94:DE:80:2F:C5:8B"
#HWADDR="00:30:67:6F:7B:D1"
#IPADDR=192.168.0.105
#PREFIX=24
#GATEWAY=192.168.0.1
#DNS1=75.75.75.75
#DNS1=75.75.76.76
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME="System eth0"


# cat ifcfg-br0
DEVICE="br0"
#NM_CONTROLLED="yes"
ONBOOT=yes
TYPE=Bridge
BOOTPROTO=none
IPADDR=192.168.1.109
PREFIX=24
GATEWAY=192.168.1.1
DNS1=75.75.75.75
DNS1=75.75.76.76
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME="System br0"
 
Old 07-27-2013, 01:59 PM   #10
gradinaruvasile
Member
 
Registered: Apr 2010
Location: Cluj, Romania
Distribution: Debian Testing
Posts: 515

Rep: Reputation: 102Reputation: 102
Now you dont have any ip addresses set on neither interface. Do you have the cable commected to eth0 and the router's IP address is 192.168.1.1?

Whats the output of "brctl show" again?

Also, you have 2 "DNS1" lines in the script, you should have DNS1 and 2.
Comment out the uuid line too.

ipv6 doesnt cause these issues, but if you want to remove it you have to do more than just the ipv6init=no in the script:

http://wiki.centos.org/FAQ/CentOS6#h...6a8a10d41781df
 
1 members found this post helpful.
Old 07-27-2013, 03:31 PM   #11
walterbyrd
Member
 
Registered: Apr 2004
Posts: 572

Original Poster
Rep: Reputation: 30
I think I need to start over.

I got rid of virbr0.
I renamed. ifcfg-br0 to ifcfg-br0.bu.
I setup everything to work with eth0.
Rebooted

Now my network works. I am able to ping everything from everywhere.

Changing the DNS1 to DNS2 is easy enough, but I suspect that is not my only problem.

Oddly, br0 still comes up on an ifconfig, even though there is no ifcfg-br0 file. Still getting different IP addresses for eth0 and br0, even though I have changed the MAC address. Also br0 and eth0 have different MAC address, no idea how that is happening. Also, br0 seems to come up with a different MAC address every time I reboot.



Code:
$ brctl show
bridge name	bridge id		STP enabled	interfaces
br0		8000.000000000000	no	

$ ifconfig 
br0       Link encap:Ethernet  HWaddr 7E:AA:AA:38:E6:32  
          inet addr:192.168.1.109  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::7caa:aaff:fe38:e632/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:830 (830.0 b)

eth0      Link encap:Ethernet  HWaddr 94:DE:80:2F:C5:8B  
          inet addr:192.168.1.105  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::96de:80ff:fe2f:c58b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:30965 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18550 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:33613375 (32.0 MiB)  TX bytes:3450316 (3.2 MiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:109 errors:0 dropped:0 overruns:0 frame:0
          TX packets:109 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:11809 (11.5 KiB)  TX bytes:11809 (11.5 KiB)




$ cat ifcfg-eth0
DEVICE="eth0"
BOOTPROTO="dhcp"
#NM_CONTROLLED="yes"
ONBOOT="yes"
TYPE="Ethernet"
UUID="08986b4c-ed59-41f4-b329-f08e3100af28"
HWADDR="94:DE:80:2F:C5:8B"
#HWADDR="00:30:67:6F:7B:D1"
IPADDR=192.168.0.109
PREFIX=24
GATEWAY=192.168.0.1
DNS1=75.75.75.75
DNS1=75.75.76.76
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME="System eth0"
#BRIDGE=br0

$ cat ifcfg-br0.bu
DEVICE="br0"
#NM_CONTROLLED="yes"
ONBOOT=yes
TYPE=Bridge
BOOTPROTO=none
IPADDR=192.168.1.109
PREFIX=24
GATEWAY=192.168.1.1
DNS1=75.75.75.75
DNS1=75.75.76.76
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME="System br0"

Last edited by walterbyrd; 07-27-2013 at 04:27 PM.
 
Old 07-27-2013, 05:38 PM   #12
walterbyrd
Member
 
Registered: Apr 2004
Posts: 572

Original Poster
Rep: Reputation: 30
Okay, I think I got it.

Whew! What a total PITA.

Code:
# brctl show
bridge name	bridge id		STP enabled	interfaces
br0		8000.94de802fc58b	no		eth0



# ifconfig
br0       Link encap:Ethernet  HWaddr 94:DE:80:2F:C5:8B  
          inet addr:192.168.1.109  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::96de:80ff:fe2f:c58b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1157 (1.1 KiB)  TX bytes:2670 (2.6 KiB)

eth0      Link encap:Ethernet  HWaddr 94:DE:80:2F:C5:8B  
          inet6 addr: fe80::96de:80ff:fe2f:c58b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3385 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3764 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1806803 (1.7 MiB)  TX bytes:763287 (745.3 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:233 errors:0 dropped:0 overruns:0 frame:0
          TX packets:233 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:23109 (22.5 KiB)  TX bytes:23109 (22.5 KiB)


# cat ifcfg-eth0
DEVICE="eth0"
#IPADDR=192.168.1.109
NETMASK=255.255.255.0
#BOOTPROTO="static"
ONBOOT="yes"
NM_CONTROLLED="no"
TYPE="Ethernet"
UUID="08986b4c-ed59-41f4-b329-f08e3100af28"
HWADDR="94:DE:80:2F:C5:8B"
#HWADDR="00:30:67:6F:7B:D1"
#PREFIX=24
#GATEWAY=192.168.1.1
#DNS1=75.75.75.75
#DNS1=75.75.76.76
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME="System eth0"
BRIDGE=br0


# cat ifcfg-br0
DEVICE="br0"
NM_CONTROLLED="no"
ONBOOT=yes
TYPE=Bridge
BOOTPROTO=none
IPADDR=192.168.1.109
PREFIX=24
GATEWAY=192.168.1.1
DNS1=75.75.75.75
DNS2=75.75.76.76
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME="System br0"
 
  


Reply

Tags
centos, kvm


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Centos 6.3 - KVM - Bridge/Networking problem cultavix Linux - Virtualization and Cloud 1 10-04-2012 06:19 AM
centos-5-x86_64 named/bind problems deadlyp99 Linux - Server 3 09-25-2012 04:33 AM
[SOLVED] Configuring 3c59x on CentOS 6.2 x86_64 gtludwig Red Hat 2 08-10-2012 02:41 PM
[SOLVED] CentOS: php-devel-5.1.6-32.el5.x86_64 from base has depsolving problems lrtward Linux - Server 7 03-23-2012 12:05 PM
KVM on Centos 5.4 - bridge issue on virtual interfaces asmar Linux - Networking 1 03-02-2010 12:11 AM


All times are GMT -5. The time now is 07:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration