LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Virtualization and Cloud
User Name
Password
Linux - Virtualization and Cloud This forum is for the discussion of all topics relating to Linux Virtualization and Linux Cloud platforms. Xen, KVM, OpenVZ, VirtualBox, VMware, Linux-VServer and all other Linux Virtualization platforms are welcome. OpenStack, CloudStack, ownCloud, Cloud Foundry, Eucalyptus, Nimbus, OpenNebula and all other Linux Cloud platforms are welcome. Note that questions relating solely to non-Linux OS's should be asked in the General forum.

Notices

Reply
 
Search this Thread
Old 03-19-2010, 09:55 AM   #1
slinx
Member
 
Registered: Apr 2008
Location: Cleveland, Ohio
Distribution: SuSE, CentOS, Fedora, Ubuntu
Posts: 106

Rep: Reputation: 23
Question How to prevent xen from using a network interface


I have two Ethernet ports on my server, and I want to use one for the xen bridge, and the other reserved for DRBD. How can I prevent xen from setting up a bridge on eth1?

Thank you!
 
Old 04-02-2010, 04:27 PM   #2
jrdouglas
LQ Newbie
 
Registered: Oct 2009
Posts: 4

Rep: Reputation: Disabled
I am going to guess that you are relying on xen's standard network-bridge script to create your bridges.

I've only used xen as provided by Novell/SuSE, so some of the paths to the files might be different on different distros, but hopefully this will give you the information you need.

By default, xen's network-bridge script will setup a bridge on whichever NIC had the default route. However, you can override this behavior by changing a single line in your /etc/xen/xend-config.sxp file. By default, you'll have a line that looks like this:

(network-script network-bridge)

You'll want to change it to something like this:

(network-script 'network-bridge netdev=eth0')

assuming eth0 is the interface you want to use for xen networking. That setting will take effect when you reboot your host. However, you can accomplish the same thing without rebooting, by doing the following:

1. Shut down all running VMs.
2. Shut down the bridge by running `/etc/xen/scripts/network-bridge stop`
3. Start the bridge on the correct interface by running `/etc/xen/scripts/network-bridge start netdev=eth0`
 
  


Reply

Tags
network bridge, xen


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] strange networking issue involving xen interface housemusic42 Linux - Networking 1 01-27-2010 04:30 PM
How NET_TX_SOFTIRQ select network interface when multiple interface exits Mr.J Linux - Kernel 0 06-02-2009 11:17 AM
LXer: Xen With Graphical User Interface On A Fedora 7 Desktop LXer Syndicated Linux News 0 09-20-2007 09:40 PM
How to prevent ENOBUFS failures in eth0 interface rylan76 Linux - Networking 3 12-31-2006 03:52 AM
LXer: Managing Xen With Xen-Tools, Xen-Shell, And Argo LXer Syndicated Linux News 0 11-05-2006 12:21 PM


All times are GMT -5. The time now is 08:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration