LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Virtualization and Cloud
User Name
Password
Linux - Virtualization and Cloud This forum is for the discussion of all topics relating to Linux Virtualization and Linux Cloud platforms. Xen, KVM, OpenVZ, VirtualBox, VMware, Linux-VServer and all other Linux Virtualization platforms are welcome. OpenStack, CloudStack, ownCloud, Cloud Foundry, Eucalyptus, Nimbus, OpenNebula and all other Linux Cloud platforms are welcome. Note that questions relating solely to non-Linux OS's should be asked in the General forum.

Notices

Reply
 
Search this Thread
Old 04-10-2010, 06:24 AM   #1
tkmsr
Member
 
Registered: Oct 2006
Distribution: Ubuntu,Open Suse,Debian,Mac OS X
Posts: 798

Rep: Reputation: 39
How do I test whether network-script is running or not in Xen Dom0.


How do I test whether network-script is running or not in Xen Dom0.
I have a Debian Lenny Dom0.Running Xen on it and 4 virtual hosts on it.
I am currently setting up a proxy server in Dom0 which DomU's will be able to use.The problem is before I go on to set NAT I wanted to test bridges.

So I renamed the bridge in /etc/xen/xend-config.sxp
Code:
(network-script 'network-bridge bridge=ABCD')

but when I do a reboot or xend restart and do following

Code:
openworld:/etc/xen# brctl show
bridge name	bridge id		STP enabled	interfaces
eth2		8000.0026b9824238	no		peth2
							vif1.0
							vif2.0
							vif3.0
							vif4.0
openworld:/etc/xen#
the bridge is not renamed to ABCD above output is showing eth2 which is not even default.
So I doubt that the script network-bridge has not been called so that it renames the bridge or there is some thing else I should look for.
 
Old 04-10-2010, 07:03 PM   #2
blacky_5251
Member
 
Registered: Oct 2004
Location: Adelaide Hills, South Australia
Distribution: RHEL 4&5, Fedora 10, CentOS 5.4, IPCop
Posts: 569

Rep: Reputation: 55
Sorry, I was not answering the question you asked.

Last edited by blacky_5251; 04-10-2010 at 07:17 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setup Slackware64 HVM with Xen Dom0 Kernel 2.6.31.4 in Fedora 11 x86-64 Dom0 Teo En Ming Linux - Virtualization and Cloud 0 11-01-2009 08:24 AM
LXer: Setup Xen 3.3.0 Ubuntu Intrepid Server Dom0 via build xen-kernel based on http: LXer Syndicated Linux News 0 01-03-2009 05:50 PM
LXer: Setup Xen 3.3.0 Ubuntu Intrepid Server Dom0 via build xen-kernel based on http: LXer Syndicated Linux News 0 01-03-2009 12:00 PM
LXer: Running 64-bit Solaris 10U6 HVM DomU (2 vcpus) at Xen 3.3.1-RC3 CentOS 5.2 Dom0 LXer Syndicated Linux News 0 12-20-2008 05:00 PM
LXer: Backport Intrepid Xen 3.3 Hypervisor to Ubuntu Hardy Dom0 (2.6.24-21-xen) LXer Syndicated Linux News 0 11-13-2008 06:11 PM


All times are GMT -5. The time now is 09:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration