LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Virtualization and Cloud
User Name
Password
Linux - Virtualization and Cloud This forum is for the discussion of all topics relating to Linux Virtualization and Linux Cloud platforms. Xen, KVM, OpenVZ, VirtualBox, VMware, Linux-VServer and all other Linux Virtualization platforms are welcome. OpenStack, CloudStack, ownCloud, Cloud Foundry, Eucalyptus, Nimbus, OpenNebula and all other Linux Cloud platforms are welcome. Note that questions relating solely to non-Linux OS's should be asked in the General forum.

Notices

Reply
 
Search this Thread
Old 10-24-2011, 06:33 PM   #1
LinusStallman
Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Linux Mint 17 MATE
Posts: 285

Rep: Reputation: 14
Question Full screen resolution for Bodhi 1.2.1 in VirtualBox possible?


Hi.

I have many distros installed in VirtualBox like Ubuntu 11.10, Xubuntu 11.10, Kubuntu 11.10 etc.
Getting them to go full screen resolution is simple.

How would I do this in Bodhi Linux?

Thanks.
 
Old 10-25-2011, 11:10 AM   #2
SecretCode
Member
 
Registered: Apr 2011
Location: UK
Distribution: Kubuntu 11.10
Posts: 562

Rep: Reputation: 102Reputation: 102
Do you install the VirtualBox Guest Additions in those distros? That's the only way afaik.

And have you tried to install Guest Additions in Bodhi?
 
Old 10-25-2011, 03:52 PM   #3
jefro
Guru
 
Registered: Mar 2008
Posts: 11,969

Rep: Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484
I don't think it can hurt to try to add in additions but I am not sure it will fix it either.

A few issues. Does Bodhi offer a compatible driver for the virtualized video card? Can it run an a compatible mode like vesa?

Did you try to change the display/monitor properties in Bohdi to the native host settings? I assume you know the hot keys to go full screen and back.
 
Old 10-27-2011, 05:21 AM   #4
LinusStallman
Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Linux Mint 17 MATE
Posts: 285

Original Poster
Rep: Reputation: 14
The max resolution I can get in it is 800*600.

I don't see any where to install drivers.

How would I access VESA mode?

I tried to install Guest Additions but got this: http://i.imgur.com/iJNPz.png

If anyone can get full screen resolution for Bodhi 1.2.1 in VirtualBox -- please post the necessary steps.
Attached Images
File Type: png iJNPz.png (25.3 KB, 3 views)
 
Old 10-27-2011, 03:09 PM   #5
SecretCode
Member
 
Registered: Apr 2011
Location: UK
Distribution: Kubuntu 11.10
Posts: 562

Rep: Reputation: 102Reputation: 102
Guest Additions needs Linux headers and a complete build system ... I think Ubuntu and derivatives strip some of this out. Try installing packages linux-headers-generic (or linux-headers-$(uname -r)) and build-essential first.

I also find that dkms is useful.
 
1 members found this post helpful.
Old 10-27-2011, 04:20 PM   #6
jefro
Guru
 
Registered: Mar 2008
Posts: 11,969

Rep: Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484
The max resolution is a result of the drivers available in the distro. You seem to be stuck in vesa already.

Simple enough to try a more main stream distro or search the virtualbox documentation for exactly what driver is needed. At one time vmware had a real issue with even big OS's. Everyone had to fool with getting a vmware driver.
 
Old 10-28-2011, 08:11 AM   #7
LinusStallman
Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Linux Mint 17 MATE
Posts: 285

Original Poster
Rep: Reputation: 14
Quote:
Originally Posted by jefro View Post
The max resolution is a result of the drivers available in the distro. You seem to be stuck in vesa already.

Simple enough to try a more main stream distro or search the virtualbox documentation for exactly what driver is needed. At one time vmware had a real issue with even big OS's. Everyone had to fool with getting a vmware driver.
I have many distros installed in VB already. Most of the Ubuntu family and they are all in fullscreen with little effort required. I want to try Bodhi because it looks decent and is lightning quick but it is not ideal with such a low resolution.
 
Old 10-28-2011, 08:16 AM   #8
LinusStallman
Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Linux Mint 17 MATE
Posts: 285

Original Poster
Rep: Reputation: 14
Exclamation

Quote:
Originally Posted by SecretCode View Post
Guest Additions needs Linux headers and a complete build system ... I think Ubuntu and derivatives strip some of this out. Try installing packages linux-headers-generic (or linux-headers-$(uname -r)) and build-essential first.

I also find that dkms is useful.
I tried those steps, cheers. Then I tried the guest additions ISO but it frequently crashes (when I run the x86.run file). I presume a future release of Bodhi will allow for full screen resolution easily.
 
Old 10-28-2011, 08:37 AM   #9
SecretCode
Member
 
Registered: Apr 2011
Location: UK
Distribution: Kubuntu 11.10
Posts: 562

Rep: Reputation: 102Reputation: 102
It does work!

I've just got 32-bit Bodhi 1.0.0 running full-screen in VirtualBox 4.0.12, via the following commands:

Code:
sudo aptitude update

sudo aptitude safe-upgrade
ignoring warnings about untrusted packages
reboot (because there is a new kernel)
OK to lots of messages about error loading module
Code:
sudo aptitude install build-essential dkms linux-headers-$(uname -r)
reboot (might not be necessary)
insert Guest Additions CD
does not seem to automount - use PCManFM to mount
Code:
cd /media/VBOXADDITIONS...
(./autorun.sh doesn't seem to help - flashes a window and does nothing) - instead:
Code:
sudo ./VBoxLinuxAdditions.run
reboot

Enjoy resizable or full-screen display!

Last edited by SecretCode; 10-28-2011 at 03:44 PM.
 
2 members found this post helpful.
Old 10-28-2011, 10:15 PM   #10
jefro
Guru
 
Registered: Mar 2008
Posts: 11,969

Rep: Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484Reputation: 1484
I saw that the other day on a bodhi wiki site and was going to post it but SecretCode beat me to it.
 
Old 11-01-2011, 05:13 PM   #11
LinusStallman
Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Linux Mint 17 MATE
Posts: 285

Original Poster
Rep: Reputation: 14
Unhappy

Quote:
Originally Posted by SecretCode View Post
It does work!

I've just got 32-bit Bodhi 1.0.0 running full-screen in VirtualBox 4.0.12, via the following commands:

[CODE]sudo aptitude update
...
Hi SecretCode. I tried all the steps in your post but with no luck. I am still stuck with 800*600 resolution. Perhaps it is because I am on Bodhi 1.2.1 instead of Bodhi 1.0.0?
 
Old 11-09-2011, 08:40 AM   #12
SecretCode
Member
 
Registered: Apr 2011
Location: UK
Distribution: Kubuntu 11.10
Posts: 562

Rep: Reputation: 102Reputation: 102
Sorry for only replying now - I have been away from the board.

Tried it (from scratch) with the 1.2.1 iso, and it still works fine for me.

What version of vbox are you running? What video memory have you assigned to the guest, and have you enabled 3D acceleration?
 
1 members found this post helpful.
Old 11-10-2011, 04:55 AM   #13
LinusStallman
Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Linux Mint 17 MATE
Posts: 285

Original Poster
Rep: Reputation: 14
Lightbulb

Quote:
Originally Posted by SecretCode View Post
Sorry for only replying now - I have been away from the board.

Tried it (from scratch) with the 1.2.1 iso, and it still works fine for me.

What version of vbox are you running? What video memory have you assigned to the guest, and have you enabled 3D acceleration?
Here is the info. Thanks for sticking by.
Attached Images
File Type: jpg VirtualBox - About.jpg (55.9 KB, 4 views)
File Type: png Settings.png (58.3 KB, 4 views)
 
Old 11-10-2011, 05:08 AM   #14
SecretCode
Member
 
Registered: Apr 2011
Location: UK
Distribution: Kubuntu 11.10
Posts: 562

Rep: Reputation: 102Reputation: 102
Bump the video memory to 64MB, or even 128MB.

If that doesn't do it, try the latest version of vbox - I think 4.1.6 is out, though I'm using 4.0.12 (I've had no problems with video effects on any 4.x version).

Also, reinstall VBoxLinuxAdditions.run and post all the output you get.
 
1 members found this post helpful.
Old 11-10-2011, 11:06 AM   #15
LinusStallman
Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Linux Mint 17 MATE
Posts: 285

Original Poster
Rep: Reputation: 14
Thumbs up

Quote:
Originally Posted by SecretCode View Post
Bump the video memory to 64MB, or even 128MB.

If that doesn't do it, try the latest version of vbox - I think 4.1.6 is out, though I'm using 4.0.12 (I've had no problems with video effects on any 4.x version).

Also, reinstall VBoxLinuxAdditions.run and post all the output you get.
Will do that and report back. Cheers.
 
  


Reply

Tags
bodhi, virtualbox


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
using full-screen mode in Virtualbox newbiesforever Linux - Software 21 01-12-2013 11:53 AM
full screen on virtualbox j360 Linux - General 5 01-15-2011 04:53 AM
Screen resolution in XP as guest system on VirtualBox altella Linux - Virtualization and Cloud 2 12-01-2009 11:43 AM
Debian in Virtualbox - Weird Screen Resolution michalng Linux - Newbie 1 04-16-2009 05:23 AM
X windows resolution is not full screen lbdgwgt Linux - Newbie 4 12-22-2006 09:33 AM


All times are GMT -5. The time now is 07:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration