LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Virtualization and Cloud (http://www.linuxquestions.org/questions/linux-virtualization-and-cloud-90/)
-   -   CentOS 6 in VirtualBox video problems (http://www.linuxquestions.org/questions/linux-virtualization-and-cloud-90/centos-6-in-virtualbox-video-problems-918591/)

zebadee2010 12-13-2011 07:09 PM

CentOS 6 in VirtualBox video problems
 
I am currently learning linux and making pretty good progress. However, I recently installen CentOS in VirtualBox and upon typing startx the screen get bigger, then does some bar stuff and then gives me two errors. one about vboxvideo module not existing, and another that says open /dev/fb0: no such device.

What could be the cause of this? and a possible solution?

davemguru 12-13-2011 08:23 PM

Quote:

vboxvideo module not existing
is because you have not installed the "Virtualbox Linux Additons" Also known as "Guest additions" - use your HOST+D key (if you know which key you defined as your host key) or click on the menu choice "Devices".
Your need to do a bit of reading of the virtualbox manual about installing guest additions. Some O/S's will automatically run the "autorun" command on the virtual cd that is the "guest additions" - whilst some will not. So, you might have to learn a bit about that.
Quote:

open /dev/fb0: no such device
is the same reason as above... Centos X windows is expecting a graphics card with a F.rame B.uffer - hence the "fb" part of the device name. But, you haven't installed the guest additions - so....... it can't find the device because... there is no such device (yet).

Dave

zebadee2010 12-13-2011 09:12 PM

Okay, so I installed the guest additions, and that got me a little bit further but now I get different error codes.

(EE) open /dev/fb0: no such device
(EE) VBoxVideo(0): Failed to initialize the VirtualBox device (rc=-102)
WARNING: Depreceated config file /etc/modprobe.conf, all config files belong into /etc/modrobe.d/.
FATAL: Module vboxvideo not found.
(EE) [drm] drmOpen failed.
(EE) VBoxVideo(0): DRIScreenInit failed, disabling DRI.
(EE) VBoxVideo(0): Unable to determine whether the virtual machine supports mouse pointer integration - request initialization failed with return code -4
Failed to connect to the VirtualBox kernel service

davemguru 12-14-2011 08:19 AM

Quote:

Okay, so I installed the guest additions, and that got me a little bit further but now I get different error codes.
So (in a way) you have a different problem. Which (perhaps) may require a different post in a different forum.
However
Quote:

(EE) VBoxVideo(0): Failed to initialize the VirtualBox device (rc=-102)
and the other errors are telling you the VB drivers are not working/"fail to start".. SO you could feed your favorite search engine with one of those messages - such as the one above. That would lead to VirtualBox Forum topic which (in turn) recommends this solution.
These solutions refer to an older VB and to Kubuntu and debian. But, I think the symptoms you describe apply.
Your could also search using keywords like "centos" "X not starting" etc. within the VB forums too.

Dave

zebadee2010 12-15-2011 06:19 PM

Quote:

Originally Posted by davemguru (Post 4549650)
So (in a way) you have a different problem. Which (perhaps) may require a different post in a different forum.
However and the other errors are telling you the VB drivers are not working/"fail to start".. SO you could feed your favorite search engine with one of those messages - such as the one above. That would lead to VirtualBox Forum topic which (in turn) recommends this solution.
These solutions refer to an older VB and to Kubuntu and debian. But, I think the symptoms you describe apply.
Your could also search using keywords like "centos" "X not starting" etc. within the VB forums too.

Dave

Thanks for the help, I was unable to figure out what exactly was wrong with it. So I ended up just doing a reinstall with minimal desktop. Thanks though


All times are GMT -5. The time now is 04:06 PM.