-   Linux - Virtualization and Cloud (
-   -   [Debian/Qemu/KVM] Why qemu --enable-kvm works but not kvm directly? (

gb2312 03-21-2011 12:35 AM

[Debian/Qemu/KVM] Why qemu --enable-kvm works but not kvm directly?
I'm running debian unstable with qemu (and qemu-kvm) 0.12.5+dfsg-3. I had been running a windows 7 64-bit virtual machine for a while and then noticed that I've always been running the vm with


  qemu-system-x86_64 \
    -m 1024 \
    --enable-kvm \

but qemu-kvm package says I should run "kvm" directly. But that didn't work for the vm (stuck in boot up). Does it mean that I was not using kvm at all? (My processor supports it, and qemu console command "info kvm" says "kvm support: enabled")

I'm actually quite happy with current setup of 0.12.5 but windows 7 64 bit doesn't support the sound card, and I've tried new 0.14.0 qemu, but I have the same problem of stucking boot screen...

Could this be a Windows problem instead? Anyone upgraded qemu and old windows 7 64-bit vm breaks?

Slax-Dude 03-21-2011 01:51 PM


Originally Posted by gb2312 (Post 4297647)
but qemu-kvm package says I should run "kvm" directly

Can you post the exact message?
Did you load the kvm module prior to trying qemu-kvm?

gb2312 03-21-2011 03:05 PM

I don't remember where I found the example, but "qemu-kvm" package does provide "kvm" command:

$ dpkg -L qemu-kvm

I did have kvm modules loaded (by /etc/init.d/qemu-kvm)

$ lsmod | grep kvm
kvm_intel              43515  3
kvm                  255441  1 kvm_intel

Anyone experienced similar windows 7 64-bit bootup problem? I probably have to try a 32-bit one...

All times are GMT -5. The time now is 01:24 AM.