LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Yum Update Transaction Errors - CentOS (http://www.linuxquestions.org/questions/linux-software-2/yum-update-transaction-errors-centos-810139/)

deibertine 05-26-2010 01:06 AM

Yum Update Transaction Errors - CentOS
 
Im running an update through YUM from my CentOS5 64bit box and came across this error:Transaction Check Error: file /usr/lib64/httpd/modules/mod_ssl.so from install of mod_ssl-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_access.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_actions.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_alias.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_asis.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_auth.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_auth_anon.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_auth_dbm.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_auth_digest.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_auth_ldap.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_autoindex.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_cache.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_cern_meta.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_cgi.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_dav.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_dav_fs.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_deflate.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_dir.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_disk_cache.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_env.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_expires.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_ext_filter.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_file_cache.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_headers.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_imap.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_include.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_info.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_ldap.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_log_config.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_log_forensic.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_logio.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_mem_cache.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_mime.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_mime_magic.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_negotiation.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_proxy.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_proxy_connect.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_proxy_ftp.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_proxy_http.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_rewrite.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_setenvif.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_speling.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_status.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_suexec.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_unique_id.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_userdir.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_usertrack.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_vhost_alias.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1

I've done some research on this and found solutions on how to rectify (i.e. reconfig YUM repositories etc.) but still same issue.

Hoping someone in here can advise me please.

Cheers!
DB ;)

vikas027 05-26-2010 01:20 AM

run these commands and post results

Code:

service yum-updatesd restart
yum clean all
yum clean metadata
yum remove http* -y
yum update
yum install http* -y

If this does not resolves, post output of
Code:

rpm -qa | grep http

deibertine 05-26-2010 08:08 PM

Quote:

Originally Posted by vikas027 (Post 3981391)
run these commands and post results

Code:

service yum-updatesd restart
yum clean all
yum clean metadata
yum remove http* -y
yum update
yum install http* -y

If this does not resolves, post output of
Code:

rpm -qa | grep http

Thanks for the post. After doing yum install http* -y still gave me this:
ransaction Check Error: file /usr/lib64/httpd/modules/mod_access.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_actions.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_alias.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_asis.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_auth.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_auth_anon.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_auth_dbm.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_auth_digest.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_auth_ldap.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_autoindex.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_cache.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_cern_meta.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_cgi.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
file /usr/lib64/httpd/modules/mod_dav.so from install of httpd-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1

doing a rpm -qa | grep http displayed nothing.

Please advise.
Cheers.

chrism01 05-26-2010 10:09 PM

Quote:

mod_ssl-2.0.52-41.ent.7.centos4 conflicts with file from package 3rdparty-10-1
2 things;

1. that says you're trying to install a Centos v4 pkg; what version of Centos do you have? Current is 5.5
2. what is the 3rdparty-10-1 pkg??

blue_print 05-26-2010 10:12 PM

Seems to be an issue with the package '3rdparty-10-1'. Check whether this package is installed in the OS.

rpm -qa | grep -i 3rdparty-10-1

If so, if this package is not in use, please remove it and then run the update.

Hope this will solve your issue.


All times are GMT -5. The time now is 12:27 PM.