LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-18-2010, 11:17 AM   #1
nivantha
LQ Newbie
 
Registered: Apr 2006
Distribution: Fedora
Posts: 17

Rep: Reputation: 0
yum update issue - broken packages??


Hi Guys,

I had to shutdown my machine while a yum update was in progress. Once I restarted I got the following error.

[root@Avatar ~]# yum -y update
Loaded plugins: fastestmirror, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
fedora/metalink | 12 kB 00:00
updates/metalink | 9.6 kB 00:00
* fedora: www.ftp.ne.jp
* rpmfusion-free: rpmfusion.idrepo.or.id
* rpmfusion-free-updates: rpmfusion.idrepo.or.id
* rpmfusion-nonfree: rpmfusion.idrepo.or.id
* rpmfusion-nonfree-updates: rpmfusion.idrepo.or.id
* updates: www.ftp.ne.jp
adobe-linux-i386 | 951 B 00:00
rpmfusion-free | 2.8 kB 00:00
rpmfusion-free-updates | 3.3 kB 00:00
rpmfusion-nonfree | 2.8 kB 00:00
rpmfusion-nonfree-updates | 3.3 kB 00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package libunrar.i686 0:3.9.10-3.fc13 set to be updated
---> Package lohit-oriya-fonts.noarch 0:2.4.3-5.fc13 set to be updated
--> Processing Dependency: perl = 4:5.10.1-116.fc13 for package: 1:perl-Module-Pluggable-3.90-116.fc13.i686
--> Processing Dependency: perl = 4:5.10.1-116.fc13 for package: 4:perl-libs-5.10.1-116.fc13.i686
--> Processing Dependency: perl = 4:5.10.1-116.fc13 for package: 1:perl-Pod-Simple-3.07-116.fc13.i686
--> Processing Dependency: perl = 4:5.10.1-116.fc13 for package: 1:perl-Pod-Escapes-1.04-116.fc13.i686
---> Package perl.i686 4:5.10.1-119.fc13 set to be updated
---> Package perl-ExtUtils-MakeMaker.i686 0:6.55-119.fc13 set to be updated
---> Package perl-ExtUtils-ParseXS.i686 1:2.20-119.fc13 set to be updated
---> Package perl-Test-Harness.i686 0:3.17-119.fc13 set to be updated
---> Package perl-devel.i686 4:5.10.1-119.fc13 set to be updated
---> Package perl-suidperl.i686 4:5.10.1-119.fc13 set to be updated
---> Package unrar.i686 0:3.9.10-3.fc13 set to be updated
--> Finished Dependency Resolution
Error: Package: 1:perl-Pod-Escapes-1.04-116.fc13.i686 (@updates)
Requires: perl = 4:5.10.1-116.fc13
Removing: 4:perl-5.10.1-116.fc13.i686 (@updates)
perl = 4:5.10.1-116.fc13
Updated By: 4:perl-5.10.1-119.fc13.i686 (updates)
perl = 4:5.10.1-119.fc13
Available: 4:perl-5.10.1-112.fc13.i686 (fedora)
perl = 4:5.10.1-112.fc13
Error: Package: 1:perl-Pod-Simple-3.07-116.fc13.i686 (@updates)
Requires: perl = 4:5.10.1-116.fc13
Removing: 4:perl-5.10.1-116.fc13.i686 (@updates)
perl = 4:5.10.1-116.fc13
Updated By: 4:perl-5.10.1-119.fc13.i686 (updates)
perl = 4:5.10.1-119.fc13
Available: 4:perl-5.10.1-112.fc13.i686 (fedora)
perl = 4:5.10.1-112.fc13
Error: Package: 1:perl-Module-Pluggable-3.90-116.fc13.i686 (@updates)
Requires: perl = 4:5.10.1-116.fc13
Removing: 4:perl-5.10.1-116.fc13.i686 (@updates)
perl = 4:5.10.1-116.fc13
Updated By: 4:perl-5.10.1-119.fc13.i686 (updates)
perl = 4:5.10.1-119.fc13
Available: 4:perl-5.10.1-112.fc13.i686 (fedora)
perl = 4:5.10.1-112.fc13
Error: Package: 4:perl-libs-5.10.1-116.fc13.i686 (@updates)
Requires: perl = 4:5.10.1-116.fc13
Removing: 4:perl-5.10.1-116.fc13.i686 (@updates)
perl = 4:5.10.1-116.fc13
Updated By: 4:perl-5.10.1-119.fc13.i686 (updates)
perl = 4:5.10.1-119.fc13
Available: 4:perl-5.10.1-112.fc13.i686 (fedora)
perl = 4:5.10.1-112.fc13
You could try using --skip-broken to work around the problem
** Found 33 pre-existing rpmdb problem(s), 'yum check' output follows:
bzip2-libs-1.0.6-1.fc13.i686 is a duplicate with bzip2-libs-1.0.5-6.fc12.i686
1:cups-libs-1.4.4-10.fc13.i686 is a duplicate with 1:cups-libs-1.4.4-5.fc13.i686
fedora-release-notes-13.2-2.fc13.noarch is a duplicate with fedora-release-notes-13.2-1.fc13.noarch
foomatic-db-filesystem-4.0-20.20100819.fc13.noarch is a duplicate with foomatic-db-filesystem-4.0-17.20100204.fc13.noarch
ghostscript-8.71-16.fc13.i686 is a duplicate with ghostscript-8.71-10.fc13.i686
glibc-2.12.1-2.i686 is a duplicate with glibc-2.12-3.i686
glibc-common-2.12.1-2.i686 is a duplicate with glibc-common-2.12-3.i686
gnome-doc-utils-stylesheets-0.20.1-2.fc13.noarch is a duplicate with gnome-doc-utils-stylesheets-0.20.1-1.fc13.noarch
gnome-python2-extras-2.25.3-22.fc13.i686 is a duplicate with gnome-python2-extras-2.25.3-20.fc13.i686
ibus-libs-1.3.6-2.fc13.i686 is a duplicate with ibus-libs-1.3.6-1.fc13.i686
ibus-pinyin-db-open-phrase-1.3.11-1.fc13.noarch is a duplicate with ibus-pinyin-db-open-phrase-1.3.10-1.fc13.noarch
kernel-headers-2.6.34.7-56.fc13.i686 is a duplicate with kernel-headers-2.6.34.6-54.fc13.i686
krb5-libs-1.7.1-14.fc13.i686 is a duplicate with krb5-libs-1.7.1-13.fc13.i686
libudev-153-4.fc13.i686 is a duplicate with libudev-153-3.fc13.i686
nspr-4.8.6-1.fc13.i686 is a duplicate with nspr-4.8.4-2.fc13.i686
nss-softokn-freebl-3.12.7-6.fc13.i686 is a duplicate with nss-softokn-freebl-3.12.6-3.fc13.i686
nss-util-3.12.7-2.fc13.i686 is a duplicate with nss-util-3.12.6-1.fc13.i686
oyranos-libs-0.1.10-1.fc13.i686 is a duplicate with oyranos-libs-0.1.9-4.fc12.i686
perf-2.6.34.7-56.fc13.noarch is a duplicate with perf-2.6.34.6-54.fc13.noarch
1:perl-Module-Pluggable-3.90-119.fc13.i686 is a duplicate with 1:perl-Module-Pluggable-3.90-116.fc13.i686
1:perl-Module-Pluggable-3.90-119.fc13.i686 has missing requires of perl = ('4', '5.10.1', '119.fc13')
1:perl-Pod-Escapes-1.04-119.fc13.i686 is a duplicate with 1:perl-Pod-Escapes-1.04-116.fc13.i686
1:perl-Pod-Escapes-1.04-119.fc13.i686 has missing requires of perl = ('4', '5.10.1', '119.fc13')
1:perl-Pod-Simple-3.07-119.fc13.i686 is a duplicate with 1:perl-Pod-Simple-3.07-116.fc13.i686
1:perl-Pod-Simple-3.07-119.fc13.i686 has missing requires of perl = ('4', '5.10.1', '119.fc13')
4:perl-libs-5.10.1-119.fc13.i686 is a duplicate with 4:perl-libs-5.10.1-116.fc13.i686
4:perl-libs-5.10.1-119.fc13.i686 has missing requires of perl = ('4', '5.10.1', '119.fc13')
policycoreutils-2.0.83-28.fc13.i686 is a duplicate with policycoreutils-2.0.83-20.fc13.i686
policycoreutils-python-2.0.83-28.fc13.i686 is a duplicate with policycoreutils-python-2.0.83-20.fc13.i686
shared-desktop-ontologies-0.5-1.fc13.noarch is a duplicate with shared-desktop-ontologies-0.4-1.fc13.noarch
system-config-language-1.3.5-1.fc13.noarch is a duplicate with system-config-language-1.3.4-6.fc13.noarch
udev-153-4.fc13.i686 is a duplicate with udev-153-3.fc13.i686
xorg-x11-server-common-1.8.2-4.fc13.i686 is a duplicate with xorg-x11-server-common-1.8.2-3.fc13.i686




Can anybody help me out in resolving this issue? I'm running fedora 13 on a ThinkPad T61.

Thanks in advance.
 
Old 10-18-2010, 04:46 PM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 12,811

Rep: Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705
Quote:
I had to shutdown my machine while a yum update was in progress.
you will never do that again

if you are lucky - very lucky - cleaning the yum and rpm database MIGHT fix it
Code:
su -
yum clean all 
rpm --rebuilddb 
 ( if the first yum command tosses an error do the rpm -- rebuilddb first ) 
yum update
now at the end of the error ( you did not post that part ) there should be a massage about trying " skip broken" and a second command( i can not remember it at the moment ) unless you ALREADY have the yum utility tools installed ( not installed by default) you will not be able to use that second help option
 
Old 10-19-2010, 11:48 AM   #3
nivantha
LQ Newbie
 
Registered: Apr 2006
Distribution: Fedora
Posts: 17

Original Poster
Rep: Reputation: 0
Thanks for the tip John. But looks like I'm not that lucky after all.

Code:
[root@Avatar ~]# yum clean all
Loaded plugins: fastestmirror, presto, refresh-packagekit
Cleaning repos: adobe-linux-i386 fedora rpmfusion-free rpmfusion-free-updates rpmfusion-nonfree rpmfusion-nonfree-updates updates
Cleaning up Everything
Cleaning up list of fastest mirrors
0 delta-package files removed, by presto
[root@Avatar ~]# rpm --rebuilddb
[root@Avatar ~]# yum update
Loaded plugins: fastestmirror, presto, refresh-packagekit
Determining fastest mirrors
fedora/metalink                                                                                                   |  12 kB     00:00     
updates/metalink                                                                                                  | 4.6 kB     00:00     
 * fedora: ftp.cuhk.edu.hk
 * rpmfusion-free: mirror.cse.iitk.ac.in
 * rpmfusion-free-updates: mirror.cse.iitk.ac.in
 * rpmfusion-nonfree: mirror.cse.iitk.ac.in
 * rpmfusion-nonfree-updates: mirror.cse.iitk.ac.in
 * updates: ftp.cuhk.edu.hk
adobe-linux-i386                                                                                                  |  951 B     00:00     
adobe-linux-i386/primary                                                                                          |  12 kB     00:00     
adobe-linux-i386                                                                                                                   18/18
fedora                                                                                                            | 4.3 kB     00:00     
fedora/primary_db                                                                                                 |  10 MB     05:01     
rpmfusion-free                                                                                                    | 2.8 kB     00:00     
rpmfusion-free/primary_db                                                                                         | 304 kB     00:08     
rpmfusion-free-updates                                                                                            | 3.3 kB     00:00     
rpmfusion-free-updates/primary_db                                                                                 | 369 kB     00:18     
rpmfusion-nonfree                                                                                                 | 2.8 kB     00:00     
rpmfusion-nonfree/primary_db                                                                                      |  97 kB     00:05     
rpmfusion-nonfree-updates                                                                                         | 3.3 kB     00:00     
rpmfusion-nonfree-updates/primary_db                                                                              |  87 kB     00:04     
updates                                                                                                           | 4.7 kB     00:00     
updates/primary_db                                                                                                | 4.1 MB     01:39     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: perl = 4:5.10.1-116.fc13 for package: 1:perl-Module-Pluggable-3.90-116.fc13.i686
--> Processing Dependency: perl = 4:5.10.1-116.fc13 for package: 4:perl-libs-5.10.1-116.fc13.i686
--> Processing Dependency: perl = 4:5.10.1-116.fc13 for package: 1:perl-Pod-Simple-3.07-116.fc13.i686
--> Processing Dependency: perl = 4:5.10.1-116.fc13 for package: 1:perl-Pod-Escapes-1.04-116.fc13.i686
---> Package perl.i686 4:5.10.1-119.fc13 set to be updated
---> Package perl-ExtUtils-MakeMaker.i686 0:6.55-119.fc13 set to be updated
---> Package perl-ExtUtils-ParseXS.i686 1:2.20-119.fc13 set to be updated
---> Package perl-Test-Harness.i686 0:3.17-119.fc13 set to be updated
---> Package perl-devel.i686 4:5.10.1-119.fc13 set to be updated
---> Package perl-suidperl.i686 4:5.10.1-119.fc13 set to be updated
--> Finished Dependency Resolution
Error: Package: 1:perl-Pod-Escapes-1.04-116.fc13.i686 (@updates)
           Requires: perl = 4:5.10.1-116.fc13
           Removing: 4:perl-5.10.1-116.fc13.i686 (@updates)
               perl = 4:5.10.1-116.fc13
           Updated By: 4:perl-5.10.1-119.fc13.i686 (updates)
               perl = 4:5.10.1-119.fc13
           Available: 4:perl-5.10.1-112.fc13.i686 (fedora)
               perl = 4:5.10.1-112.fc13
Error: Package: 1:perl-Pod-Simple-3.07-116.fc13.i686 (@updates)
           Requires: perl = 4:5.10.1-116.fc13
           Removing: 4:perl-5.10.1-116.fc13.i686 (@updates)
               perl = 4:5.10.1-116.fc13
           Updated By: 4:perl-5.10.1-119.fc13.i686 (updates)
               perl = 4:5.10.1-119.fc13
           Available: 4:perl-5.10.1-112.fc13.i686 (fedora)
               perl = 4:5.10.1-112.fc13
Error: Package: 1:perl-Module-Pluggable-3.90-116.fc13.i686 (@updates)
           Requires: perl = 4:5.10.1-116.fc13
           Removing: 4:perl-5.10.1-116.fc13.i686 (@updates)
               perl = 4:5.10.1-116.fc13
           Updated By: 4:perl-5.10.1-119.fc13.i686 (updates)
               perl = 4:5.10.1-119.fc13
           Available: 4:perl-5.10.1-112.fc13.i686 (fedora)
               perl = 4:5.10.1-112.fc13
Error: Package: 4:perl-libs-5.10.1-116.fc13.i686 (@updates)
           Requires: perl = 4:5.10.1-116.fc13
           Removing: 4:perl-5.10.1-116.fc13.i686 (@updates)
               perl = 4:5.10.1-116.fc13
           Updated By: 4:perl-5.10.1-119.fc13.i686 (updates)
               perl = 4:5.10.1-119.fc13
           Available: 4:perl-5.10.1-112.fc13.i686 (fedora)
               perl = 4:5.10.1-112.fc13
 You could try using --skip-broken to work around the problem
** Found 33 pre-existing rpmdb problem(s), 'yum check' output follows:
bzip2-libs-1.0.6-1.fc13.i686 is a duplicate with bzip2-libs-1.0.5-6.fc12.i686
1:cups-libs-1.4.4-10.fc13.i686 is a duplicate with 1:cups-libs-1.4.4-5.fc13.i686
fedora-release-notes-13.2-2.fc13.noarch is a duplicate with fedora-release-notes-13.2-1.fc13.noarch
foomatic-db-filesystem-4.0-20.20100819.fc13.noarch is a duplicate with foomatic-db-filesystem-4.0-17.20100204.fc13.noarch
ghostscript-8.71-16.fc13.i686 is a duplicate with ghostscript-8.71-10.fc13.i686
glibc-2.12.1-2.i686 is a duplicate with glibc-2.12-3.i686
glibc-common-2.12.1-2.i686 is a duplicate with glibc-common-2.12-3.i686
gnome-doc-utils-stylesheets-0.20.1-2.fc13.noarch is a duplicate with gnome-doc-utils-stylesheets-0.20.1-1.fc13.noarch
gnome-python2-extras-2.25.3-22.fc13.i686 is a duplicate with gnome-python2-extras-2.25.3-20.fc13.i686
ibus-libs-1.3.6-2.fc13.i686 is a duplicate with ibus-libs-1.3.6-1.fc13.i686
ibus-pinyin-db-open-phrase-1.3.11-1.fc13.noarch is a duplicate with ibus-pinyin-db-open-phrase-1.3.10-1.fc13.noarch
kernel-headers-2.6.34.7-56.fc13.i686 is a duplicate with kernel-headers-2.6.34.6-54.fc13.i686
krb5-libs-1.7.1-14.fc13.i686 is a duplicate with krb5-libs-1.7.1-13.fc13.i686
libudev-153-4.fc13.i686 is a duplicate with libudev-153-3.fc13.i686
nspr-4.8.6-1.fc13.i686 is a duplicate with nspr-4.8.4-2.fc13.i686
nss-softokn-freebl-3.12.7-6.fc13.i686 is a duplicate with nss-softokn-freebl-3.12.6-3.fc13.i686
nss-util-3.12.7-2.fc13.i686 is a duplicate with nss-util-3.12.6-1.fc13.i686
oyranos-libs-0.1.10-1.fc13.i686 is a duplicate with oyranos-libs-0.1.9-4.fc12.i686
perf-2.6.34.7-56.fc13.noarch is a duplicate with perf-2.6.34.6-54.fc13.noarch
1:perl-Module-Pluggable-3.90-119.fc13.i686 is a duplicate with 1:perl-Module-Pluggable-3.90-116.fc13.i686
1:perl-Module-Pluggable-3.90-119.fc13.i686 has missing requires of perl = ('4', '5.10.1', '119.fc13')
1:perl-Pod-Escapes-1.04-119.fc13.i686 is a duplicate with 1:perl-Pod-Escapes-1.04-116.fc13.i686
1:perl-Pod-Escapes-1.04-119.fc13.i686 has missing requires of perl = ('4', '5.10.1', '119.fc13')
1:perl-Pod-Simple-3.07-119.fc13.i686 is a duplicate with 1:perl-Pod-Simple-3.07-116.fc13.i686
1:perl-Pod-Simple-3.07-119.fc13.i686 has missing requires of perl = ('4', '5.10.1', '119.fc13')
4:perl-libs-5.10.1-119.fc13.i686 is a duplicate with 4:perl-libs-5.10.1-116.fc13.i686
4:perl-libs-5.10.1-119.fc13.i686 has missing requires of perl = ('4', '5.10.1', '119.fc13')
policycoreutils-2.0.83-28.fc13.i686 is a duplicate with policycoreutils-2.0.83-20.fc13.i686
policycoreutils-python-2.0.83-28.fc13.i686 is a duplicate with policycoreutils-python-2.0.83-20.fc13.i686
shared-desktop-ontologies-0.5-1.fc13.noarch is a duplicate with shared-desktop-ontologies-0.4-1.fc13.noarch
system-config-language-1.3.5-1.fc13.noarch is a duplicate with system-config-language-1.3.4-6.fc13.noarch
udev-153-4.fc13.i686 is a duplicate with udev-153-3.fc13.i686
xorg-x11-server-common-1.8.2-4.fc13.i686 is a duplicate with xorg-x11-server-common-1.8.2-3.fc13.i686
Regarding the skip broken option you've mentioned, it actually comes at the middle of the output.

Code:
Error: Package: 4:perl-libs-5.10.1-116.fc13.i686 (@updates)
           Requires: perl = 4:5.10.1-116.fc13
           Removing: 4:perl-5.10.1-116.fc13.i686 (@updates)
               perl = 4:5.10.1-116.fc13
           Updated By: 4:perl-5.10.1-119.fc13.i686 (updates)
               perl = 4:5.10.1-119.fc13
           Available: 4:perl-5.10.1-112.fc13.i686 (fedora)
               perl = 4:5.10.1-112.fc13
 You could try using --skip-broken to work around the problem
** Found 33 pre-existing rpmdb problem(s), 'yum check' output follows:
So, trying yum update --skip-broken skips the packages with dependency issues and updates the rest of the packages.

Code:
Updated:
  NetworkManager.i686 1:0.8.1-8.git20100831.fc13                   NetworkManager-devel.i686 1:0.8.1-8.git20100831.fc13                 
  NetworkManager-glib.i686 1:0.8.1-8.git20100831.fc13              NetworkManager-glib-devel.i686 1:0.8.1-8.git20100831.fc13            
  NetworkManager-gnome.i686 1:0.8.1-8.git20100831.fc13             anthy.i686 0:9100h-15.fc13                                           
  coreutils.i686 0:8.4-9.fc13                                      coreutils-libs.i686 0:8.4-9.fc13                                     
  fpaste.noarch 0:0.3.5-1.fc13                                     freetype.i686 0:2.3.11-6.fc13                                        
  freetype-devel.i686 0:2.3.11-6.fc13                              iproute.i686 0:2.6.33-7.fc13                                         
  libunrar.i686 0:3.9.10-3.fc13                                    lohit-oriya-fonts.noarch 0:2.4.3-5.fc13                              
  mysql.i686 0:5.1.51-2.fc13                                       mysql-embedded.i686 0:5.1.51-2.fc13                                  
  mysql-libs.i686 0:5.1.51-2.fc13                                  mysql-server.i686 0:5.1.51-2.fc13                                    
  nc.i686 0:1.84-23.fc13                                           poppler.i686 0:0.12.4-6.fc13                                         
  poppler-glib.i686 0:0.12.4-6.fc13                                poppler-qt4.i686 0:0.12.4-6.fc13                                     
  poppler-utils.i686 0:0.12.4-6.fc13                               postgresql-libs.i686 0:8.4.5-1.fc13                                  
  psmisc.i686 0:22.6-14.fc13                                       selinux-policy.noarch 0:3.7.19-65.fc13                               
  selinux-policy-targeted.noarch 0:3.7.19-65.fc13                  setroubleshoot.i686 0:2.2.102-1.fc13                                 
  setroubleshoot-server.i686 0:2.2.102-1.fc13                      unrar.i686 0:3.9.10-3.fc13                                           
  webkitgtk.i686 0:1.2.5-1.fc13                                   

Skipped (dependency problems):
  perl.i686 4:5.10.1-119.fc13               perl-ExtUtils-MakeMaker.i686 0:6.55-119.fc13    perl-ExtUtils-ParseXS.i686 1:2.20-119.fc13   
  perl-Test-Harness.i686 0:3.17-119.fc13    perl-devel.i686 4:5.10.1-119.fc13               perl-suidperl.i686 4:5.10.1-119.fc13         

Complete!
[root@Avatar ~]#
Isn't there any other way to fix these packages?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken update - yum missing libssl.so on Fedora 12 phluks Fedora 3 04-02-2010 09:33 AM
How does yum (or rpm or other pm) update/upgrade in use packages engineman Linux - Software 2 09-26-2007 12:06 PM
RHEL 5 Yum Update Errors, Pup Broken - Help. maxvonseibold Red Hat 1 08-16-2007 06:33 AM
yum update issue metallica1973 Linux - Software 2 11-14-2006 02:35 PM
Debian unstable - unfixable broken packages after update. Imek Debian 4 07-20-2005 12:23 PM


All times are GMT -5. The time now is 07:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration