LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-28-2007, 02:20 PM   #1
tightface
LQ Newbie
 
Registered: Aug 2006
Posts: 3

Rep: Reputation: 0
yum update gives 'Error: Missing Dependency:" on fresh install


Hi,

I have a fresh install of RHEL5 i386, and it is registered with Redhat to receive all updates but I get the following when trying to do a yum update...

Code:
[root@rh5box /]# yum update
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Setting up Update Process
Setting up repositories
epel                      100% |=========================| 1.1 kB    00:00     
rpmforge                  100% |=========================| 1.1 kB    00:00     
rhel-i386-client-5        100% |=========================| 1.4 kB    00:00     
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 1.1 MB    00:22     
################################################## 3826/3826
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package vim-minimal.i386 2:7.0.109-3.el5.3 set to be updated
---> Package openoffice.org-calc.i386 1:2.0.4-5.4.17.2 set to be updated
---> Package vixie-cron.i386 4:4.1-70.el5 set to be updated
---> Package xorg-x11-apps.i386 0:7.1-4.0.1.el5 set to be updated
---> Package krb5-workstation.i386 0:1.5-26 set to be updated
---> Package krb5-libs.i386 0:1.5-26 set to be updated
---> Package openoffice.org-xsltfilter.i386 1:2.0.4-5.4.17.2 set to be updated
---> Package bind-utils.i386 30:9.3.3-8.el5 set to be updated
---> Package net-snmp-libs.i386 1:5.3.1-14.0.1.el5 set to be updated
---> Package xorg-x11-server-Xvfb.i386 0:1.1.1-48.13.0.1.el5 set to be updated
---> Package libpng.i386 2:1.2.10-7.0.2 set to be updated
---> Package libgcc.i386 0:4.1.1-52.el5.2 set to be updated
---> Package httpd.i386 0:2.2.3-7.el5 set to be updated
---> Package samba-common.i386 0:3.0.23c-2.el5.2.0.2 set to be updated
---> Package cpp.i386 0:4.1.1-52.el5.2 set to be updated
---> Package evolution-data-server.i386 0:1.8.0-15.0.4.el5 set to be updated
---> Package module-init-tools.i386 0:3.3-0.pre3.1.16.0.1.el5 set to be updated
---> Package kernel.i686 0:2.6.18-8.1.6.el5 set to be installed
---> Package evolution.i386 0:2.8.0-33.0.1.el5 set to be updated
---> Package cups-libs.i386 1:1.2.4-11.5.1.el5 set to be updated
---> Package net-snmp-utils.i386 1:5.3.1-14.0.1.el5 set to be updated
---> Package openoffice.org-impress.i386 1:2.0.4-5.4.17.2 set to be updated
---> Package dhclient.i386 12:3.0.5-5.el5 set to be updated
---> Package mutt.i386 5:1.4.2.2-3.0.2.el5 set to be updated
---> Package nss-tools.i386 0:3.11.5-3.el5 set to be updated
---> Package openoffice.org-graphicfilter.i386 1:2.0.4-5.4.17.2 set to be updated
---> Package nss.i386 0:3.11.5-3.el5 set to be updated
---> Package kdebase.i386 6:3.5.4-13.6.el5 set to be updated
---> Package tzdata.noarch 0:2007d-1.el5 set to be updated
---> Package gimp.i386 2:2.2.13-2.el5 set to be updated
---> Package libXfont.i386 0:1.2.2-1.0.2.el5 set to be updated
---> Package samba-client.i386 0:3.0.23c-2.el5.2.0.2 set to be updated
---> Package libgfortran.i386 0:4.1.1-52.el5.2 set to be updated
---> Package autofs.i386 1:5.0.1-0.rc2.43.0.2 set to be updated
---> Package tomcat5-servlet-2.4-api.i386 0:5.5.23-0jpp.1.0.3.el5 set to be updated
---> Package openoffice.org-draw.i386 1:2.0.4-5.4.17.2 set to be updated
---> Package ipsec-tools.i386 0:0.6.5-8.el5 set to be updated
---> Package net-snmp.i386 1:5.3.1-14.0.1.el5 set to be updated
---> Package libexif.i386 0:0.6.13-4.0.2.el5 set to be updated
---> Package cups.i386 1:1.2.4-11.5.1.el5 set to be updated
---> Package vim-common.i386 2:7.0.109-3.el5.3 set to be updated
---> Package xorg-x11-server-Xorg.i386 0:1.1.1-48.13.0.1.el5 set to be updated
---> Package freetype.i386 0:2.2.1-19.el5 set to be updated
---> Package openoffice.org-core.i386 1:2.0.4-5.4.17.2 set to be updated
---> Package tomcat5-jsp-2.0-api.i386 0:5.5.23-0jpp.1.0.3.el5 set to be updated
---> Package xorg-x11-server-Xnest.i386 0:1.1.1-48.13.0.1.el5 set to be updated
---> Package nspr.i386 0:4.6.5-1.0.1.el5 set to be updated
---> Package gimp-libs.i386 2:2.2.13-2.el5 set to be updated
---> Package kernel-headers.i386 0:2.6.18-8.1.6.el5 set to be updated
---> Package bind-libs.i386 30:9.3.3-8.el5 set to be updated
---> Package file.i386 0:4.17-9.0.1.el5 set to be updated
---> Package gcc.i386 0:4.1.1-52.el5.2 set to be updated
---> Package mod_ssl.i386 1:2.2.3-7.el5 set to be updated
---> Package openoffice.org-writer.i386 1:2.0.4-5.4.17.2 set to be updated
---> Package libX11.i386 0:1.0.3-8.0.1.el5 set to be updated
---> Package vim-enhanced.i386 2:7.0.109-3.el5.3 set to be updated
---> Package libgcj.i386 0:4.1.1-52.el5.2 set to be updated
---> Package openoffice.org-math.i386 1:2.0.4-5.4.17.2 set to be updated
---> Package samba.i386 0:3.0.23c-2.el5.2.0.2 set to be updated
---> Package postgresql-libs.i386 0:8.1.9-1.el5 set to be updated
---> Package libwpd.i386 0:0.8.7-3.el5 set to be updated
---> Package ekiga.i386 0:2.0.2-7.0.2 set to be updated
---> Package libgomp.i386 0:4.1.1-52.el5.2 set to be updated
---> Package Deployment_Guide-en-US.noarch 0:5.0.0-21 set to be updated
---> Package libstdc++.i386 0:4.1.1-52.el5.2 set to be updated
---> Package redhat-rpm-config.noarch 0:8.0.45-17.0.1.el5 set to be updated
---> Package gnupg.i386 0:1.4.5-13 set to be updated
---> Package vim-X11.i386 2:7.0.109-3.el5.3 set to be updated
--> Running transaction check
--> Processing Dependency: tomcat5-servlet-2.4-api = 0:5.5.17-8jpp.2 for package: tomcat5-common-lib
--> Processing Dependency: libstdc++ = 4.1.1-52.el5 for package: libstdc++-devel
--> Processing Dependency: libpng = 2:1.2.10-7 for package: libpng-devel
--> Processing Dependency: libXfont = 1.2.2-1.fc6 for package: libXfont-devel
--> Processing Dependency: libgcj = 4.1.1-52.el5 for package: gcc-java
--> Processing Dependency: kdebase = 6:3.5.4-13.5.el5 for package: kdebase-devel
--> Processing Dependency: gcc = 4.1.1-52.el5 for package: gcc-c++
--> Processing Dependency: gcc = 4.1.1-52.el5 for package: gcc-gfortran
--> Processing Dependency: libstdc++ = 4.1.1-52.el5 for package: gcc-c++
--> Processing Dependency: libgcj = 4.1.1-52.el5 for package: libgcj-src
--> Processing Dependency: gcc = 4.1.1-52.el5 for package: gcc-java
--> Processing Dependency: evolution-data-server = 1.8.0-15.el5 for package: evolution-data-server-devel
--> Processing Dependency: libX11 = 1.0.3-8.el5 for package: libX11-devel
--> Processing Dependency: freetype = 2.2.1-16.el5 for package: freetype-devel
--> Processing Dependency: tomcat5-servlet-2.4-api = 0:5.5.17-8jpp.2 for package: tomcat5-jasper
--> Processing Dependency: tomcat5-jsp-2.0-api = 0:5.5.17-8jpp.2 for package: tomcat5-common-lib
--> Processing Dependency: libgcj = 4.1.1-52.el5 for package: libgcj-devel
--> Processing Dependency: httpd = 2.2.3-6.el5 for package: httpd-manual
--> Processing Dependency: krb5-libs = 1.5-17 for package: krb5-devel
--> Processing Dependency: libgfortran = 4.1.1-52.el5 for package: gcc-gfortran
--> Finished Dependency Resolution
Error: Missing Dependency: tomcat5-servlet-2.4-api = 0:5.5.17-8jpp.2 is needed by package tomcat5-common-lib
Error: Missing Dependency: libstdc++ = 4.1.1-52.el5 is needed by package libstdc++-devel
Error: Missing Dependency: libpng = 2:1.2.10-7 is needed by package libpng-devel
Error: Missing Dependency: libXfont = 1.2.2-1.fc6 is needed by package libXfont-devel
Error: Missing Dependency: libgcj = 4.1.1-52.el5 is needed by package gcc-java
Error: Missing Dependency: kdebase = 6:3.5.4-13.5.el5 is needed by package kdebase-devel
Error: Missing Dependency: gcc = 4.1.1-52.el5 is needed by package gcc-c++
Error: Missing Dependency: gcc = 4.1.1-52.el5 is needed by package gcc-gfortran
Error: Missing Dependency: libstdc++ = 4.1.1-52.el5 is needed by package gcc-c++
Error: Missing Dependency: libgcj = 4.1.1-52.el5 is needed by package libgcj-src
Error: Missing Dependency: gcc = 4.1.1-52.el5 is needed by package gcc-java
Error: Missing Dependency: evolution-data-server = 1.8.0-15.el5 is needed by package evolution-data-server-devel
Error: Missing Dependency: libX11 = 1.0.3-8.el5 is needed by package libX11-devel
Error: Missing Dependency: freetype = 2.2.1-16.el5 is needed by package freetype-devel
Error: Missing Dependency: tomcat5-servlet-2.4-api = 0:5.5.17-8jpp.2 is needed by package tomcat5-jasper
Error: Missing Dependency: tomcat5-jsp-2.0-api = 0:5.5.17-8jpp.2 is needed by package tomcat5-common-lib
Error: Missing Dependency: libgcj = 4.1.1-52.el5 is needed by package libgcj-devel
Error: Missing Dependency: httpd = 2.2.3-6.el5 is needed by package httpd-manual
Error: Missing Dependency: krb5-libs = 1.5-17 is needed by package krb5-devel
Error: Missing Dependency: libgfortran = 4.1.1-52.el5 is needed by package gcc-gfortran
[root@rh5box /]#
The thing is, all the dependencies I have checked are already installed, and same version number...
Code:
[root@rh5box /]# rpm -qa |grep libX11
libX11-1.0.3-8.el5
libX11-devel-1.0.3-8.el5
I have tried yum clean all, with the same results. TIA!
 
Old 06-28-2007, 02:29 PM   #2
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
In your case, if you're paying for that, maybe RedHat is the place you should ask, as they are responsible to fix it.

Try to re-create the rpm database just in case
Code:
rpm --rebuilddb
 
Old 06-28-2007, 02:43 PM   #3
tightface
LQ Newbie
 
Registered: Aug 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by b0uncer
In your case, if you're paying for that, maybe RedHat is the place you should ask, as they are responsible to fix it.

Try to re-create the rpm database just in case
Code:
rpm --rebuilddb
Logical you would think. My license is only for access to the FAQ section, no email or phone support. My subscription card says 'Contact vendor for Technical Support' (Dell) I spent ~30 minutes going through the FAQ's, and it is all circa 2004 docs talking about 'up2date'.

I just tried rpm --rebuilddb, but the same outcome...
 
Old 06-29-2007, 07:32 PM   #4
tightface
LQ Newbie
 
Registered: Aug 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Cool

I figured out what the problem was.

I logged in to RHN, and updated my subscription channels to also include the two following channels

RHEL Desktop Workstation (v. 5 for 32-bit x86)
RHEL Desktop Supplementary (v. 5 for 32-bit x86)
 
Old 07-04-2007, 03:10 AM   #5
durgacss
LQ Newbie
 
Registered: Jul 2007
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by tightface
I figured out what the problem was.

I logged in to RHN, and updated my subscription channels to also include the two following channels

RHEL Desktop Workstation (v. 5 for 32-bit x86)
RHEL Desktop Supplementary (v. 5 for 32-bit x86)

Hi,


I am also coming across the same prob... Cud u please tell how to include more subscription channels? As for as i chked it tells only one base channel can be included. i donno how to include more than child channels. Thanx in advance...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
yum update - error. dependency btaylor1988 Linux - Desktop 3 06-11-2007 06:52 AM
Receiving constant error "Missing Dependency: /usr/bin/php is needed" GreenDragonComputers Linux - Software 3 05-09-2007 02:40 AM
On fresh FC5 install, initial "yum update" taking forever lavie Linux - General 1 05-06-2006 06:12 AM
yum install kino - Missing Dependency: libavutil.so schlough Linux - Software 5 01-13-2006 10:07 PM
FC4: "yum update libcddb" fails -- missing dependancy problem: MattCrypto Fedora 2 07-28-2005 07:47 PM


All times are GMT -5. The time now is 07:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration