LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 08-16-2006, 03:01 PM   #1
vegetassj2
Member
 
Registered: Jan 2005
Posts: 201

Rep: Reputation: 30
yum update error


hey,

I haven't updated my system for a long time and now when I run
yum -y update
I get this output(read last 2 lines!!!):

Code:
# yum -y -e0 -t update
Setting up Update Process
Setting up repositories
Dries                                                                [1/10]
freshrpms                                                            [2/10]
Bremen                                                               [3/10]
Macromedia                                                           [4/10]
updates-released                                                     [5/10]
greysector-all                                                       [6/10]
greysector-all-noarch                                                [7/10]
base                                                                 [8/10]
greysector                                                           [9/10]
extras                                                               [10/10]
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package samba.i386 0:3.0.23a-1.fc5.1 set to be updated
---> Package vim-minimal.i386 2:7.0.042-0.fc5 set to be updated
---> Package squirrelmail.noarch 0:1.4.8-1.fc5 set to be updated
---> Package pam.i386 0:0.99.5.0-5.fc5 set to be updated
---> Package nautilus-cd-burner.i386 0:2.14.3-1.fc5 set to be updated
---> Package cairo-java.i386 0:1.0.5-1.fc5 set to be updated
---> Package kernel-devel.i686 0:2.6.17-1.2174_FC5 set to be installed
---> Package cups.i386 1:1.2.2-1.1 set to be updated
---> Package gnome-games.i386 1:2.14.3-1.fc5 set to be updated
---> Package netpbm.i386 0:10.34-1.fc5 set to be updated
---> Package evolution-data-server.i386 0:1.6.3-1.fc5.2 set to be updated
---> Package openoffice.org-impress.i386 1:2.0.2-5.17.2 set to be updated
---> Package gnome-icon-theme.noarch 0:2.14.2-1.fc5.2 set to be updated
---> Package libgconf-java.i386 0:2.12.4-2.fc5 set to be updated
---> Package gnome-desktop.i386 0:2.14.3-1.fc5 set to be updated
---> Package netpbm-progs.i386 0:10.34-1.fc5 set to be updated
---> Package httpd.i386 0:2.2.2-1.2 set to be updated
---> Package firefox.i386 0:1.5.0.6-2.fc5 set to be updated
---> Package libmad.i386 0:0.15.1b-4.fc5.rf set to be updated
---> Package NetworkManager-glib.i386 0:0.6.4-1.fc5 set to be updated
---> Package tcsh.i386 0:6.14-6.fc5.2 set to be updated
---> Package openoffice.org-math.i386 1:2.0.2-5.17.2 set to be updated
---> Package samba-client.i386 0:3.0.23a-1.fc5.1 set to be updated
---> Package evolution.i386 0:2.6.3-1.fc5.5 set to be updated
---> Package xine.i386 0:0.99.4-5.fc5.rf set to be updated
---> Package libsoup.i386 0:2.2.96-1.fc5.1 set to be updated
---> Package xvidcore.i386 0:1.1.0-3.fc5.rf set to be updated
---> Package libwnck.i386 0:2.14.3-1.fc5 set to be updated
---> Package ypbind.i386 3:1.19-1 set to be updated
---> Package openoffice.org-javafilter.i386 1:2.0.2-5.17.2 set to be updated
---> Package kernel.i686 0:2.6.17-1.2174_FC5 set to be installed
---> Package aalib.i386 0:1.4.0-0.8.rc5.fc5 set to be updated
---> Package openoffice.org-testtools.i386 1:2.0.2-5.17.2 set to be updated
---> Package NetworkManager.i386 0:0.6.4-1.fc5 set to be updated
---> Package hal.i386 0:0.5.7.1-2.fc5 set to be updated
---> Package libXfont.i386 0:1.0.0-3 set to be updated
---> Package samba-common.i386 0:3.0.23a-1.fc5.1 set to be updated
---> Package ftp.i386 0:0.17-32.1.2.fc5 set to be updated
---> Package selinux-policy-targeted.noarch 0:2.3.3-8.fc5 set to be updated
---> Package openoffice.org-langpack-de.i386 1:2.0.2-5.17.2 set to be updated
---> Package openoffice.org-writer.i386 1:2.0.2-5.17.2 set to be updated
---> Package selinux-policy.noarch 0:2.3.3-8.fc5 set to be updated
---> Package libgtk-java.i386 0:2.8.6-2.fc5 set to be updated
---> Package krb5-workstation.i386 0:1.4.3-5.1 set to be updated
---> Package nautilus.i386 0:2.14.3-1.fc5 set to be updated
---> Package vim-enhanced.i386 2:7.0.042-0.fc5 set to be updated
---> Package bittorrent.noarch 0:4.4.0-1.fc5.rf set to be updated
---> Package openoffice.org-langpack-nl.i386 1:2.0.2-5.17.2 set to be updated
---> Package gtkhtml3.i386 0:3.10.3-1.fc5.1 set to be updated
---> Package gnome-panel.i386 0:2.14.3-1.fc5 set to be updated
---> Package sendmail.i386 0:8.13.7-2.fc5.2 set to be updated
---> Package gnome-menus.i386 0:2.14.3-1.fc5 set to be updated
---> Package vim-common.i386 2:7.0.042-0.fc5 set to be updated
---> Package openoffice.org-langpack-fr.i386 1:2.0.2-5.17.2 set to be updated
---> Package libtiff.i386 0:3.7.4-8 set to be updated
---> Package openoffice.org-core.i386 1:2.0.2-5.17.2 set to be updated
---> Package sendmail-cf.i386 0:8.13.7-2.fc5.2 set to be updated
---> Package openoffice.org-xsltfilter.i386 1:2.0.2-5.17.2 set to be updated
---> Package gnupg.i386 0:1.4.5-2 set to be updated
---> Package xorg-x11-drv-nv.i386 0:1.2.0-3.fc5 set to be updated
---> Package mtools.i386 0:3.9.10-2.fc5 set to be updated
---> Package perl-Net-DNS.i386 0:0.57-1.fc5.rf set to be updated
---> Package openoffice.org-draw.i386 1:2.0.2-5.17.2 set to be updated
---> Package vcdimager.i386 0:0.7.23-4.fc5.rf set to be updated
---> Package sed.i386 0:4.1.5-4.fc5 set to be updated
---> Package gimp.i386 2:2.2.12-3.fc5 set to be updated
---> Package cups-libs.i386 1:1.2.2-1.1 set to be updated
---> Package openoffice.org-graphicfilter.i386 1:2.0.2-5.17.2 set to be updated
---> Package openoffice.org-pyuno.i386 1:2.0.2-5.17.2 set to be updated
---> Package openoffice.org-calc.i386 1:2.0.2-5.17.2 set to be updated
---> Package SDL_net.i386 0:1.2.6-1.fc5.rf set to be updated
---> Package krb5-libs.i386 0:1.4.3-5.1 set to be updated
---> Package vim-X11.i386 2:7.0.042-0.fc5 set to be updated
---> Package libdvdcss.i386 0:1.2.9-2.fc5.rf set to be updated
---> Package eel2.i386 0:2.14.3-1.fc5 set to be updated
---> Package java-1.4.2-gcj-compat.i386 0:1.4.2.0-40jpp_83rh.1 set to be updated
---> Package glib-java.i386 0:0.2.6-1.fc5 set to be updated
--> Running transaction check
--> Processing Dependency: libgimpui-2.0.so.0 for package: xsane-gimp
--> Processing Dependency: libgimpui-2.0.so.0 for package: gimp-gap
--> Processing Dependency: libgimpui-2.0.so.0 for package: gimp
--> Processing Dependency: libgimpcolor-2.0.so.0 for package: gimp-print-plugin
--> Processing Dependency: libgimpcolor-2.0.so.0 for package: xsane-gimp
--> Processing Dependency: libgimpmath-2.0.so.0 for package: gimp
--> Processing Dependency: libgimpbase-2.0.so.0 for package: gimp
--> Processing Dependency: libgimpmath-2.0.so.0 for package: gimp-gap
--> Processing Dependency: libgimpui-2.0.so.0 for package: gimp-print-plugin
--> Processing Dependency: libgimpthumb-2.0.so.0 for package: gimp
--> Processing Dependency: libgimpwidgets-2.0.so.0 for package: xsane-gimp
--> Processing Dependency: libgimpthumb-2.0.so.0 for package: gimp-gap
--> Processing Dependency: python-khashmir for package: bittorrent
--> Processing Dependency: libgimpmath-2.0.so.0 for package: gimp-print-plugin
--> Processing Dependency: libgimpmath-2.0.so.0 for package: xsane-gimp
--> Processing Dependency: libgimpcolor-2.0.so.0 for package: gimp
--> Processing Conflict: cups conflicts system-config-printer < 0.6.151.3
--> Processing Dependency: libgimpcolor-2.0.so.0 for package: gimp-gap
--> Processing Dependency: libgimp-2.0.so.0 for package: xsane-gimp
--> Processing Dependency: libgimp-2.0.so.0 for package: gimp-gap
--> Processing Dependency: libgimpmodule-2.0.so.0 for package: gimp
--> Processing Dependency: libgimp-2.0.so.0 for package: gimp
--> Processing Dependency: libgimpbase-2.0.so.0 for package: xsane-gimp
--> Processing Dependency: libgimpbase-2.0.so.0 for package: gimp-print-plugin
--> Processing Dependency: libgimpbase-2.0.so.0 for package: gimp-gap
--> Processing Dependency: libgimp-2.0.so.0 for package: gimp-print-plugin
--> Processing Conflict: cups conflicts foomatic < 3.0.2-33.3
--> Processing Dependency: libgimpwidgets-2.0.so.0 for package: gimp
--> Processing Dependency: libgimpwidgets-2.0.so.0 for package: gimp-gap
--> Processing Dependency: libgimpwidgets-2.0.so.0 for package: gimp-print-plugin
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package python-khashmir.noarch 0:4.4.0-1.fc5.rf set to be updated
---> Package gimp-libs.i386 2:2.2.12-3.fc5 set to be updated
--> Running transaction check
--> Processing Conflict: cups conflicts foomatic < 3.0.2-33.3
--> Processing Conflict: cups conflicts system-config-printer < 0.6.151.3
--> Finished Dependency Resolution
Error: cups conflicts with system-config-printer < 0.6.151.3
Error: cups conflicts with foomatic < 3.0.2-33.3
how can I solve this?
thanks
 
Old 08-16-2006, 05:14 PM   #2
PhenuxRizing
Member
 
Registered: Feb 2004
Distribution: Fedora
Posts: 59

Rep: Reputation: 15
Thumbs up

Try removing the cups packages, running yum update, and then reinstalling cups using "yum install cups".

It doesn't happen much but every now and then updates conflict while using yum. Give it a try and let me know how it works.
 
Old 08-17-2006, 12:03 AM   #3
bluelightning
Member
 
Registered: Mar 2006
Location: Redmond, WA
Distribution: FC4, WinXP Pro
Posts: 37

Rep: Reputation: 15
I would avoid uninstalling cups. Too many things depend on it. Often though, if you update the rest of your system, then these conflicts disappear.

Try running this to update everything except cups. Afterwards, try updating cups again:
yum --exclude=cups update
 
Old 09-06-2006, 08:28 PM   #4
rioguia
Member
 
Registered: Jun 2002
Posts: 411

Rep: Reputation: 30
sudo yum -y --exclude=cups --exclude cups-libs update

i agree but would suggest trying
sudo yum -y --exclude=cups --exclude cups-libs update
 
Old 09-07-2006, 01:01 PM   #5
vegetassj2
Member
 
Registered: Jan 2005
Posts: 201

Original Poster
Rep: Reputation: 30
yes, I did this a while:
yum -y --exclude="cups*" update

but later I removed the foomatic thing.
then I installed it back and now everything updates fine
 
  


Reply

Tags
cups, update, yum


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yum update error natewlew Fedora 9 08-16-2008 12:22 AM
yum update is giving error namit Linux - Software 14 07-20-2007 12:02 PM
yum chec-update error linux juggler Fedora 9 09-06-2005 01:20 AM
Yum Update error fcoutel Red Hat 1 12-30-2004 10:22 AM
Error message using yum update Seventh_Warrior Fedora 7 06-23-2004 12:47 PM


All times are GMT -5. The time now is 11:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration