LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   yum install php-mysql fails with mysql 5.1 - "Error: mysql conflicts with MySQL" (http://www.linuxquestions.org/questions/linux-software-2/yum-install-php-mysql-fails-with-mysql-5-1-error-mysql-conflicts-with-mysql-710878/)

rebelde 03-11-2009 06:03 PM

yum install php-mysql fails with mysql 5.1 - "Error: mysql conflicts with MySQL"
 
I can't figure this out.

CentOS5
I've installed MySQL 5.1.32 (client and server).
I've used the standard PHP (5.1.6) and Apache (2.2.3) that came with the OS.

Wanting PHP to talk to MySQL, I try:
yum install php-mysql

I get the error:
Error: mysql conflicts with MySQL

Any ideas?

(I wish I could just run the PHP configure command '--with-mysql',but have no idea how to do that with yum.)

Thanks!

j-ray 03-12-2009 06:12 AM

Welcome!
I don't know whether the problem is obvious or not. The driver's version is lower than the installed mysql server and client. So I think there are 2 clean solutions possible:

1. Install everything from source
2. Install everything with your distro's packet manager

Personally I recommend the first as it gives you more freedom in the long run.
Cheers, J.

rebelde 03-13-2009 10:32 AM

Thanks!

I was hoping for a third option.

I chose #2 for now just to keep it easy. I'm back on MySQL 5.0 for now. When I find the time, I'll probably go with route #1 to get the advantages of the newer software, such as security bug fixes.


All times are GMT -5. The time now is 04:12 AM.