LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Yum error: Cannot find a valid baseurl for repo: (http://www.linuxquestions.org/questions/linux-software-2/yum-error-cannot-find-a-valid-baseurl-for-repo-478600/)

BogusTrumper 08-29-2006 07:22 PM

Yum error: Cannot find a valid baseurl for repo:
 
I'm getting an error running yum on my Fedora 4 system.

Here's what I type:
sudo yum check-update

This returns:
Setting up repositories
Cannot find a valid baseurl for repo: updates-released
Error: Cannot find a valid baseurl for repo: updates-released

I have a system running Fedora 5 on the same network with identical DNS entries in resolv.conf and very similar files in yum.repos.d, and yum works just fine on it. This is a machine that was formerly on a different network (different IP, different subnet, etc) with presumably different DNS servers, so I'm betting there's some sort of configuration change that I'm forgetting to do?

Formerly everything was done via static IP, and the new network uses DHCP. I attempted to switch to DHCP, get the new address, and then lock that address down as a static address since addresses don't change often on this network. I'm having no problems accessing this machine through SSH, but I cannot access the web from it without knowing the IP address of the site in question. This makes me think there's something wrong with my DNS configuration, but I don't know what to change about it. Anybody have any advice?

LiNuXkOlOnIe 08-30-2006 03:53 AM

Hi, i am using Fedora since Fedora 2 Core and this problem
i had often. Try some yum clean all.
If you need the downloaded packages the go to /var/log/cache/yum. But there only there if you have
configured it.

So we come to the next point. Configuration is in /etc/yum.repos.d. Every repository-file is ended with an
.repo. So you can check there too.

Sometimes if my connection is overloaded with downloading files
and i try an yum update i have this problem too.

The other thing is you can use the gui-version yumex too.

I hope i could help.

cu

BogusTrumper 08-30-2006 05:46 PM

Hi,

I'm thinking this isn't actually a yum problem. Everything's cleaned, and in addition to yum having this same error finding the repository, I can't load webpages, I can't use wget without an IP address, etc. What I can't figure out is why this is, since as far as I can tell it's using the same DNS servers as other functioning computers?

BogusTrumper 08-30-2006 06:04 PM

I think I've figured it out. So, what I did was start with DHCP then switch back to static. I just read that switching between the two can affect DNS information, so I ran dhclient and everything works now. Not sure why this had to be the case, but just in case anybody ever encounters this strange set of circumstances, that's the problem.

igoruch 10-25-2006 07:44 AM

I did have the same error recently with my FC5 after latest update. The problem was that yum could not find a mirror and baseurl was commented - so I did uncomment it and it worked for me.

deardoom 10-25-2006 11:17 AM

I'm getting this error with FC 4. Which file did you
edit to uncomment baseurl ?

Thanks Dekc

0x44 10-25-2006 02:16 PM

Ran into this issue this morning with some FC4 boxes.

Some files in /etc/yum.repos.d/ had commented baseurls as igoruch remarked. Run yum, uncomment baseurl in file described in yum's error message, repeat. This got my boxes working.

phoenix_hacker 10-25-2006 02:48 PM

Oh! Please tell me how to uncomment it! Thanx in advance!!
Quote:

Originally Posted by igoruch
I did have the same error recently with my FC5 after latest update. The problem was that yum could not find a mirror and baseurl was commented - so I did uncomment it and it worked for me.


UMTopSpinC7 10-25-2006 08:49 PM

Just delete the # in front of the line that has base-url in it. I just had the same problem too and uncommenting fixes it. You might have to uncomment the line in multiple .repo files... i know i did.

daihard 10-25-2006 08:59 PM

Quote:

Originally Posted by UMTopSpinC7
Just delete the # in front of the line that has base-url in it. I just had the same problem too and uncommenting fixes it. You might have to uncomment the line in multiple .repo files... i know i did.

The problem is still there. Looks like the main issue is that the Fedora Core site (http://fedora.redhat.com) is down at the moment, and the mirrorlist is right there. Once the site is back up, yum should work again.

bskrakes 05-13-2007 11:10 AM

YUM update - no base url found - Fedora Core 6
 
I had the same problem with Fedora Core 6. All of the config files regarding /etc/yum.repos.d/* has the baseurl line commented out. Why the heck would the system change this - I did not change anything. Just kind of curious why the system would do it on its own or if it was user affected?

Thanks!

akilenc 05-18-2007 03:12 AM

YUM update - no base url found - Fedora Core 6
 
I had the same problem,

I followed the posting by "LiNuXkOlOnIe".

Everything works now. Not sure why this had to be the case, but it is gone.

Akilen

animeshsaxena 05-22-2007 11:17 PM

cd /etc/yum.repos.d.



then


you'll need to remove '#' from the beginning of the baseurl line.

i faced the same problem and somehow this small changed fixed the issue.

Hope this helps ;)

JSUN 05-30-2007 10:35 AM

I work for a big corporation and came across this problem with Fedora Core 5/6.

From these posts, I removed the '#' from the *.repo files in /etc/yum.repos.d/, but still was experiencing the connection error.

Like some of the others, I could not access the internet - and found that there was a proxy that I needed in this corporation - but still yum was not working - "cannot find a valid baseurl for repo" whether I was working with the command line or the GUI interface in gnome.

But finally found that there were two other items that I needed:
1) In Network Configuration -> DNS -> DNS search path: I added other server names: dns, dhcp, wins, eda
2) Network Proxy Preferences -> Manual proxy configuration -> cache1.domainname, Port 80 (at least in my corporation).

All of a sudden it began to work - and yum is a whole heck of a lot better then installing each of the packages I needed for DekiWiki seperately.

ARGH! But better now ... JSUN

demirsha 07-09-2007 10:52 AM

Hello. I had the same problem.
To resolv it I proceded like this:
- I changed all "enabled" parameters from 1 to 0 in all files from /etc/yum.repos.d (when needed)

Obs: No more internet usage
I didn't delete any #

Don't ask me why, I did it and it worked.


All times are GMT -5. The time now is 09:08 AM.