LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-07-2010, 07:38 AM   #1
athomas
Member
 
Registered: May 2009
Location: Eastern Shore, MD, USA
Distribution: CentOS 5.5
Posts: 184

Rep: Reputation: 15
Yum Dependency Issues...


I'm working on getting PHP with MySQL installed (on an offline server) and I'm getting the following:

Code:
gnupg-1.4.5-14.x86_64 from installed has depsolving problems
  --> Missing Dependency: libcurl.so.3()(64bit) is needed by package gnupg-1.4.5-14.x86_64 (installed)
gnome-vfs2-smb-2.16.2-4.el5.x86_64 from installed has depsolving problems
  --> Missing Dependency: libsmbclient.so.0()(64bit) is needed by package gnome-vfs2-smb-2.16.2-4.el5.x86_64 (installed)
dbus-libs-1.1.2-12.el5.x86_64 from installed has depsolving problems
  --> Missing Dependency: dbus = 1.1.2-12.el5 is needed by package dbus-libs-1.1.2-12.el5.x86_64 (installed)
kvm-qemu-img-83-105.el5.x86_64 from installed has depsolving problems
  --> Missing Dependency: liblog4cpp.so.4()(64bit) is needed by package kvm-qemu-img-83-105.el5.x86_64 (installed)
passwd-0.73-1.x86_64 from installed has depsolving problems
  --> Missing Dependency: libuser.so.1()(64bit) is needed by package passwd-0.73-1.x86_64 (installed)
setuptool-1.19.2-1.el5.centos.x86_64 from installed has depsolving problems
  --> Missing Dependency: libnewt.so.0.52()(64bit) is needed by package setuptool-1.19.2-1.el5.centos.x86_64 (installed)
1:autofs-5.0.1-0.rc2.143.el5.i386 from OS has depsolving problems
  --> autofs conflicts with cyrus-sasl-lib
cadaver-0.22.3-4.el5.x86_64 from installed has depsolving problems
  --> Missing Dependency: libneon.so.25()(64bit) is needed by package cadaver-0.22.3-4.el5.x86_64 (installed)
1:openoffice.org-core-2.3.0-6.11.el5.x86_64 from installed has depsolving problems
  --> Missing Dependency: libcurl.so.3()(64bit) is needed by package 1:openoffice.org-core-2.3.0-6.11.el5.x86_64 (installed)
orca-1.0.0-5.el5.x86_64 from installed has depsolving problems
  --> Missing Dependency: libbrlapi.so.0.4()(64bit) is needed by package orca-1.0.0-5.el5.x86_64 (installed)
setuptool-1.19.2-1.el5.centos.x86_64 from installed has depsolving problems
  --> Missing Dependency: libnewt.so.0.52(NEWT_0.52)(64bit) is needed by package setuptool-1.19.2-1.el5.centos.x86_64 (installed)
usermode-1.88-3.el5.2.x86_64 from installed has depsolving problems
  --> Missing Dependency: libuser.so.1()(64bit) is needed by package usermode-1.88-3.el5.2.x86_64 (installed)
ccid-1.3.8-1.el5.x86_64 from installed has depsolving problems
  --> Missing Dependency: libpcsclite.so.1()(64bit) is needed by package ccid-1.3.8-1.el5.x86_64 (installed)
PyQt-3.16-4.x86_64 from installed has depsolving problems
  --> Missing Dependency: libGLU.so.1()(64bit) is needed by package PyQt-3.16-4.x86_64 (installed)
qspice-libs-0.3.0-39.el5.x86_64 from installed has depsolving problems
  --> Missing Dependency: libGLU.so.1()(64bit) is needed by package qspice-libs-0.3.0-39.el5.x86_64 (installed)
ppp-2.4.4-2.el5.x86_64 from installed has depsolving problems
  --> Missing Dependency: libpcap.so.0.9.4()(64bit) is needed by package ppp-2.4.4-2.el5.x86_64 (installed)
Error: Missing Dependency: libcurl.so.3()(64bit) is needed by package 1:openoffice.org-core-2.3.0-6.11.el5.x86_64 (installed)
Error: Missing Dependency: liblog4cpp.so.4()(64bit) is needed by package kvm-qemu-img-83-105.el5.x86_64 (installed)
Error: Missing Dependency: libGLU.so.1()(64bit) is needed by package PyQt-3.16-4.x86_64 (installed)
Error: Missing Dependency: libnewt.so.0.52()(64bit) is needed by package setuptool-1.19.2-1.el5.centos.x86_64 (installed)
Error: Missing Dependency: libpcap.so.0.9.4()(64bit) is needed by package ppp-2.4.4-2.el5.x86_64 (installed)
Error: Missing Dependency: libuser.so.1()(64bit) is needed by package usermode-1.88-3.el5.2.x86_64 (installed)
Error: Missing Dependency: libuser.so.1()(64bit) is needed by package passwd-0.73-1.x86_64 (installed)
Error: Missing Dependency: libcurl.so.3()(64bit) is needed by package gnupg-1.4.5-14.x86_64 (installed)
Error: Missing Dependency: libnewt.so.0.52(NEWT_0.52)(64bit) is needed by package setuptool-1.19.2-1.el5.centos.x86_64 (installed)
Error: Missing Dependency: libbrlapi.so.0.4()(64bit) is needed by package orca-1.0.0-5.el5.x86_64 (installed)
Error: Missing Dependency: dbus = 1.1.2-12.el5 is needed by package dbus-libs-1.1.2-12.el5.x86_64 (installed)
Error: Missing Dependency: libneon.so.25()(64bit) is needed by package cadaver-0.22.3-4.el5.x86_64 (installed)
Error: Missing Dependency: libsmbclient.so.0()(64bit) is needed by package gnome-vfs2-smb-2.16.2-4.el5.x86_64 (installed)
Error: Missing Dependency: libpcsclite.so.1()(64bit) is needed by package ccid-1.3.8-1.el5.x86_64 (installed)
Error: autofs conflicts with cyrus-sasl-lib
Error: Missing Dependency: libGLU.so.1()(64bit) is needed by package qspice-libs-0.3.0-39.el5.x86_64 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
I don't even know where to begin with this one... Any suggestions?!
 
Old 09-07-2010, 10:42 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,470
Blog Entries: 54

Rep: Reputation: 2900Reputation: 2900Reputation: 2900Reputation: 2900Reputation: 2900Reputation: 2900Reputation: 2900Reputation: 2900Reputation: 2900Reputation: 2900Reputation: 2900
Which repos are you mixing and what's your complete command line for this action?
 
Old 09-07-2010, 10:48 AM   #3
athomas
Member
 
Registered: May 2009
Location: Eastern Shore, MD, USA
Distribution: CentOS 5.5
Posts: 184

Original Poster
Rep: Reputation: 15
Whoops, forgot to mention repos... It's a local repo server, I have the entire CentOS repo on a server here.

Doing yum install php-devel
 
Old 09-07-2010, 11:40 AM   #4
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Debian, OS X
Posts: 1,267

Rep: Reputation: 99
See if you can run the below commands successfully and then install again.
Code:
yum clean all	
yum clean metadata
yum list all	
yum grouplist
 
Old 09-07-2010, 11:54 AM   #5
athomas
Member
 
Registered: May 2009
Location: Eastern Shore, MD, USA
Distribution: CentOS 5.5
Posts: 184

Original Poster
Rep: Reputation: 15
Whoops I did a "yum update" there. I ran what you suggested and it didn't seem to help. Same dep's issues as before.
 
Old 09-07-2010, 12:06 PM   #6
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Rep: Reputation: 55
Quote:
Originally Posted by athomas View Post
Whoops I did a "yum update" there. I ran what you suggested and it didn't seem to help. Same dep's issues as before.
Dear athomas,

It seems your local yum repository is not properly configured. Because php-devel dependencies would be available in a repository which is created from centos iso.

check weather old cache is cleared under
Code:
/var/cache/yum/

What does below commands give ?
Code:
yum groupinfo
yum list all

Last edited by vinaytp; 09-07-2010 at 12:09 PM.
 
Old 09-07-2010, 12:12 PM   #7
athomas
Member
 
Registered: May 2009
Location: Eastern Shore, MD, USA
Distribution: CentOS 5.5
Posts: 184

Original Poster
Rep: Reputation: 15
yum list all lists about three pages of various packages. Yum groupinfo doesn't seem to be a valid command.
 
Old 09-07-2010, 12:20 PM   #8
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Debian, OS X
Posts: 1,267

Rep: Reputation: 99
Could you please post your repo file ?
 
Old 09-07-2010, 10:02 PM   #9
John VV
Guru
 
Registered: Aug 2005
Posts: 13,057

Rep: Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741
Quote:
I have the entire CentOS repo on a server here.
??? so you made a 40+ gig repo ????? and put it on some server someplace , instead of using the already supported and updated Cent repos ?
then you are trying to use this for a OFFLINE and NOT connected to the net computer.

the full lamp stack is in the base cent repo and in on the centos5.5 install dvd ( though the install dvd IS OUT OF DATE )
there is an option to install all of this on the install screens when you first install cent 5.5
please see:
http://wiki.centos.org/AdditionalResources
http://wiki.centos.org/AdditionalResources/Repositories

also this is not the right command "yum list all"
that lists ALL the rpms installed on the computer

vikas027 posted the wrong commands
unSpawn was asking about this -- and this would have been the command to run
Code:
yum repolist all
in rhel5/CentOS 5 there ARE A BUNCH of conflicting repos
some are NOT binary compatible , that is why the yum plugin "priories" is SO VERY IMPORTANT to set up and have configured CORRECTLY
this is what vikas027 should have posted
Code:
yum clean all 
rpm --rebuilddb 
yum update
sometimes , do to yum /python error, the "rpm --rebuilddb " needs to be ran first

remember that CentOS5/RHEL 5 is and was DESIGNED for the headless server first and foremost , then the office/laboratory secondly .
 
Old 09-08-2010, 08:29 AM   #10
athomas
Member
 
Registered: May 2009
Location: Eastern Shore, MD, USA
Distribution: CentOS 5.5
Posts: 184

Original Poster
Rep: Reputation: 15
Yes, this server is connected to an offline testing/development lab for government proprietary software. Of course it's offline.

Tried yum --rebuilddb, no such command.
 
Old 09-08-2010, 04:32 PM   #11
John VV
Guru
 
Registered: Aug 2005
Posts: 13,057

Rep: Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741
well EVERYTHING is already on the install dvd , it is out of date but
apache.mysql,php is there and installed BY DEFAULT


but if you need to keep it off line then uninstall yum ( you will never need it or be able to use it )
and install the lamp stack from source , that is very easy and the RECOMMENDED way to install the lamp stack
the rpm's only shave about 30 min. off the install.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing dependency issues installing MRTG from yum GavB Linux - Software 5 02-18-2008 09:01 AM
yum dependency issues nick623 Fedora 14 04-25-2007 03:00 AM
yum update dependency issues ZeroIdea Linux - Desktop 1 09-24-2006 04:44 AM
yum update dependency issues ZeroIdea Linux - Newbie 1 09-23-2006 10:24 PM


All times are GMT -5. The time now is 06:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration