LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-17-2004, 01:54 AM   #1
winchester169
Member
 
Registered: Mar 2004
Posts: 31

Rep: Reputation: 15
yet another upgrade/update question, which is best


which updage/upgrade package manager is best to use?
apt-get
yum
up2date

thanks
 
Old 09-17-2004, 03:54 AM   #2
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
Posting your distro would probably help here. If your using RH/Fedora I'd say up2date. Most distro's have their prefered update managers. I've fallen in love with both yast and swaret. Emerge is the bomb, but gentoo is sometime "not fun".

Post the distro and I'll try to make a more educated reason on why you should use one of them
 
Old 09-17-2004, 03:42 PM   #3
winchester169
Member
 
Registered: Mar 2004
Posts: 31

Original Poster
Rep: Reputation: 15
Distro

Sorry, was late at night, brain not in its socket.

Fedora Core 1 upgraded to 2 via yum some time ago.

Since the upgrade up2date and yum give me the errors.

-[up2date]-
Unresolvable chain of dependencies:
XFree86-Xnest-4.3.0-55 requires XFree86 = 4.3.0-55
XFree86-Xvfb-4.3.0-55 requires XFree86 = 4.3.0-55
XFree86-devel-4.3.0-55 requires XFree86-libs = 4.3.0-55
XFree86-tools 4.3.0-55 requires XFree86
XFree86-twm 4.3.0-55 requires XFree86
XFree86-twm-4.3.0-55 requires XFree86-libs = 4.3.0-55
XFree86-xdm-4.3.0-55 requires XFree86 = 4.3.0
apt 0.5.15cnc6-0.1.fc1.fr requires librpm-4.2.so
apt 0.5.15cnc6-0.1.fc1.fr requires librpmdb-4.2.so
apt 0.5.15cnc6-0.1.fc1.fr requires librpmio-4.2.so
fedora-logos-1.1.24-1 requires kdebase <= 3.1.5
kdebase 3.1.4-7 requires libsensors.so.2
kdegames-3.2.2-1 requires kdebase >= 6:3.2.2
kdenetwork-3.2.2-1 requires kdebase >= 6:3.2.2
libc-client 2002e-5 requires imap
redhat-config-bind 2.0.0-18 requires /usr/bin/python2.2
redhat-config-kickstart 2.4.2-1 requires /usr/bin/python2.2
redhat-config-mouse 1.1.2-1 requires /usr/bin/python2.2
redhat-config-nfs 1.1.3-1 requires /usr/bin/python2.2
redhat-config-samba 1.1.4-1 requires /usr/bin/python2.2
redhat-config-users 1.2.4-1 requires /usr/bin/python2.2
spamassassin-tools-2.63-1 requires perl-Mail-SpamAssassin = 2.63-1

-[yum]-
.Package spamassassin-tools needs perl-Mail-SpamAssassin = 2.63-1, this is not available.
Package apt needs librpm-4.2.so, this is not available.
Package apt needs librpmdb-4.2.so, this is not available.
Package apt needs librpmio-4.2.so, this is not available.
Package redhat-config-date needs /usr/bin/python2.2, this is not available.
Package redhat-config-keyboard needs /usr/bin/python2.2, this is not available.
Package redhat-config-language needs /usr/bin/python2.2, this is not available.
Package redhat-config-mouse needs /usr/bin/python2.2, this is not available.
Package redhat-config-network-tui needs /usr/bin/python2.2, this is not available.
Package redhat-config-rootpassword needs /usr/bin/python2.2, this is not available.
Package redhat-config-securitylevel needs /usr/bin/python2.2, this is not available.
Package redhat-config-soundcard needs /usr/bin/python2.2, this is not available.
Package redhat-config-bind needs /usr/bin/python2.2, this is not available.
Package redhat-config-kickstart needs /usr/bin/python2.2, this is not available.
Package redhat-config-nfs needs /usr/bin/python2.2, this is not available.
Package redhat-config-samba needs /usr/bin/python2.2, this is not available.
Package redhat-config-users needs /usr/bin/python2.2, this is not available.
Package redhat-config-xfree86 needs /usr/bin/python2.2, this is not available.

but apt-get seems to work without a problem.

I tried using apt-get remove python and then reinstalled via apt-get to remove the errors (thought that maybe files didnt point to where the should have been)

I have not installed 100% RPM's I have rolled alot of my own source for installs (QMail Samba etc)

I should let you know I am still fairly new to the Linux world, 2 years and have a lot of undiscovered country to deal with.
 
Old 09-17-2004, 06:24 PM   #4
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
I'd stay with up2date cause that would manage the rpm database. Although if you are installing many packages from source, it wouldn't help track it.
 
Old 09-17-2004, 07:40 PM   #5
winchester169
Member
 
Registered: Mar 2004
Posts: 31

Original Poster
Rep: Reputation: 15
up2date

so, how do I solve those
[package] requires /usr/bin/python2.2
messages?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Update -vs Upgrade carlosinfl Debian 14 10-30-2011 01:06 PM
apt-get update/upgrade Red Squirrel Linux - Software 26 07-11-2005 11:14 PM
Yum upgrade/update question stefaandk Linux - Newbie 1 06-23-2005 12:04 AM
Update and Upgrade DebianNew Linux - Newbie 4 01-19-2005 07:02 AM
upgrade/update syl20 Linux - Software 2 06-14-2004 10:45 AM


All times are GMT -5. The time now is 08:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration