LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-20-2005, 11:26 PM   #1
fatblueduck
Member
 
Registered: Dec 2003
Location: Long Beach, CA
Distribution: haven't settled on one.
Posts: 251

Rep: Reputation: 30
xwindows can't detect the mouse


The mouse's light is on.
When I run dmesg, I can see that the optical mouse has been detected.
I have usb HID compiled in the kernel.

I can't figure out why my mouse is not detected.

For reasons which are tedious to explain, I am having to use XFree86 and the 2.4 kernel. The distribution that is being used is arch linux 0.6.

Before puking out, Xfree gives me these error messages.

Code:
(EE) xf86OpenSerial: Cannot  open device /dev/mouse
No such file or directory
(EE) Mouse1: cannot open input device
(EE) PreInit failed for input device "Mouse1"
no core pointer

Fatal server error:
Failed to initialize core devices
I've tried changing the mouse device around from /dev/mouse to /dev/input/mice, but that doesn't work

indeed, when I look in the /dev directory, there is not a further mouse or input directory inside of it.

Any ideas?
 
Old 04-20-2005, 11:40 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
For usb rodents it's commonly
/dev/input/mice


Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting Mouse without Xwindows longnam Debian 2 03-22-2005 12:34 PM
running Mouse without Xwindows longnam Slackware 3 03-22-2005 11:31 AM
mouse xwindows naminator Linux - Newbie 1 08-18-2003 01:48 PM
No mouse... No Xwindows MasterC Linux - General 14 07-15-2002 10:22 AM
Xwindows mouse problem syxxpac023 Linux - Newbie 3 10-29-2001 10:52 AM


All times are GMT -5. The time now is 07:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration