LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-08-2006, 01:53 AM   #1
WojtekO
Member
 
Registered: May 2006
Distribution: CentOS 5
Posts: 47

Rep: Reputation: 15
Xvnc will not start (CentOS vps)


Hello folks,

I just got a nice CentOS vps and I'm trying to install vnc on it.

I ran the yum install and it installed it.

Code:
root@vps [/root/.vnc]# vncserver

New 'vps.host.net:1 (root)' desktop is vps.host.net:1

Starting applications specified in /root/.vnc/xstartup
Log file is /root/.vnc/vps.host.net:1.log



root@vps [/root/.vnc]# nano vps.host.net:1.log

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/vps.host.net:1
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

Xvnc version 4.0 - built Feb 21 2005 15:50:07
Underlying X server release 60801000, The X.Org Foundation


Tue Nov  7 21:34:51 2006
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5901
 vncext:      Listening for HTTP connections on port 5801
 vncext:      created VNC server for screen 0
error opening security policy file /usr/X11R6/lib/X11/xserver/SecurityPolicy
Could not init font path element /usr/X11R6/lib/X11/fonts/misc/, removing from $
Could not init font path element /usr/X11R6/lib/X11/fonts/TTF/, removing from l$
Could not init font path element /usr/X11R6/lib/X11/fonts/Type1/, removing from$
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from l$
Could not init font path element /usr/X11R6/lib/X11/fonts/75dpi/, removing from$

Fatal server error:
could not open default font 'fixed'
/root/.vnc/xstartup: line 9: xsetroot: command not found
/root/.vnc/xstartup: line 11: xterm: command not found
/root/.vnc/xstartup: line 12: twm: command not found
vncconfig: unable to open display "vps.host.net:1"
When I do netstat -a, it does not show anywhere vnc or 5901 or similar vnc stuff.

Any solutions?
Thank You
 
Old 11-09-2006, 05:51 PM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Check out this link to see if all is setup. http://fedoranews.org/tchung/vnc/
Also make sure the 5901 port is open if a firewall is active. Same may apply if using selinux.

Brian
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xvnc couldn't start-->trying to run vnc..... pablovschby Linux - Networking 14 10-20-2012 03:19 AM
CentOS 4.2, Making Apache, and VsFTP Start at bootup adnonimape Linux - Software 1 03-22-2006 05:08 AM
Where can I download UML VPS or Xen VPS to make a virtual private server? abefroman Linux - Software 3 12-09-2005 10:00 AM
start LDAP on CENTOS! mumux Linux - Software 5 08-10-2005 06:00 PM
update centos 4 rc1 to centos 4 trou yum? maxut cAos 2 03-04-2005 02:36 AM


All times are GMT -5. The time now is 01:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration