LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-08-2004, 10:25 AM   #1
ivanatora
Member
 
Registered: Sep 2003
Location: Bulgaria
Distribution: Ubuntu 9.10, FreeBSD 7.2
Posts: 459

Rep: Reputation: 31
Xvidcap can't capture mpegs


I tried over a week.. tried source installs, tried precompiled tgz's, tried different ffmpeg versions..
When I try to shot a movie captured from my desktop it always says: codec not found!
The last time I compiled it with ./configure --with-forced-embedded-ffmpeg and made it with some troubles (I had to symlink one .h file to another in a subdirectory). I searched the web but didn't find that problem discussed anywhere.
Can you give me some tips?
Last tried versions:
xvidcap-1.1.3
ffmpeg 0.4.6

PS. If I try to compile it without --with-forced-embedded-ffmpeg, I got the 'pow' error, described in the documentation, but when I try the solution described there I got another errors.
 
Old 12-08-2004, 11:05 AM   #2
ivanatora
Member
 
Registered: Sep 2003
Location: Bulgaria
Distribution: Ubuntu 9.10, FreeBSD 7.2
Posts: 459

Original Poster
Rep: Reputation: 31
I tried with ffmpeg 0.4.8 and without --embeded-ffmpeg, and here is the error:

xtoffmpeg.c: In function `XImageToFFMPEG':
xtoffmpeg.c:1120: warning: passing arg 2 of `av_write_frame' makes pointer from integer without a cast
xtoffmpeg.c:1120: error: too many arguments to function `av_write_frame'

If you could solve that will be sufficient..


PS. I forgot to mention.. When I run the compiled xvid I get the following output immediately after the GUI appears:
Output not a video file or no counter in filename
Disabling autocontinue!
That is even before I try to record the video. The filename is 'test.mpeg'. If I change it with somestring.xwd it captures only different frames into xwd (X Windows Dump), but NOT mpeg

Last edited by ivanatora; 12-08-2004 at 11:12 AM.
 
Old 12-08-2004, 01:09 PM   #3
ivanatora
Member
 
Registered: Sep 2003
Location: Bulgaria
Distribution: Ubuntu 9.10, FreeBSD 7.2
Posts: 459

Original Poster
Rep: Reputation: 31
Anyone?..
 
Old 12-08-2004, 11:47 PM   #4
tanm
LQ Newbie
 
Registered: Dec 2004
Location: Malaysia
Distribution: RH Fc1
Posts: 13

Rep: Reputation: 0
Does this help?
mplayer -vo mpegpes vcd://
my xvidcap fail too

tanm
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xvidcap aerogate Mandriva 2 12-05-2005 10:21 AM
"libpng missing" on xvidcap compilation ( Slack 10.2 ) Enjo Linux - Software 2 11-15-2005 01:13 PM
mpegs Bob Vila Linux - Software 2 12-03-2003 02:37 PM
How To Play Mpegs lil213 Linux - Software 2 10-14-2003 04:26 PM
Capture support for dvd and video capture in linux is it even going to be real ever? maximalred Linux - Distributions 3 07-06-2003 08:29 PM


All times are GMT -5. The time now is 07:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration