LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 03-28-2003, 07:05 PM   #1
chlee
LQ Newbie
 
Registered: Jun 2002
Location: melbourne, australia
Distribution: slackware 9.0
Posts: 29

Rep: Reputation: 15
xterm config


hi,

i just recenty installed slackware 9.0
and xterm is giving me grief


i was wonderign if anyone new the command line commands for starting xterm such
that

it has a scrollbar on the left
and also

if i do a command liek man or vi
when i quit those programs
how do i make it so it donest clear the screen
ie, the prompt jstu comes up from the bottom of the screen without removing wat was on teh screen
 
Old 03-29-2003, 05:20 PM   #2
chlee
LQ Newbie
 
Registered: Jun 2002
Location: melbourne, australia
Distribution: slackware 9.0
Posts: 29

Original Poster
Rep: Reputation: 15
nobody has any ideas?
 
Old 03-30-2003, 01:33 AM   #3
doublefailure
Member
 
Registered: Mar 2002
Location: ma
Distribution: slackware
Posts: 747

Rep: Reputation: 30
about the scroll bar position, u can change it under 'setting' menu
my xterm doesn't clean screen after man or vi
maybe u can check setting menu to control it

gl
 
Old 03-30-2003, 02:17 AM   #4
cuckoopint
Member
 
Registered: Feb 2003
Distribution: Debian
Posts: 797

Rep: Reputation: 30
man xterm:

-leftbar - left side bar

maybe you have a .bashrc or something, that clears your entry...? (kind of a stretch)
 
Old 03-31-2003, 08:42 AM   #5
mtb
Member
 
Registered: Nov 2002
Location: Italy
Distribution: Linux Mint 17 Xfce
Posts: 277

Rep: Reputation: 30
And talking about xterm..

I have problems with the home and and keys: they doesn't work ( they work fine in a rxvt ).

Some ideas?
 
Old 04-01-2003, 02:08 AM   #6
doublefailure
Member
 
Registered: Mar 2002
Location: ma
Distribution: slackware
Posts: 747

Rep: Reputation: 30
hmm.. i don't use home and end keys , but they seem to work fine on mine.
why don't u use ctrl-a ctrl-e
it's emacs binding .. faster than hitting home/end
 
Old 04-01-2003, 02:22 AM   #7
mtb
Member
 
Registered: Nov 2002
Location: Italy
Distribution: Linux Mint 17 Xfce
Posts: 277

Rep: Reputation: 30
Thank you, good idea ( my habit was to use shift +right arrow or shift +left arrow, i have moreless never used home and end, and a pc )

Quote:
Originally posted by doublefailure
hmm.. i don't use home and end keys , but they seem to work fine on mine.
why don't u use ctrl-a ctrl-e
it's emacs binding .. faster than hitting home/end
 
Old 04-01-2003, 02:36 AM   #8
doublefailure
Member
 
Registered: Mar 2002
Location: ma
Distribution: slackware
Posts: 747

Rep: Reputation: 30
nope

other useful bindings are
ctrl-r ctrl-s : history lookup
ctrl-/ : undo
alt-b alt-f : word back forward
 
Old 05-14-2003, 11:28 AM   #9
itsjustme
Senior Member
 
Registered: Mar 2003
Location: Earth
Distribution: Slackware, Ubuntu, Smoothwall
Posts: 1,571

Rep: Reputation: 45
I was going to use this title for a new thread, but since I found this one in my search.....

I am learning about and using Slackware 9.0 - and WindowMaker. xterm is the default terminal. Is there an xterm configuration app or file? Or, do you have to make any xterm modifications by adding something to the .bash_profile? I haven't been able to glean this info directly from the 'man xterm'.

What I want is a black background instead of a white background and make the font a point size larger.

thanks...


Last edited by itsjustme; 05-14-2003 at 11:32 AM.
 
Old 05-14-2003, 12:36 PM   #10
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Quote:
Originally posted by itsjustme
I haven't been able to glean this info directly from the 'man xterm'.

What I want is a black background instead of a white background and make the font a point size larger.
What are you talking about, the man page for xterm is pretty straight forward.

$ xterm -fg white -bg black

That would give you a black background and white default text. I didn't specify the font cause quite frankly there are too many options you can try or to list really.

Maybe just specifying a -fn bold would give you want you need, making it just bold. Check the man pages again, lots of options though.

Last edited by trickykid; 05-14-2003 at 12:37 PM.
 
Old 05-14-2003, 12:41 PM   #11
itsjustme
Senior Member
 
Registered: Mar 2003
Location: Earth
Distribution: Slackware, Ubuntu, Smoothwall
Posts: 1,571

Rep: Reputation: 45
Right, that will give me a new xterm session after I already started another xterm.

I was talking about the xterm that pops up when I double click the default xterm button on windowmaker?
 
Old 05-14-2003, 12:45 PM   #12
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Quote:
Originally posted by itsjustme
Right, that will give me a new xterm session after I already started another xterm.

I was talking about the xterm that pops up when I double click the default xterm button on windowmaker?
Most likely in the properties, its just loading xterm with no options passed, just edit it accordingly to open up how you like by adding those options.

I haven't messed with WindowMaker in a long time, might just be able to just right click on the xterm link in the menu and select properties to edit how it starts up xterm.
 
Old 05-14-2003, 01:03 PM   #13
itsjustme
Senior Member
 
Registered: Mar 2003
Location: Earth
Distribution: Slackware, Ubuntu, Smoothwall
Posts: 1,571

Rep: Reputation: 45
Quote:
Most likely in the properties, its just loading xterm with no options passed, just edit it accordingly to open up how you like by adding those options.
Therein lies the problem.

I can right click on the title bar and get some options, 'attributes' actually, for killing the title bar and borders, etc. but there's no place in there to set parameters like colors and fonts for that xterm itself.

I'm assuming maybe that this can be set in .bash_profile, or some place. It's not set in /etc/profile. And the .bash_profile I had to create so far only has the PS1 assignment in it. Also, I don't see any place to set this in the "Window Maker Preferences Utility" either. And there isn't an xterm.conf file.

What do I edit?

Thanks...

Last edited by itsjustme; 08-04-2003 at 08:59 PM.
 
Old 05-14-2003, 01:09 PM   #14
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Quote:
Originally posted by itsjustme
Therein lies the problem.

I can right click on the tilte bar and get some options, 'attributes' actually, for killing the title bar and borders, etc. but there's no place in there to set parameters like colors and fonts for that xterm itself.

I'm assuming maye that this can be set in .bash_profile, or some place. It's not set in /etc/profile. And the .bash_profile I had to create so far only has the PS1 assignment in it. Also, I don't see any place to set this in the "Window Maker Preferences Utility" either. And there isn't an xterm.conf file.

What do I edit?

Thanks...
Do you have some sort of menu editor? If not look in your home directory, specifically a WindowMaker directory and look for a file called "menu" that you can edit.

Within that file you'll find something that looks like this for your xterm entry on the menu itself to start xterm:

"xterm" EXEC xterm &

This is where you'll want to edit and add those options I mentioned before with something like this:

"xterm" EXEC xterm -fg white -bg black -fn bold &
 
Old 05-14-2003, 01:10 PM   #15
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Here ya go, right in the FAQ for windowmaker: http://www.windowmaker.org/faq-chapter3.html#87
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xterm - howto lauch an xterm into a specific directory jobano Linux - Software 8 02-26-2008 04:18 PM
I have an XF86 config file for video, how do I turn it into XORG config lowpingnoob Linux - Newbie 18 06-12-2005 01:07 PM
how is black xterm background in IceWM when issue a xterm command? BRAHmS Linux - Software 1 02-14-2005 04:51 AM
Webmin cannot handle Samba config files that use the config or include directives allelopath Linux - Networking 3 01-18-2005 10:36 AM
krfb --config; Format of config file? Need to allow ports below 1024. SavvyPlayer Linux - Software 0 10-16-2004 09:28 PM


All times are GMT -5. The time now is 08:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration