LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   xterm: cannot match normal font "Monospace" on xterm 282, X11R7.7 (http://www.linuxquestions.org/questions/linux-software-2/xterm-cannot-match-normal-font-monospace-on-xterm-282-x11r7-7-a-4175431024/)

ebol4 10-07-2012 07:17 PM

xterm: cannot match normal font "Monospace" on xterm 282, X11R7.7
 
I've been building CLFS (Linux from Scratch, but multilib), and have had a lot of trouble getting Xorg stuff working. I've finally got everything compiled, but X won't run. When I type startx, I get the following errors:

xterm: cannot match normal font "Monospace"
xterm: Selected font has no non-zero height for ISO-8859-1 encoding
Warning: cannot convert string "" to type XftFont

I'm not sure what the problem is. If you need any more information, let me know.

Thanks

dickey 10-07-2012 07:56 PM

Quote:

Originally Posted by ebol4 (Post 4799763)
I've been building CLFS (Linux from Scratch, but multilib), and have had a lot of trouble getting Xorg stuff working. I've finally got everything compiled, but X won't run. When I type startx, I get the following errors:

xterm: cannot match normal font "Monospace"
xterm: Selected font has no non-zero height for ISO-8859-1 encoding
Warning: cannot convert string "" to type XftFont

I'm not sure what the problem is. If you need any more information, let me know.

Thanks

Offhand, I'd first check if there's something different between my X resources on the CLFS system versus a working system (using appres XTerm). xterm can be compiled with a debug-trace that shows what resource settings it's using, and what fonts it thinks it's using (--enable-trace configure option). If it's not due to a broken fontconfig setup, then between the trace and appres there should be enough information to diagnose the problem.

ebol4 10-07-2012 08:59 PM

Figured out the problem. The fonts I installed for Xorg were installed to /usr/X11R7.7/share/fonts/X11, so I just had to add the directory to fontconfig's configs.


All times are GMT -5. The time now is 01:03 AM.