LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-01-2007, 02:16 PM   #1
urticadioica
LQ Newbie
 
Registered: Oct 2005
Posts: 14

Rep: Reputation: 0
Wink xterm and fontconfig not getting along


I just finished a CLFS build, and got a comfortable system built on top of it, with firefox and my terminal environment. Anyway, xterm-229 is having problems with a correct configuration of fontconfig-2.4.2. With the <dir></dir> line(s) in my fonts.conf pointing to the correct font directory, xterm won't load any font other than fixed. If I take that line out, xterm will load fonts normally.

The problem of course is that programs that work correctly, like firefox, can't find their fonts unless fontconfig knows where to look for them, so my "fix" breaks firefox and most other GUI apps as well.

I should point out that xterm is at least verifying the name of the fonts, since it prints an error when I give a nonsense name, but not when I give a real one. For example:

% xterm -fn 8x16
% xterm -fn foobar
xterm: unable to open font "foobar", trying "fixed"....

Yet the first one is loading fixed anyway; it just isn't telling me about it.

I'd guess that without the <dir> line, xterm is falling back a non-fontconfig way of finding its fonts, which happens to be working.

I'm lost. Anyone have an idea?
 
Old 12-01-2007, 04:47 PM   #2
urticadioica
LQ Newbie
 
Registered: Oct 2005
Posts: 14

Original Poster
Rep: Reputation: 0
I apparently solved the problem. It seems no xterm I'd ever used on other unixes had been built with Xft support. When Xft support is compiled in, one must add "XTerm*renderFont: false" to .Xdefaults to prevent the -fa option (and XTerm*faceName) from overriding -fn (and XTerm*font). Or one could make sure the default bitmap fonts are seen by fontconfig and use -fa with their freetype names.

Tough problem, so sorry for the trouble.
 
  


Reply

Tags
fontconfig, fonts, xterm


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xterm - howto lauch an xterm into a specific directory jobano Linux - Software 8 02-26-2008 03:18 PM
When I tries to execute the xterm i got this message: xterm: no available ptys johnsanty Other *NIX 4 09-20-2006 12:29 PM
xterm alt becomes compose? Only xterm affected. -0- Linux - Software 0 09-12-2006 11:59 PM
how is black xterm background in IceWM when issue a xterm command? BRAHmS Linux - Software 1 02-14-2005 03:51 AM
Another problem........fontconfig-2.2.2 / fontconfig-2.2.94 xonner Linux - Software 2 04-28-2004 10:13 PM


All times are GMT -5. The time now is 03:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration