LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   XSANE sees scanner but does not scan (http://www.linuxquestions.org/questions/linux-software-2/xsane-sees-scanner-but-does-not-scan-4175456375/)

bosje 04-01-2013 09:29 AM

XSANE sees scanner but does not scan
 
Hi,
I've a problem with xsane. I wish to use xsane instead of other frontends as it can save scanned images to pdf quite easily.

I'm using OpenSuse 12.2 and the scanner is on the network.
Kooka, Skanlight and scanimage all do work (recognize the network scanner and can scan images to e.g. .jpg files).

When starting xsane, the scanner is found (like scanimage -L does: "device `net:192.168.2.3:pixma:04A91728_16FFA6' is a CANON Canon PIXMA MX310 multi-function peripheral"). But when I hit the scan button nothing happens, not even an error message in /var/log/messages.

It used to work under Ubuntu 12.4.

Anyone an idea to get me on track again?
Thx

Mike

amani 04-01-2013 10:28 AM

Ubuntu has specific drivers for most canon scanners.
Are they not available in opensuse?

bosje 04-01-2013 01:29 PM

Mm... AFAIK OpenSuse DOES have sufficient drivers, as it CAN see the scanner and it CAN scan using scanimage. However, as said, when I use XSANE it does SEE the scanner but does NOT SCAN, when I pus the scan button. And also does not spit out errors to the system, nor on the terminal when I start it from the commandline.

Any other options?
Thx
Mike

---------- Post added 04-01-13 at 06:29 PM ----------

Mm... AFAIK OpenSuse DOES have sufficient drivers, as it CAN see the scanner and it CAN scan using scanimage. However, as said, when I use XSANE it does SEE the scanner but does NOT SCAN, when I pus the scan button. And also does not spit out errors to the system, nor on the terminal when I start it from the commandline.

Any other options?
Thx
Mike

bosje 04-01-2013 01:58 PM

Mmm.. issue solved!!!

Some idiot (probably myself :-( ) set the behaviour of xsane to 'button controlled scanning'. Apparently the scanner and xsane were waiting for a button to be pushed.

Cheers,
Mike


All times are GMT -5. The time now is 04:37 AM.