LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-23-2003, 08:57 AM   #1
lawadm1
Member
 
Registered: Jul 2003
Location: Illinois
Distribution: Fedora 11, Ubuntu 9.04
Posts: 80

Rep: Reputation: 15
XP/Grub Boot


I'm dual booting Win XP and Red Hat 9 and I've modified the boot.ini file to add Red Hat 9 to the selection list.

The problem is, when I select Red Hat 9, I get "GRUB" and it hangs there and does nothing.

I've set this up successfully on a machine dual booting W2K and Red Hat 9. The only difference is that I used LILO on the W2K machine.

Any suggestions would be appreciated,

-J
 
Old 07-23-2003, 09:01 AM   #2
lawadm1
Member
 
Registered: Jul 2003
Location: Illinois
Distribution: Fedora 11, Ubuntu 9.04
Posts: 80

Original Poster
Rep: Reputation: 15
I also need to add that I did create the linux_bs.bin file using "dd", and did place that in C: in XP

In boot.ini I added C:\linux_bs.bin="Red Hat 9"
 
Old 08-09-2003, 09:48 PM   #3
ponkanMonster
LQ Newbie
 
Registered: Aug 2003
Location: Philippines
Distribution: mandrake 10
Posts: 16

Rep: Reputation: 0
hey bro!

i think you better use the lilo or grub that linux provides for the very reason that they are the bootloaders that can load multiple OSes without being file-system-sensitive.

i hope this one helps. by the way XP is nasty coz of the ntfs. M*@#$% wants their OS to be the only on a PC.

this is the very first time i've encountered a problem like yours of all the time i'm searching almost all linux forums.
 
Old 09-01-2003, 07:18 PM   #4
CFink
LQ Newbie
 
Registered: Sep 2003
Distribution: RH 8.0
Posts: 2

Rep: Reputation: 0
XP/Grub boot

Did you ever get this working? I have the same problem. I can boot into Linux (on the 2nd HD) only if I go into the BIOS and switch the boot order of my drives, and even then I have to modify the Grub.conf file to reverse the HD identifiers there as well.

Thanks,

Chris
cfphd@earthlink.net
 
Old 09-02-2003, 08:48 AM   #5
ponkanMonster
LQ Newbie
 
Registered: Aug 2003
Location: Philippines
Distribution: mandrake 10
Posts: 16

Rep: Reputation: 0
Unhappy

well,i am very sad to inform you, my dear friend that i was only to modify the grub.conf file so as to let grub find my winXP. i have had no problem with my machine on the dual boot. why not try to reinstall WinXP first then linux. but remember change only the grub for your bootloader and not all of the bootloaders.....
sorry, i hope this helps
 
Old 09-27-2003, 04:35 PM   #6
f_r_c
LQ Newbie
 
Registered: Sep 2003
Location: Mexico City
Posts: 1

Rep: Reputation: 0
I'm working fine with XP/w2k/Redhat9

I have 3 partitions in a same HD.
First installed WinXP, after Windows 2k, at last Redhat 9.

Win2k configures both partitions (WinXP y Win2k) in order to boot between those OS's.
File configured when you install those OS's is c:\boot.ini (in first partition)

Installing Redhat9 in third partition you can configure /etc/grub.conf in order to boot Linux and Windows OS's.

When you turned on the machine, first executed is Linux Grub, asking for the system which you want to start. If you choose Windows OS, next screen is the menu of boot.ini asking for the Windows system that you want to start (in my case Win2k and WinXP).

I hope this help you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gentoo : grub: The file /boot/boot/grub/stage1 not read correctly Boudewijn Linux - Software 3 05-21-2008 04:13 AM
need to access /boot/grub/menu.lst and /boot/grub/device.map neouto Linux - Newbie 8 09-04-2005 12:45 PM
Setting password on grub, wha to do after changing default values in /boot/grub/menu. sarajevo Linux - Security 1 08-17-2005 09:01 PM
Grub setup problem (/boot/grub/stage1 not found) davidas Debian 2 04-28-2004 09:13 PM
Trying to dual-boot XP and RH9 with GRUB...GRUB stops right after BIOS EvilYoda Linux - Newbie 5 06-20-2003 04:38 PM


All times are GMT -5. The time now is 09:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration