LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-26-2004, 12:46 PM   #1
Covel
Member
 
Registered: Oct 2003
Location: Portugal
Distribution: Gentoo
Posts: 116

Rep: Reputation: 16
xorg hanging for no apparent reason [solved]


Hi!

I'm having a strange problem with xorg (probably) that I'm having a hard time to resolve.

xorg sometimes just hangs! Only the mouse keeps working. If I ssh from another machine, I can log in and all seems working just fine. I tried to kill X but it just ignores me. There's no relevant info in the log files.

I know it will be dificult for someone to help me with so short info. Somedays it doesn't hang at all, somedays it hangs like 5 times in 12 hours. I only hope that this is a known bug and someone has a solution for this. Or some clues on how to debug this.

Thanks!

Last edited by Covel; 06-03-2004 at 03:29 PM.
 
Old 05-26-2004, 12:50 PM   #2
drigz
Member
 
Registered: Apr 2004
Distribution: Gentoo ~x86
Posts: 407

Rep: Reputation: 30
can you use ctrl+alt+f6 to put it into console mode? what do you do when it hangs to regain control? if you are restarting, it could be easier to ssh from the other machine and type 'init 3' then return to your computer and use init 4 to get X up again.
 
Old 05-26-2004, 01:15 PM   #3
Covel
Member
 
Registered: Oct 2003
Location: Portugal
Distribution: Gentoo
Posts: 116

Original Poster
Rep: Reputation: 16
Quote:
Originally posted by drigz
can you use ctrl+alt+f6 to put it into console mode? what do you do when it hangs to regain control? if you are restarting, it could be easier to ssh from the other machine and type 'init 3' then return to your computer and use init 4 to get X up again.
I can't ctrl+alt+f?. The keyboard doesn't work at all. Only mouse but I can't click anything . Yes, I usualy ssh from another machine but I usually reboot. I tried once that but it was taking so much time to terminate X that I just typed reboot. Next time, if I have the time, I'll wait a little longer.

If I only could reproduce it...
 
Old 05-30-2004, 04:38 AM   #4
Covel
Member
 
Registered: Oct 2003
Location: Portugal
Distribution: Gentoo
Posts: 116

Original Poster
Rep: Reputation: 16
I suspected it was a problem related to ACPI. So I added pci=noacpi to kernel. Still testing but haven't had any hang since. 2 days have passed.
 
Old 06-03-2004, 03:29 PM   #5
Covel
Member
 
Registered: Oct 2003
Location: Portugal
Distribution: Gentoo
Posts: 116

Original Poster
Rep: Reputation: 16
Thumbs up

Ok. I'm gonna accept this problem as solved. Been some days without a single problem.
 
Old 06-03-2004, 05:16 PM   #6
drigz
Member
 
Registered: Apr 2004
Distribution: Gentoo ~x86
Posts: 407

Rep: Reputation: 30
nice move - what made you suspect it?
 
Old 06-06-2004, 03:59 AM   #7
Covel
Member
 
Registered: Oct 2003
Location: Portugal
Distribution: Gentoo
Posts: 116

Original Poster
Rep: Reputation: 16
Quote:
Originally posted by drigz
nice move - what made you suspect it?
I recently added support for ACPI and when booting I noticed a message saying something like:

"If you have any problems with this try pci=noaci or acpi=off"

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fedora server shuts down for no apparent reason jordanthompson Linux - General 9 09-10-2005 01:54 PM
Eth0 interface dead... for no apparent reason in suse 9.1. any ideas? GD_19 Linux - Networking 1 10-16-2004 02:19 AM
Fedora Core II locking for no apparent reason k41184 Linux - Software 1 09-11-2004 11:47 AM
LFS - first apparent problem itsjustme Linux From Scratch 22 07-22-2003 12:58 PM
X drops back to 640x480 for no apparent reason Griffon26 Linux - Software 2 06-24-2002 12:55 PM


All times are GMT -5. The time now is 12:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration