LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   xorg.conf and 1440x900 resolution (http://www.linuxquestions.org/questions/linux-software-2/xorg-conf-and-1440x900-resolution-254587/)

mrsolo 11-14-2004 01:22 AM

xorg.conf and 1440x900 resolution
 
How do I make my FC3 system use a resolution of 1440x900? I am not sure how to edit the xorg.conf file.

mrsolo 11-14-2004 02:08 AM

As a follow up, I checked my Xorg.0.log and when it mentioned the 1440x900 resolution, the log showed that the width was too big for the virtual size. So I guess the question now is how do I get the virtual size increased?

perfect_circle 11-14-2004 02:16 AM

in xorg.conf u 'll find something like this

Code:

Section "Screen"
        Identifier "Screen0"
        Device    "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth    24
        SubSection "Display"
                Viewport  0 0
                Depth    24
                Modes    "1024x768" "800x600" "640x480"
        EndSubSection

Why don't you put your resolution in there?

I'm not sure if your system supports this resulution.

mrsolo 11-14-2004 02:55 AM

Here's my xorg.conf file:

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1400x1050"
HorizSync 31.5 - 90.0
VertRefresh 40 - 80
Modeline "1440x900" 86.73 1440 1472 1800 1832 900 919 927 946
Option "IgnoreEDID" "off"
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce FX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1440x900" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1440x900" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

mrsolo 11-14-2004 02:56 AM

Here's the entry in the log that is causing me trouble:

(II) NVIDIA(0): Not using mode "1440x900" (width too large for virtual size)

perfect_circle 11-14-2004 03:09 AM

I don't know if that helps but as far as i can see you have installed Nvidia's 3d accelerations drivers (module "nvidia")
u should dissable dri module:

Quote:

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
#Load "dri"
EndSection
Read the nvidia README file!!!

CJ Chitwood 11-15-2010 10:32 PM

I realize this is an ANCIENT thread and that I'm crossposting, but I just lost -- literally -- days on this problem. I finally found a solution and I post this reply for people with the same problem I had who may find this thread. My issue was using Sabayon (though not OS specific) Linux with a Polaroid tla-01911c 19-inch HD television as a monitor attached via VGA cable to my nVidia GeForce 6200 NV44a AGP video card and not getting the proper set of resolutions available to the "monitor". Studying my /etc/var/Xorg.0.log showed me that the card could not get EDID info from the monitor. (Let's see how many more keywords I can add)

What I finally did was set a "modeline" (not just "modes" but actually "modeline") so that EDID info was not necessary. Turns out it's an ancient method that still works.


The link below is what got it working for me:

http://www.zotacusa.com/forum/topic/...post__p__10247


Hope this helps the next poor fellow looking to get something other than 4:3 resolutions on a 16:10 screen!




FWIW, my /etc/X11/xorg.conf (may not be 100% correct, but it's working for just right now -- I'll mess with it later)

Code:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 260.19.21  (buildmeister@builder101)  Thu Nov  4 21:47:28 PDT 2010


Section "ServerLayout"
    Identifier    "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/X11R6/lib/X11/fonts/misc/:unscaled"
    FontPath        "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath        "/usr/X11R6/lib/X11/fonts/TTF/"
EndSection

Section "Module"
    Load          "glx"
    Load          "v4l"
EndSection

Section "InputDevice"

    # generated from data in "/etc/conf.d/gpm"
    Identifier    "Mouse0"
    Driver        "mouse"
    Option        "Protocol"
    Option        "Device" "/dev/input/mice"
    Option        "Emulate3Buttons" "no"
    Option        "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier    "Keyboard0"
    Driver        "kbd"
EndSection

Section "Monitor"
 #28.0 - 33.0
 #43.0 - 72.0
    Identifier    "Monitor0"
    VendorName    "Polaroid"
    ModelName      "tla-01911c"
    HorizSync      12.5 - 55.93
    VertRefresh    43.0 - 160.0
    Option        "DPMS"
    Option        "DPI" "96 x 96"
    # 1440x900 59.89 Hz (CVT 1.30MA) hsync: 55.93 kHz; pclk: 106.50 MHz
    Modeline "1440x900_60.00"  106.50  1440 1528 1672 1904  900 903 909 934 -hsync +vsync
EndSection

Section "Device"

#    Option        "ConnectedMonitor" "DFP-0"
#    Option        "IgnoreEDID" "TRUE"
    Option        "UseEDID" "FALSE"
#    Option        "UseEDIDFreqs" "FALSE"
#    Option        "UseEDIDDpi" "FALSE"
#    Option        "ModeValidation" "NoEDIDModes"
    Identifier    "Device0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option        "UseEdid" "False"
    SubSection    "Display"

#        Virtual 1440 900
        Depth      24
        Modes      "1440x900_60"
    EndSubSection
EndSection



All times are GMT -5. The time now is 12:12 AM.