LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Xmonad launch error (http://www.linuxquestions.org/questions/linux-software-2/xmonad-launch-error-894321/)

ADX 07-28-2011 11:07 AM

Xmonad launch error
 
I originally attempted to compile and install xmonad package by package, and the end result was this:

Code:

$ xmonad
/home/adx/.xmonad/xmonad-x86_64-linux: executeFile: does not exist (No such file or directory)
X Error of failed request:  BadAccess (attempt to access private resource denied)
  Major opcode of failed request:  2 (X_ChangeWindowAttributes)
  Serial number of failed request:  7
  Current serial number in output stream:  8

I figured I left out a flag on the make file or something, so I tried the slackbuild packages next; however, the same error was present at launch.

Anyone have any ideas?

TobiSGD 07-28-2011 01:26 PM

Normally Xmonad isn't installed into ~/.xmonad/, that is where the configuration file is expected. This file has to be present to launch Xmonad, and it won't generate a standard file. So I would assume that you have no configuration file, have a look at that.


All times are GMT -5. The time now is 09:04 AM.