LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   XMMS Wont Read Disks (http://www.linuxquestions.org/questions/linux-software-2/xmms-wont-read-disks-442245/)

carlosinfl 05-06-2006 12:27 PM

XMMS Wont Read Disks
 
When I tell XMMS to play an audio CD from /media/cdrom, it does not display and media info like "artist, track title, or album name" which is very poor for a media player in my opinion. I downloaded and installed a plugin for XMMS

Code:

xmms-cdread - input plugin for XMMS that reads audio data from CDs
I have restarted XMMS many times and still don't have any luck. I then go to "Preferences" and check all 4 plugin tabs that I see and I show the 1st tab called "Audio I/O Plugins" has a plugin called "Audio CD Reader 0.14a"

What do I need to do to get this working and does anyone even know if this is possible for XMMS to read artist, song, and album info while playing from a CD source?

jschiwal 05-06-2006 01:16 PM

A CDROM does not contain that information. The number of tracks and their length are used to retrieve the information from a CDDB database server on the web. You need to configure the CD Audio Player plugin.
Preferences -> Audio I/O Plugins (tab)
Select CD Audio Player (libcdaudio.so) in the Input plugins list. Click on the small "Enable plugin" button. Then press configure if changes are needed. This will give you a "CD Audio Play Configuration" dialog with 2 tabs. If xmms plays the cd but doesn't display the information, then the information on the Device tab is probably correct. Click on the "CD Info" tab and click the "Use CDDB" button. You can also select a different CDDB database server here.

carlosinfl 05-06-2006 03:49 PM

I don't understand...my CDDB is set to /home/cwilliams/.cddb & I still don't see anything. The plugin is enabled.

jschiwal 05-06-2006 06:54 PM

Try using the web address of a cddb server in the "CDDB Server" entry such as "freedb.freedb.org" or "us.freedb.org". Make sure that "Use CDDB" is enabled. Your phrasing is slightly different. I wonder if you are using a different plugin, or a different version of the same plugin.

Also, I checked the config settings in my ~/.xmms/config file.
[CDDA]
device=/dev/cdrom
directory=/media/xmms_audio_cd/
mixer=2
readmode=0
num_drives=1
title_override=FALSE
name_format=%p - %t
use_cddb=TRUE
cddb_server=us.freedb.org
cddb_protocol_level=0
use_cdin=FALSE
cdin_server=www.cdindex.org

I'm not sure what the use_cdin=FALSE and cdin_server=www.cdindex.org is for.

Good Luck!


All times are GMT -5. The time now is 06:45 AM.