LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-22-2005, 02:13 PM   #1
curmudgeon42
Member
 
Registered: May 2004
Posts: 86

Rep: Reputation: 15
XMMS skips when compiling / other tasks


I use XMMS to play music (MP3) while I am tooling around with Linux, which is quite often. :-)

Sometimes, when I start a new program or start compiling a program it will start to skip or distort. This doesn't happen constantly when the processor is pegged, but it happens more often when the processor is pegged.

It isn't a RAM issue as far as I can tell because 'top' reports that of my 512MB RAM only about 490MB is used right now, while I have KDE, Firefox, Thunderbird, XMMS, and emerge (GCC) running.

Is there a way I can give XMMS a higher priority when running it so that the resources it demands are given to it and the other processes have to wait?

Also, I am currently using OSS because I had a large battle with ALSA which I lost. If it will help my skipping problem though I will ask for a rematch.

Thanks for the help,

~ Justin
 
Old 01-22-2005, 02:43 PM   #2
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
ALSA skips as well when I do those things so that won't help much.
 
Old 01-22-2005, 03:05 PM   #3
Linux~Powered
Member
 
Registered: Jan 2004
Location: /lost+found
Distribution: Slack`er-current
Posts: 845

Rep: Reputation: 31
Quote:
Is there a way I can give XMMS a higher priority when running it so that the resources it demands are given to it and the other processes have to wait?
The command you're looking for is the nice command.

Code:
nice n or -n xmms
Where n is a lower priority and -n is higher. 19 is the lowest -20 is the highest, 0 is default

Last edited by Linux~Powered; 01-22-2005 at 03:07 PM.
 
Old 01-22-2005, 04:21 PM   #4
curmudgeon42
Member
 
Registered: May 2004
Posts: 86

Original Poster
Rep: Reputation: 15
thanks i'll give that a shot
 
Old 01-22-2005, 04:28 PM   #5
curmudgeon42
Member
 
Registered: May 2004
Posts: 86

Original Poster
Rep: Reputation: 15
well it seems to work but i can't run 'nice -n -20' as a non-root user. according to some google pages i found this is appropriate behavior. but i don't want to run XMMS as root. i could issue a renice command as root after running xmms as a standard user, but i would rather come up with a solution where XMMS always run at a high priority.

is there a group that i could add my standard user to to allow nice to be used with negative commands by that user. could i get rid of the security checks in nice completely? (it is a desktop on which i'm not concerned about users abusing process priviledges)

thanks,

~ Justin
 
Old 01-22-2005, 04:40 PM   #6
curmudgeon42
Member
 
Registered: May 2004
Posts: 86

Original Poster
Rep: Reputation: 15
well even with xmms reniced to -19 it seems that emerge can still make it skip horribly

is there anything else i can try? this is a bad sign - windows can do something just fine that linux can't. my music will still play in windows when other processes are demanding resources...

~ Justin
 
Old 01-22-2005, 05:32 PM   #7
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
XMMS - really should never skip, even at considerable background-compiling load. It is mostly is a scheduler and kernel issue. It can be tweaked but is a complicated process and even worst to setup everytime xmms is killed and restarted. They say it was fixed in the 2.6.0.test6 kernel and newer. But it is worst in some versions of 2.6 than others.

Things you can do:
1. go and compile xmms with CPU-optimizations for your CPU
2. set the output-buffer to a higher value
( Preferences -> Output Plugin -> configure -> Buffering -> Buffer size(ms)
Enter something like 2500 oder 3000 )
3. use a decent soundcards that actually does things in hardware
Switching from ISA- to PCI-cards helps a lot

Brian1
" Google the Linux way @ http://www.google.com/linux "
 
Old 01-22-2005, 05:42 PM   #8
curmudgeon42
Member
 
Registered: May 2004
Posts: 86

Original Poster
Rep: Reputation: 15
1. I think I already did this. I use Gentoo so I had already compiled it with architecture and cflags set.

2. I will give this a shot.

3. my soundcard is onboard. would switching to a PCI soundblaster really help this issue?

Thanks,

~ Justin
 
Old 01-22-2005, 06:02 PM   #9
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
You can do a ' lspci ' and see if your audio device is listed there. Sound Blaster Live is a good cheap choice. I am sure someone can recommend a better card here. If posible I would try to find a friend with a SB Live card and try it in your machine before buying one. Just to see if that works. The more hardware control the card can do the less of load on the cpu there is.

Brian1
" Google the Linux way @ http://www.google.com/linux "
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
XMMS skips on some MP3s Guitarist88 Linux - Software 9 03-25-2005 04:43 PM
xmms skips help wearetheborg Linux - Software 1 11-18-2004 12:14 AM
XMMS skips a LOT Stalkz Linux - Software 2 03-03-2004 02:42 PM
Digital Audio Extraction w/ XMMS - disk skips r_jensen11 Linux - Software 0 01-18-2004 12:03 PM
Gnome CD Player stops randomly, XMMS skips tracks steveybaby2 Linux - Software 0 01-02-2004 03:02 PM


All times are GMT -5. The time now is 05:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration