LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-16-2002, 09:11 PM   #1
safrout
Member
 
Registered: Mar 2002
Location: egypt
Distribution: Gentoo
Posts: 457

Rep: Reputation: 30
Unhappy xmms problem with glib 1.2.10


when makin ./configure for xmm i go this error msg


checking for glib-config... no
checking for GLIB - version >= 1.2.2... no
*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***
safrout@linux:~/Desktop/xmms-1.2.7>


although iam surethat i have the glib version 1.2.10 installed on my system

can anyone help me plz


do i have to install the old version or what?
 
Old 09-16-2002, 09:22 PM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Is this on your SuSE system or LFS or what?

You might need to specify the location. ./configure --help will give you more options like this. So maybe:
./configure -with-glibdir=/usr/bin/glibxxx

Obviously that's not it, but you can probably understand what I mean with that.

Cool
 
Old 09-16-2002, 09:26 PM   #3
safrout
Member
 
Registered: Mar 2002
Location: egypt
Distribution: Gentoo
Posts: 457

Original Poster
Rep: Reputation: 30
it is suse

and i am tring now to find the place where glibxxxis located

thanx for help
 
Old 09-16-2002, 09:33 PM   #4
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
It's more than likely going to be on your CD then if you have a CD of your distro. If not, I am sure you could find it via the ftp site. Might be a little easier finding one for your distro... But where's the fun in that

Cool
 
Old 09-16-2002, 09:38 PM   #5
safrout
Member
 
Registered: Mar 2002
Location: egypt
Distribution: Gentoo
Posts: 457

Original Poster
Rep: Reputation: 30
i found the solution

what samrt i am?
LOL

i found that version 1.2.10 which i have on my system is older than 1.2.2 which xmms need

so i am now downlloading the new version 1.2.2

but shall i install the lateset version which is 2.0.6 or let it be 1.2.2 and be in the safe side
 
Old 09-16-2002, 09:41 PM   #6
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
I would think that 1.2.10 is newer than 1.2.2 (the last digit being a whole number, not an actual decimal number, so 10 not, 1) but I guess it's different here.

If you are upgrading, why go semi new, as long as it's stable, I'd say get the latest and greatest.

Cool
 
Old 09-16-2002, 09:44 PM   #7
safrout
Member
 
Registered: Mar 2002
Location: egypt
Distribution: Gentoo
Posts: 457

Original Poster
Rep: Reputation: 30
i don't know but i tld myself to be sure that it will work with 1.2.2

i am installing it now
and if it worked
i will try the lateset version after that
 
Old 09-16-2002, 09:53 PM   #8
safrout
Member
 
Registered: Mar 2002
Location: egypt
Distribution: Gentoo
Posts: 457

Original Poster
Rep: Reputation: 30
i installed glib version 1.2.2 and removed the old verision
now i am installing GTK+ version 1.2.2 and removing the older version
 
Old 10-11-2002, 03:33 AM   #9
lganeva
LQ Newbie
 
Registered: Oct 2002
Posts: 9

Rep: Reputation: 0
Hello,
i have the same problem like You but I don;t know how to remove the old version
 
Old 10-11-2002, 03:44 AM   #10
iceman47
Senior Member
 
Registered: Oct 2002
Location: Belgium
Distribution: Debian, Free/OpenBSD
Posts: 1,123

Rep: Reputation: 47
You remove something by going into the map where you installed it originally and typ make clean or make uninstall.
Removing RPM's is rpm -e <name of rpm>.
If you don't have the map anymore, reinstall it, so untar, ./configure, make and then make clean or make uninstall.
If you don't know the name of the rpm querry all the rpm's on your system using rpm --aq >> /root/rpms goto /root and look at the rpms file. the name of your installed rpm should be listed somewhere.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM
xmms n GLIB AVD_ZM Linux - Software 1 02-09-2005 10:46 AM
XMMS and GLIB binny959 Linux - Software 2 08-25-2004 10:00 PM
Tring to insall XMMS, GLIB problem MatthewASmith79 Linux - Newbie 3 06-04-2004 10:01 PM
Installing XMMS, Problem with glib Inexactitude Linux - Software 3 10-18-2003 04:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration