LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message (http://www.linuxquestions.org/questions/linux-software-2/xmms-install-needs-glib-1-22-just-installed-glib-2-4-8-and-still-get-error-message-268457/)

eskiled 12-20-2004 12:25 PM

xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message
 
***Repost from www.justlinux.com (but nobody answered there)***

I just tried installing the newest version of xmms and it decided to tell me that:

code:#tar -xvzf xmms-someversion.tar.gz
#cd xmms-someversion
#./configure



then I get this error message
"checking for GLIB - version >= 1.2.2... no
*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.

configure: error: *** GLIB >= 1.2.2 not installed - please install first ***"


I say fine, and I go pick up the latest tar.gz of glib (2.4.8). I go through the install (tar -xvzf, cd, ./configure, make, su root, make install) and everything is fine. I go back to complete my xmms installion:

code:
#cd xmms-someversion
#./configure



And I end up with the same error message as before! Whats going on?


Thanks,
eskiled


Ps. I know that this means ./configure cannot find my Glib updated packages. However I don't know where my updated packages are, and I don't know how to telll ./configure (as well as make and make install), where they are.

Pps. It would also be nice if I were able to move these Glib packages to a place where other "./configure's, make, and make install"s will be able to find and use them.

corfe 12-20-2004 12:42 PM

Usually, when installing libraries, there are two types to install - the regular library, that will let you run programs (you'll need this to run any program that uses it), and the development library, that will let you compile programs that use it. Since you're trying to compile xmms, even though you have the right version of the glib libraries installed, you'll want to install the development version of the glib libraries so that it can compile programs that use them..

However, that being said - with Mandrake, you can probably download an appropriate RPM or install all of these things (glib, glib-dev, and xmms) straight from a package manager. This is part of the ease of Mandrake and other user-friendly distributions - you don't often have to compile your own things. I don't know enough about Mandrake to know where their package manager is or anything, but I would check on some mandrake forums or in a mandrake tutorial, and it should tell you how to install all of this stuff without messing around with compiling your own stuff. You might also check your menus for some kind of "package manager" program, that might do the trick.

Good luck! :)

wazzu 12-19-2005 09:12 PM

That worked! I had to install GTK and GLIB developement libs and it worked!

Thanks
wazzu


All times are GMT -5. The time now is 09:10 AM.