LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 05-26-2005, 09:47 AM   #1
SeriousArnoud
LQ Newbie
 
Registered: Dec 2004
Location: Netherlands, Hilversum
Distribution: slackware-current
Posts: 10

Rep: Reputation: 0
xmms-crossfade built-in OSS problem arised


SHORT:
i have an annoying problem. my crossfade plugin doesn't seem to be working properly anymore and i can't set it anymore to function like it used to. Also xmms crashes randomly with this error message.
Code:
[crossfade] open_output: buffer: size=238140 (1100+0+250=1350 ms) (44100 Hz)
[crossfade] open_audio: XFADE:
[crossfade] apply_fade_config: avail=0 out=0 in=0 offset=0 skip=0
*** allocation 2304 bytes
[crossfade] buffer_thread_f: thread started (pid=6266)
Trace/breakpoint trap
My question is to find a 'possible' bug in crossfade but basically i want it to function properly again

LONG:
I'm already a few good months in love with the crossfade plug-in for xmms. mainly it's ***** fast in seeking (instantaneous) and i can set it to gapless for automatic songchange which is perfect.
however i just did a swaret --upgrade -a and upgraded my computersoftware to kde 3.4 and some other stuff including new alsa drivers etc.. (700mb software). after this huge upgrade the plugin just didn't function anymore. (I also reinstalled the alsa* software)

What happens is this: seeking goes still perfectly but when i do a songchange the song doesn't start playing (and i have to stop and play xmms to go to the next song, basically automatic songchange is broke) in the plugin there is an option to give output(stderr) of what happens:
Code:
[crossfade] close:
[crossfade] close: stop
[crossfade]
[crossfade] open_audio: XMMS-crossfade 0.3.8
[crossfade] buffer_thread_f: input restarted after 5 ms
[xfade-oss] buffer_thread_f: select(): Interrupted system call
[xfade-oss] buffer_thread_f: thread finished
[crossfade] open_audio: bname="Symphony X - A Fool's Paradise"
[crossfade] open_audio: fmt=FMT_S16_NE rate=44100 nch=2 dt=5 ms
[crossfade] open_audio: FLUSH:
[crossfade] apply_fade_config: avail=0 out=0 in=0 offset=0 skip=0
[crossfade] write_audio: leading gap size: 0/500 ms
[crossfade] write_audio: 4 samples to next crossing
i can fix this by setting it to having another output plugin for crossfade. But now my seeking is broke (2 a 3 seconds delay even when i play with several buffer timings). I know it's a long question but i found this to be a most annoying problem.
these are those problems which i'm actually able to format the whole HDD and reinstall slackware again just to let it function properly again.

(EDIT)ow yeah after sending this post i just noticed xmms crashed the whole time. after a restart (yeah where to look :S)the first times xmms crashed again and now it plays perfectly with seeking and automatic songchange going perfectly with the external OSS driver. I really hate this to random things to happen!

Hope you can help me
Arnoud

Last edited by SeriousArnoud; 05-27-2005 at 04:21 AM.
 
Old 06-03-2005, 02:54 PM   #2
SeriousArnoud
LQ Newbie
 
Registered: Dec 2004
Location: Netherlands, Hilversum
Distribution: slackware-current
Posts: 10

Original Poster
Rep: Reputation: 0
never mind... i installed slackware again... couldn't resolve problem

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
buggy xfmedia and xmms using oss landroni Linux - Software 4 01-26-2006 10:24 AM
Xmms > Freezing with OSS, no sound with Alsa kloss Linux - Software 1 10-09-2005 06:45 AM
XMMS and OSS piggysmile Linux - Software 4 04-15-2005 09:11 AM
Strange problem with installing XMMS-Crossfade on Slack 9.1 gamehack Slackware 1 12-06-2003 05:15 AM
xmms, alsa and oss externalgreenfu Debian 2 07-11-2003 07:26 AM


All times are GMT -5. The time now is 01:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration