LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-27-2004, 05:56 AM   #1
Dag
LQ Newbie
 
Registered: Jun 2004
Posts: 26

Rep: Reputation: 15
XMMS AAC plugin - can't compile MPEG4IP, missing lid3tag


Hi all.
I'm trying to install an AAC plugin for XMMS. This thing has a ton of dependencies. Right now I'm working on installing MPEG4IP, but it's not working out so well.

Anyway, I go into the MPEG4IP directory and do ./bootstrap --disable-server && make - it goes through configuration apparently without issue and make gets fairly far in, but it stops at:

Code:
/bin/sh ../../../../libtool --mode=link g++ -D_REENTRANT -DNOCONTROLS -fexceptions -Wall -Werror -Wmissing-prototypes -Wno-char-subscripts -Woverloaded-virtual -Wno-unknown-pragmas -Wno-deprecated -Wformat=2 -g -O2 -DMPEG4IP   -o mp3_plugin.la -rpath /usr/local/lib/mp4player_plugin -module mp3if.lo mp3_file.lo -lm -lid3 -lid3tag ../../../../player/lib/audio/mp3/libourmp3.la ../../../../player/lib/audio/mp3util/libmp3utils.la ../../../../lib/fposrec/libfposrec.la -ldl
g++ -shared -nostdlib /usr/lib/gcc-lib/i386-redhat-linux/3.3.3/../../../crti.o /usr/lib/gcc-lib/i386-redhat-linux/3.3.3/crtbeginS.o  .libs/mp3if.o .libs/mp3_file.o -Wl,--whole-archive ../../../../player/lib/audio/mp3/.libs/libourmp3.a ../../../../player/lib/audio/mp3util/.libs/libmp3utils.a ../../../../lib/fposrec/.libs/libfposrec.a -Wl,--no-whole-archive  -lid3 -lid3tag -ldl -L/usr/lib/gcc-lib/i386-redhat-linux/3.3.3 -L/usr/lib/gcc-lib/i386-redhat-linux/3.3.3/../../.. -lstdc++ -lm -lc -lgcc_s /usr/lib/gcc-lib/i386-redhat-linux/3.3.3/crtendS.o /usr/lib/gcc-lib/i386-redhat-linux/3.3.3/../../../crtn.o  -Wl,-soname -Wl,mp3_plugin.so.0 -o .libs/mp3_plugin.so.0.0.0
/usr/bin/ld: cannot find -lid3tag
I'm assuming lid3tag is basically the same as libid3, which I do have installed. I can't find anything relevant about lid3tag, anyway.

Ideas?
 
Old 02-14-2005, 06:11 PM   #2
leosgb
Member
 
Registered: Nov 2004
Location: Brazil
Distribution: Gentoo
Posts: 363

Rep: Reputation: 31
I am having the same problem trying to compile gtkpod! Did you find it? My error message is:

./configure
.
.
checking for msgfmt... no
checking for getopt_long_only... yes
checking for getopt_long_only... (cached) yes
checking for flock... yes
checking for id3_frame_field in -lid3tag... no
configure: error: *** id3tag >= 0.15 lib not found (0.14 will not work!)

And configure stops. Any suggestions?

-----
Just got it to work. It is just a matter of finding the source code for the library (that is pointed by gtkpod's website) and compile it. Many other libraries may be needed but it is just a matter of checking the error messages and install one by one.

Last edited by leosgb; 02-14-2005 at 08:29 PM.
 
Old 03-02-2007, 08:27 PM   #3
script_this
LQ Newbie
 
Registered: Sep 2003
Posts: 2

Rep: Reputation: 0
gtkpod libid3tag installed but not found

i have libid3tag installed -

$> ls -l /usr/lib/libid3*
lrwxrwxrwx 1 root root 18 Oct 2 01:18 /usr/lib/libid3tag.so.0 -> libid3tag.so.0.3.0
-rwxr-xr-x 1 root root 80276 Apr 10 2006 /usr/lib/libid3tag.so.0.3.0

i also tried to install it via rpm (can't find source? to recompile etc). here's what happened with rpm attempt:

$> rpm -Uvh libid3tag-0.15.1b-2.fc5.i386.rpm
Preparing... ################################ [100%]
package libid3tag-0.15.1b-3.fc5.rf (which is newer than libid3tag-0.15.1b-2.fc5) is already installed

here is the error message in gtkpod config.log:

configure:8081: checking for id3_frame_field in -lid3tag
configure:8116: gcc -o conftest -g -O2 -Wall -Wno-pointer-sign conftest.c -lid3tag >&5
/usr/bin/ld: cannot find -lid3tag

any assistance would be tremendously appreciated...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xmms AAC Plugin WindowsVeteran Linux - Software 16 06-30-2009 01:03 PM
Play AAC files with XMMS? Kenji Miyamoto Linux - Software 3 01-02-2005 10:40 PM
XMMS and AAC Livewire_T Linux - Software 3 11-20-2004 10:50 PM
xmms + aac (m4a,etc) mrgreenfur Linux - Software 12 09-30-2004 12:05 PM
xmms plugin compile error archish Linux - Software 0 12-27-2003 09:09 AM


All times are GMT -5. The time now is 03:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration