LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-17-2004, 01:08 AM   #1
JROCK1980
Member
 
Registered: Aug 2003
Distribution: FreeBSD
Posts: 490

Rep: Reputation: 30
xmms 1.2.9 freezes when play


I can open it with no problems but when I play the song it freezes. Any ideas?
 
Old 02-17-2004, 01:17 AM   #2
JROCK1980
Member
 
Registered: Aug 2003
Distribution: FreeBSD
Posts: 490

Original Poster
Rep: Reputation: 30
Ok I leave it froze there and all of the sudden in a couple of minutes it starts to play the track. I am wondering if gaim has anything to do with this. The reason is I right before it freezes I heard sounds the belong to gaim. hope this help with assistance that I need
 
Old 02-17-2004, 01:24 AM   #3
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
could be a dsp resource conflict. what desktop environment are you using? also what output plugin do you have xmms using?

if you're using kde, then in xmms options, make sure you're using arts for the output plugin. if i remember correctly, the new versions of xmms don't come with the arts plugin for use in kde. you can get that at the xmms website. then in try running gaim in the shell terminal using the command:

artsdsp gaim

start xmms while testing sounds in gaim. they should now be mixed and xmms should be playing music while the gaim sounds are being tested and heard. if this is the case, just change your desktop shortcuts to use that artsdsp command.

if you're in another desktop environment or window manager using a different sound server, you'll have to hang out and see if anyone else has a solution for you.

edit: well hmm.... i started gaim up and tested sounds with xmms playing music and i have no conflicts using just the command gaim. hmm.... sorry not much help for you except to see if using arts output plugin for xmms solves this. (if you're using kde of course).

Last edited by megaspaz; 02-17-2004 at 01:27 AM.
 
Old 02-17-2004, 01:27 AM   #4
JROCK1980
Member
 
Registered: Aug 2003
Distribution: FreeBSD
Posts: 490

Original Poster
Rep: Reputation: 30
right now I am using OSS. I will download that and try that as well
 
Old 02-17-2004, 01:29 AM   #5
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
Quote:
Originally posted by JROCK1980
right now I am using OSS. I will download that and try that as well
okay, but what desktop environment? gnome, kde?

the newest gaim has a sound method preference in sounds that will let you choose arts as the sound server.

Last edited by megaspaz; 02-17-2004 at 01:30 AM.
 
Old 02-17-2004, 01:30 AM   #6
JROCK1980
Member
 
Registered: Aug 2003
Distribution: FreeBSD
Posts: 490

Original Poster
Rep: Reputation: 30
KDE 3.1
 
Old 02-17-2004, 01:35 AM   #7
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
well shizzle. what are you using oss for? arts works perfectly fine for kde. just 3 things to do.
1. get the arts plugin for xmms installed and choosing that for the output plugin in xmms options
2. set the sound method preference in gaim to use arts (choose it from the dropdown combo list)
3. make sure the arts server is started up when logging in to kde (through the sound server configurator in control center)

you shouldn't get any more dsp resource conflicts in kde with xmms and gaim. other programs you may, but you can use the artsdsp command to mix the sounds together.

artdsp <command>
 
Old 02-17-2004, 02:07 AM   #8
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Arts wont play music by itself. You need OSS or ALSA to supply the sound drivers. I'd recommend ALSA because it does sound a bit like a dsp conflict. OSS doesn't support software mixing unless you're using something like arts or esd. ALSA has a dmix plugin that mplayer and xmms can use.
 
Old 02-17-2004, 02:19 AM   #9
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
true and i assumed he had at least OSS for the drivers. i'm pretty sure redhat ships with oss drivers. the only alsa package i've ever installed was alsa-libs for xmame.
 
Old 02-17-2004, 06:57 AM   #10
SiriusAB
Member
 
Registered: Feb 2003
Location: S_AB
Distribution: FC4; FC3; RH 9.0; XP
Posts: 86

Rep: Reputation: 15
Quote:
Originally posted by megaspaz
if i remember correctly, the new versions of xmms don't come with the arts plugin for use in kde. you can get that at the xmms website.
AHHHHH!!!!!!!!!!!!! I think this might be my 1.2.9 problem!!!
 
Old 02-17-2004, 07:37 AM   #11
SiriusAB
Member
 
Registered: Feb 2003
Location: S_AB
Distribution: FC4; FC3; RH 9.0; XP
Posts: 86

Rep: Reputation: 15
Thumbs up

Oh, that mofo is SO FIXED!!

Hats off to you, mega.

CRAP, it even works with Shoutcast .pls files. Wow.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
steam freezes point 2 play lowpingnoob Linux - Games 2 06-15-2005 01:27 AM
xmms freezes my comp doralsoral Linux - Software 1 01-07-2005 09:32 PM
XMMS freezes randomly during play cisforCOJO Linux - Software 1 11-03-2004 12:46 AM
XMMS sometimes Freezes Velocide Linux - Software 5 04-03-2004 07:01 AM
XMMS Freezes avram Linux - Software 2 02-08-2004 07:38 PM


All times are GMT -5. The time now is 12:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration