LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 02-23-2012, 09:10 PM   #1
starkid
LQ Newbie
 
Registered: Jan 2012
Location: California
Distribution: Ubuntu 11.10 x64/Debian 7.3.0 x64
Posts: 24

Rep: Reputation: Disabled
Question Xlib: extension "GLX" missing on display ":0.0".


I have ubuntu 11.10 x64. When I try to start quadrapassel (simple game that comes bundled with the distro) from the command line, I get the error:

Code:
Xlib:  extension "GLX" missing on display ":0.0".
Segmentation fault
Other games work fine. I have an nvidia video card. At some point, I had a proprietary driver installed for it. I tried to uninstall this driver a couple of times, but the uninstallation failed; I would still see the driver installed every time I went to Applications -> Settings -> Additional Drivers. The last time I tried was a few weeks ago. I looked again today, and, mysteriously, it's no longer installed (I'm guessing it had something to do with the kernel being updated). I don't know if this is related to the glx problem or not; I'm bringing it up just in case. I was getting the same quadrapassel error when I had this driver.

From my searching so far, I know that I need to have "Load glx" and "Load extmod" in the modules section of xorg.conf.nvidia. They are already there, so I don't know what else to do.

Come to think of it, should the system be using xorg.conf or xorg.conf.nvidia? xorg.conf is nearly empty and doesn't have any load module statements in it.

Last edited by starkid; 02-23-2012 at 09:11 PM.
 
Old 02-24-2012, 04:35 PM   #2
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
The system would only ever use xorg.conf, not xorg.conf.nvidia (even when using the nvidia driver). Please show us your /var/log/Xorg.0.log file.

Adam
 
Old 02-24-2012, 05:16 PM   #3
starkid
LQ Newbie
 
Registered: Jan 2012
Location: California
Distribution: Ubuntu 11.10 x64/Debian 7.3.0 x64
Posts: 24

Original Poster
Rep: Reputation: Disabled
part 1

[ 22.668]
X.Org X Server 1.10.4
Release Date: 2011-08-19
[ 22.668] X Protocol Version 11, Revision 0
[ 22.668] Build Operating System: Linux 2.6.24-29-server x86_64 Ubuntu
[ 22.668] Current Operating System: Linux xubuntu-sys 3.0.0-16-generic #28-Ubuntu SMP Fri Jan 27 17:44:39 UTC 2012 x86_64
[ 22.668] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.0.0-16-generic root=UUID=c80c3f41-9185-4c0f-a143-e87a18635ff6 ro splash vga=773 quiet splash vt.handoff=7
[ 22.668] Build Date: 19 October 2011 05:21:26AM
[ 22.668] xorg-server 2:1.10.4-1ubuntu4.2 (For technical support please see http://www.ubuntu.com/support)
[ 22.668] Current version of pixman: 0.22.2
[ 22.668] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 22.668] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 22.668] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Feb 24 14:00:44 2012
[ 22.705] (==) Using config file: "/etc/X11/xorg.conf"
[ 22.705] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 22.719] (==) No Layout section. Using the first Screen section.
[ 22.719] (==) No screen section available. Using defaults.
[ 22.719] (**) |-->Screen "Default Screen Section" (0)
[ 22.719] (**) | |-->Monitor "<default monitor>"
[ 22.720] (==) No device specified for screen "Default Screen Section".
Using the first device section listed.
[ 22.720] (**) | |-->Device "Default Device"
[ 22.720] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 22.720] (==) Automatically adding devices
[ 22.720] (==) Automatically enabling devices
[ 22.747] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 22.747] Entry deleted from font path.
[ 22.747] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[ 22.747] Entry deleted from font path.
[ 22.747] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[ 22.747] Entry deleted from font path.
[ 22.748] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[ 22.748] Entry deleted from font path.
[ 22.748] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[ 22.748] Entry deleted from font path.
[ 22.749] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/Type1,
/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
built-ins
[ 22.749] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[ 22.749] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 22.749] (II) Loader magic: 0x7e0220
[ 22.749] (II) Module ABI versions:
[ 22.749] X.Org ANSI C Emulation: 0.4
[ 22.749] X.Org Video Driver: 10.0
[ 22.749] X.Org XInput driver : 12.3
[ 22.749] X.Org Server Extension : 5.0
[ 22.751] (--) PCI:*(0:0:2:0) 8086:0116:1028:0571 rev 9, Mem @ 0xf2400000/4194304, 0xe0000000/268435456, I/O @ 0x00005000/64
[ 22.752] (--) PCI: (0:1:0:0) 10de:1246:1028:0571 rev 161, Mem @ 0xf0000000/33554432, 0xc0000000/268435456, 0xd0000000/67108864, I/O @ 0x00004000/128, BIOS @ 0x????????/524288
[ 22.752] (II) Open ACPI successful (/var/run/acpid.socket)
[ 22.752] (II) LoadModule: "extmod"
[ 22.848] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[ 22.863] (II) Module extmod: vendor="X.Org Foundation"
[ 22.863] compiled for 1.10.4, module version = 1.0.0
[ 22.864] Module class: X.Org Server Extension
[ 22.864] ABI class: X.Org Server Extension, version 5.0
[ 22.864] (II) Loading extension MIT-SCREEN-SAVER
[ 22.864] (II) Loading extension XFree86-VidModeExtension
[ 22.864] (II) Loading extension XFree86-DGA
[ 22.864] (II) Loading extension DPMS
[ 22.864] (II) Loading extension XVideo
[ 22.864] (II) Loading extension XVideo-MotionCompensation
[ 22.864] (II) Loading extension X-Resource
[ 22.864] (II) LoadModule: "dbe"
[ 22.864] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[ 22.880] (II) Module dbe: vendor="X.Org Foundation"
[ 22.880] compiled for 1.10.4, module version = 1.0.0
[ 22.880] Module class: X.Org Server Extension
[ 22.880] ABI class: X.Org Server Extension, version 5.0
[ 22.880] (II) Loading extension DOUBLE-BUFFER
[ 22.880] (II) LoadModule: "glx"
[ 22.880] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so
[ 23.881] (II) Module glx: vendor="NVIDIA Corporation"
[ 23.930] compiled for 4.0.2, module version = 1.0.0
[ 23.930] Module class: X.Org Server Extension
[ 23.930] (II) NVIDIA GLX Module 280.13 Wed Jul 27 17:12:07 PDT 2011
[ 23.930] (II) Loading extension GLX
[ 23.930] (II) LoadModule: "record"
[ 23.931] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[ 24.016] (II) Module record: vendor="X.Org Foundation"
[ 24.016] compiled for 1.10.4, module version = 1.13.0
[ 24.016] Module class: X.Org Server Extension
[ 24.016] ABI class: X.Org Server Extension, version 5.0
[ 24.016] (II) Loading extension RECORD
[ 24.016] (II) LoadModule: "dri"
[ 24.016] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[ 24.067] (II) Module dri: vendor="X.Org Foundation"
[ 24.067] compiled for 1.10.4, module version = 1.0.0
[ 24.067] ABI class: X.Org Server Extension, version 5.0
[ 24.067] (II) Loading extension XFree86-DRI
[ 24.067] (II) LoadModule: "dri2"
[ 24.067] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[ 24.175] (II) Module dri2: vendor="X.Org Foundation"
[ 24.175] compiled for 1.10.4, module version = 1.2.0
[ 24.175] ABI class: X.Org Server Extension, version 5.0
[ 24.175] (II) Loading extension DRI2
[ 24.175] (==) Matched intel as autoconfigured driver 0
[ 24.175] (==) Matched vesa as autoconfigured driver 1
[ 24.175] (==) Matched fbdev as autoconfigured driver 2
[ 24.175] (==) Assigned the driver to the xf86ConfigLayout
[ 24.175] (II) LoadModule: "intel"
[ 24.206] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ 24.266] (II) Module intel: vendor="X.Org Foundation"
[ 24.266] compiled for 1.10.4, module version = 2.15.901
[ 24.266] Module class: X.Org Video Driver
[ 24.266] ABI class: X.Org Video Driver, version 10.0
[ 24.266] (II) LoadModule: "vesa"
[ 24.266] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 24.289] (II) Module vesa: vendor="X.Org Foundation"
[ 24.289] compiled for 1.10.2, module version = 2.3.0
[ 24.289] Module class: X.Org Video Driver
[ 24.289] ABI class: X.Org Video Driver, version 10.0
[ 24.289] (II) LoadModule: "fbdev"
[ 24.289] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 24.347] (II) Module fbdev: vendor="X.Org Foundation"
[ 24.347] compiled for 1.10.0, module version = 0.4.2
[ 24.347] ABI class: X.Org Video Driver, version 10.0
[ 24.347] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server
[ 24.347] (II) VESA: driver for VESA chipsets: vesa
[ 24.347] (II) FBDEV: driver for framebuffer: fbdev
[ 24.347] (++) using VT number 7

[ 24.348] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ 24.348] (WW) Falling back to old probe method for vesa
[ 24.348] (WW) Falling back to old probe method for fbdev
[ 24.348] (II) Loading sub module "fbdevhw"
[ 24.348] (II) LoadModule: "fbdevhw"
[ 24.349] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 24.349] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 24.349] compiled for 1.10.4, module version = 0.0.2
[ 24.349] ABI class: X.Org Video Driver, version 10.0
[ 24.349] drmOpenDevice: node name is /dev/dri/card0
[ 24.349] drmOpenDevice: open result is 12, (OK)
[ 24.349] drmOpenByBusid: Searching for BusID pci:0000:00:02.0
[ 24.349] drmOpenDevice: node name is /dev/dri/card0
[ 24.349] drmOpenDevice: open result is 12, (OK)
[ 24.349] drmOpenByBusid: drmOpenMinor returns 12
[ 24.349] drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
[ 24.349] (II) intel(0): Creating default Display subsection in Screen section
"Default Screen Section" for depth/fbbpp 24/32
[ 24.349] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[ 24.349] (==) intel(0): RGB weight 888
[ 24.349] (==) intel(0): Default visual is TrueColor
[ 24.349] (II) intel(0): Integrated Graphics Chipset: Intel(R) Sandybridge Mobile (GT2)
[ 24.349] (--) intel(0): Chipset: "Sandybridge Mobile (GT2)"
[ 24.349] (**) intel(0): Relaxed fencing enabled
[ 24.350] (**) intel(0): Wait on SwapBuffers? enabled
[ 24.350] (**) intel(0): Triple buffering? enabled
[ 24.350] (**) intel(0): Framebuffer tiled
[ 24.350] (**) intel(0): Pixmaps tiled
[ 24.350] (**) intel(0): 3D buffers tiled
[ 24.350] (**) intel(0): SwapBuffers wait enabled
[ 24.350] (==) intel(0): video overlay key set to 0x101fe
[ 24.350] (II) intel(0): Output LVDS1 has no monitor section
[ 24.350] (II) intel(0): found backlight control interface /sys/class/backlight/acpi_video1
[ 24.350] (II) intel(0): Output VGA1 has no monitor section
[ 24.373] (II) intel(0): Output HDMI1 has no monitor section
[ 24.428] (II) intel(0): Output DP1 has no monitor section
[ 24.428] (II) intel(0): EDID for output LVDS1
[ 24.428] (II) intel(0): Manufacturer: CMO Model: 1718 Serial#: 0
[ 24.428] (II) intel(0): Year: 2010 Week: 23
[ 24.428] (II) intel(0): EDID Version: 1.3
[ 24.428] (II) intel(0): Digital Display Input
[ 24.428] (II) intel(0): Max Image Size [cm]: horiz.: 38 vert.: 22
[ 24.428] (II) intel(0): Gamma: 2.20
[ 24.428] (II) intel(0): No DPMS capabilities specified
[ 24.428] (II) intel(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
[ 24.428] (II) intel(0): First detailed timing is preferred mode
[ 24.428] (II) intel(0): redX: 0.617 redY: 0.336 greenX: 0.321 greenY: 0.596
[ 24.428] (II) intel(0): blueX: 0.160 blueY: 0.081 whiteX: 0.313 whiteY: 0.329
[ 24.428] (II) intel(0): Manufacturer's mask: 0
[ 24.428] (II) intel(0): Supported detailed timing:
[ 24.428] (II) intel(0): clock: 108.0 MHz Image Size: 382 x 215 mm
[ 24.428] (II) intel(0): h_active: 1600 h_sync: 1687 h_sync_end 1745 h_blank_end 1900 h_border: 0
[ 24.428] (II) intel(0): v_active: 900 v_sync: 905 v_sync_end 914 v_blanking: 947 v_border: 0
[ 24.428] (II) intel(0): Supported detailed timing:
[ 24.428] (II) intel(0): clock: 108.0 MHz Image Size: 382 x 215 mm
[ 24.428] (II) intel(0): h_active: 1600 h_sync: 1687 h_sync_end 1745 h_blank_end 1900 h_border: 0
[ 24.428] (II) intel(0): v_active: 900 v_sync: 905 v_sync_end 914 v_blanking: 947 v_border: 0
[ 24.428] (II) intel(0): KPMRT\80N173O6
[ 24.428] (II) intel(0): Unknown vendor-specific block 0
[ 24.428] (II) intel(0): EDID (in hex):
[ 24.428] (II) intel(0): 00ffffffffffff000daf181700000000
[ 24.428] (II) intel(0): 17140103902616780a06359e56529829
[ 24.428] (II) intel(0): 14505400000001010101010101010101
[ 24.428] (II) intel(0): 0101010101012c2a402c61842f30573a
[ 24.428] (II) intel(0): 59007ed71000001a2c2a402c61842f30
[ 24.428] (II) intel(0): 573a59007ed71000001a000000fe004b
[ 24.428] (II) intel(0): 504d5254804e3137334f360a00000000
[ 24.428] (II) intel(0): 00000000000000000002010a202000e5
[ 24.428] (II) intel(0): EDID vendor "CMO", prod id 5912
[ 24.428] (II) intel(0): Printing DDC gathered Modelines:
[ 24.428] (II) intel(0): Modeline "1600x900"x0.0 107.96 1600 1687 1745 1900 900 905 914 947 +hsync -vsync (56.8 kHz)
[ 24.428] (II) intel(0): Not using default mode "320x240" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "512x384" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "640x480" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "640x512" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "800x600" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "896x672" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "928x696" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "960x720" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "576x432" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "680x384" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "680x384" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "700x525" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "720x450" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "800x512" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "840x525" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "840x525" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "960x540" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "960x600" (doublescan mode not supported)
[ 24.428] (II) intel(0): Not using default mode "1024x768" (doublescan mode not supported)
[ 24.428] (II) intel(0): Printing probed modes for output LVDS1
[ 24.428] (II) intel(0): Modeline "1600x900"x60.0 107.96 1600 1687 1745 1900 900 905 914 947 +hsync -vsync (56.8 kHz)
[ 24.428] (II) intel(0): Modeline "1440x900"x59.9 106.50 1440 1520 1672 1904 900 903 909 934 -hsync +vsync (55.9 kHz)
[ 24.428] (II) intel(0): Modeline "1360x768"x59.8 84.75 1360 1432 1568 1776 768 771 781 798 -hsync +vsync (47.7 kHz)
[ 24.428] (II) intel(0): Modeline "1360x768"x60.0 72.00 1360 1408 1440 1520 768 771 781 790 +hsync -vsync (47.4 kHz)
[ 24.428] (II) intel(0): Modeline "1152x864"x60.0 81.62 1152 1216 1336 1520 864 865 868 895 -hsync +vsync (53.7 kHz)
[ 24.428] (II) intel(0): Modeline "1024x768"x60.0 65.00 1024 1048 1184 1344 768 771 777 806 -hsync -vsync (48.4 kHz)
[ 24.428] (II) intel(0): Modeline "800x600"x60.3 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync (37.9 kHz)
[ 24.428] (II) intel(0): Modeline "800x600"x56.2 36.00 800 824 896 1024 600 601 603 625 +hsync +vsync (35.2 kHz)
[ 24.428] (II) intel(0): Modeline "640x480"x59.9 25.18 640 656 752 800 480 490 492 525 -hsync -vsync (31.5 kHz)
[ 24.428] (II) intel(0): EDID for output VGA1
[ 24.451] (II) intel(0): EDID for output HDMI1
[ 24.508] (II) intel(0): EDID for output DP1
[ 24.508] (II) intel(0): Output LVDS1 connected
[ 24.508] (II) intel(0): Output VGA1 disconnected
[ 24.508] (II) intel(0): Output HDMI1 disconnected
[ 24.508] (II) intel(0): Output DP1 disconnected
[ 24.508] (II) intel(0): Using exact sizes for initial modes
[ 24.508] (II) intel(0): Output LVDS1 using initial mode 1600x900
[ 24.508] (II) intel(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[ 24.508] (II) intel(0): Kernel page flipping support detected, enabling
[ 24.508] (**) intel(0): Display dimensions: (380, 220) mm
[ 24.508] (**) intel(0): DPI set to (106, 103)
[ 24.508] (II) Loading sub module "fb"
[ 24.508] (II) LoadModule: "fb"
[ 24.536] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 24.558] (II) Module fb: vendor="X.Org Foundation"
[ 24.558] compiled for 1.10.4, module version = 1.0.0
[ 24.558] ABI class: X.Org ANSI C Emulation, version 0.4
[ 24.558] (II) Loading sub module "dri2"
[ 24.558] (II) LoadModule: "dri2"
[ 24.558] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[ 24.558] (II) Module dri2: vendor="X.Org Foundation"
[ 24.558] compiled for 1.10.4, module version = 1.2.0
[ 24.558] ABI class: X.Org Server Extension, version 5.0
[ 24.559] (II) UnloadModule: "vesa"
[ 24.559] (II) Unloading vesa
[ 24.559] (II) UnloadModule: "fbdev"
[ 24.559] (II) Unloading fbdev
[ 24.559] (II) UnloadModule: "fbdevhw"
[ 24.559] (II) Unloading fbdevhw
[ 24.559] (==) Depth 24 pixmap format is 32 bpp
[ 24.559] (II) intel(0): [DRI2] Setup complete
[ 24.559] (II) intel(0): [DRI2] DRI driver: i965
[ 24.559] (II) intel(0): Allocated new frame buffer 1600x900 stride 6656, tiled
[ 24.578] (II) UXA(0): Driver registered support for the following operations:
[ 24.578] (II) solid
[ 24.578] (II) copy
[ 24.578] (II) composite (RENDER acceleration)
[ 24.578] (II) put_image
[ 24.578] (II) get_image
[ 24.578] (==) intel(0): Backing store disabled
[ 24.578] (==) intel(0): Silken mouse enabled
[ 24.578] (II) intel(0): Initializing HW Cursor
[ 24.640] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[ 24.640] (==) intel(0): DPMS enabled
[ 24.640] (==) intel(0): Intel XvMC decoder enabled
[ 24.640] (II) intel(0): Set up textured video
[ 24.640] (II) intel(0): [XvMC] xvmc_vld driver initialized.
[ 24.640] (II) intel(0): direct rendering: DRI2 Enabled
[ 24.640] (WW) intel(0): Option "NoLogo" is not used
[ 24.640] (==) intel(0): hotplug detection: "enabled"
[ 24.640] (--) RandR disabled
[ 24.640] (II) Initializing built-in extension Generic Event Extension
[ 24.640] (II) Initializing built-in extension SHAPE
[ 24.640] (II) Initializing built-in extension MIT-SHM
[ 24.640] (II) Initializing built-in extension XInputExtension
[ 24.640] (II) Initializing built-in extension XTEST
[ 24.640] (II) Initializing built-in extension BIG-REQUESTS
[ 24.640] (II) Initializing built-in extension SYNC
[ 24.640] (II) Initializing built-in extension XKEYBOARD
[ 24.640] (II) Initializing built-in extension XC-MISC
[ 24.640] (II) Initializing built-in extension SECURITY
[ 24.640] (II) Initializing built-in extension XINERAMA
[ 24.640] (II) Initializing built-in extension XFIXES
[ 24.640] (II) Initializing built-in extension RENDER
[ 24.640] (II) Initializing built-in extension RANDR
[ 24.640] (II) Initializing built-in extension COMPOSITE
[ 24.640] (II) Initializing built-in extension DAMAGE
[ 24.640] (II) Initializing built-in extension GESTURE
[ 24.678] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
[ 24.682] (II) intel(0): Setting screen physical size to 423 x 238
[ 24.795] (II) XKB: reuse xkmfile /var/lib/xkb/server-B20D7FC79C7F597315E3E501AEF10E0D866E8E92.xkm
[ 24.811] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[ 24.811] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 24.811] (II) LoadModule: "evdev"
[ 24.811] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 24.857] (II) Module evdev: vendor="X.Org Foundation"
[ 24.857] compiled for 1.10.2, module version = 2.6.0
[ 24.857] Module class: X.Org XInput Driver
[ 24.857] ABI class: X.Org XInput driver, version 12.3
[ 24.857] (II) Using input driver 'evdev' for 'Power Button'
[ 24.857] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 24.857] (**) Power Button: always reports core events
[ 24.857] (**) Power Button: Device: "/dev/input/event3"
[ 24.857] (--) Power Button: Found keys
[ 24.857] (II) Power Button: Configuring as keyboard
[ 24.857] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input3/event3"
[ 24.857] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[ 24.857] (**) Option "xkb_rules" "evdev"
[ 24.857] (**) Option "xkb_model" "pc105"
[ 24.858] (**) Option "xkb_layout" "us"
[ 24.858] (**) Option "xkb_variant" "intl"
[ 24.859] (II) XKB: reuse xkmfile /var/lib/xkb/server-A5431D4A34463C892C9E905E2E421B30A3CC30DD.xkm
[ 24.956] (II) config/udev: Adding input device Video Bus (/dev/input/event9)
[ 24.956] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[ 24.956] (II) Using input driver 'evdev' for 'Video Bus'
[ 24.956] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 24.956] (**) Video Bus: always reports core events
[ 24.956] (**) Video Bus: Device: "/dev/input/event9"
[ 24.956] (--) Video Bus: Found keys
[ 24.956] (II) Video Bus: Configuring as keyboard
[ 24.956] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:01/input/input9/event9"
[ 24.956] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
[ 24.956] (**) Option "xkb_rules" "evdev"
[ 24.956] (**) Option "xkb_model" "pc105"
[ 24.956] (**) Option "xkb_layout" "us"
[ 24.956] (**) Option "xkb_variant" "intl"
[ 24.958] (II) config/udev: Adding input device Video Bus (/dev/input/event7)
[ 24.958] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[ 24.958] (II) Using input driver 'evdev' for 'Video Bus'
[ 24.958] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 24.958] (**) Video Bus: always reports core events
[ 24.958] (**) Video Bus: Device: "/dev/input/event7"
[ 24.958] (--) Video Bus: Found keys
[ 24.958] (II) Video Bus: Configuring as keyboard
[ 24.958] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:2c/LNXVIDEO:00/input/input7/event7"
[ 24.958] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
[ 24.958] (**) Option "xkb_rules" "evdev"
[ 24.958] (**) Option "xkb_model" "pc105"
[ 24.958] (**) Option "xkb_layout" "us"
[ 24.958] (**) Option "xkb_variant" "intl"
[ 24.963] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[ 24.963] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 24.963] (II) Using input driver 'evdev' for 'Power Button'
[ 24.963] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 24.963] (**) Power Button: always reports core events
[ 24.963] (**) Power Button: Device: "/dev/input/event0"
[ 24.963] (--) Power Button: Found keys
[ 24.963] (II) Power Button: Configuring as keyboard
[ 24.963] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input0/event0"
[ 24.963] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[ 24.963] (**) Option "xkb_rules" "evdev"
[ 24.963] (**) Option "xkb_model" "pc105"
[ 24.963] (**) Option "xkb_layout" "us"
[ 24.963] (**) Option "xkb_variant" "intl"
[ 24.963] (II) config/udev: Adding input device Lid Switch (/dev/input/event2)
[ 24.963] (II) No input driver/identifier specified (ignoring)
[ 24.963] (II) config/udev: Adding input device Sleep Button (/dev/input/event1)
[ 24.963] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[ 24.963] (II) Using input driver 'evdev' for 'Sleep Button'
[ 24.963] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 24.963] (**) Sleep Button: always reports core events
[ 24.963] (**) Sleep Button: Device: "/dev/input/event1"
[ 24.963] (--) Sleep Button: Found keys
[ 24.963] (II) Sleep Button: Configuring as keyboard
[ 24.963] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input1/event1"
[ 24.963] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD)
[ 24.963] (**) Option "xkb_rules" "evdev"
[ 24.963] (**) Option "xkb_model" "pc105"
[ 24.963] (**) Option "xkb_layout" "us"
[ 24.963] (**) Option "xkb_variant" "intl"
[ 24.965] (II) config/udev: Adding input device Laptop_Integrated_Webcam_2HDM (/dev/input/event8)
[ 24.965] (**) Laptop_Integrated_Webcam_2HDM: Applying InputClass "evdev keyboard catchall"
[ 24.965] (II) Using input driver 'evdev' for 'Laptop_Integrated_Webcam_2HDM'
[ 24.965] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 24.965] (**) Laptop_Integrated_Webcam_2HDM: always reports core events
[ 24.965] (**) Laptop_Integrated_Webcam_2HDM: Device: "/dev/input/event8"
[ 24.965] (--) Laptop_Integrated_Webcam_2HDM: Found keys
[ 24.965] (II) Laptop_Integrated_Webcam_2HDM: Configuring as keyboard
[ 24.965] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4:1.0/input/input8/event8"
 
Old 02-24-2012, 05:16 PM   #4
starkid
LQ Newbie
 
Registered: Jan 2012
Location: California
Distribution: Ubuntu 11.10 x64/Debian 7.3.0 x64
Posts: 24

Original Poster
Rep: Reputation: Disabled
part 2

[ 24.965] (II) XINPUT: Adding extended input device "Laptop_Integrated_Webcam_2HDM" (type: KEYBOARD)
[ 24.965] (**) Option "xkb_rules" "evdev"
[ 24.965] (**) Option "xkb_model" "pc105"
[ 24.965] (**) Option "xkb_layout" "us"
[ 24.965] (**) Option "xkb_variant" "intl"
[ 24.965] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=3 (/dev/input/event10)
[ 24.965] (II) No input driver/identifier specified (ignoring)
[ 24.966] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event11)
[ 24.966] (II) No input driver/identifier specified (ignoring)
[ 24.966] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event12)
[ 24.966] (II) No input driver/identifier specified (ignoring)
[ 24.969] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event4)
[ 24.969] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[ 24.969] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[ 24.969] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 24.969] (**) AT Translated Set 2 keyboard: always reports core events
[ 24.969] (**) AT Translated Set 2 keyboard: Device: "/dev/input/event4"
[ 24.969] (--) AT Translated Set 2 keyboard: Found keys
[ 24.969] (II) AT Translated Set 2 keyboard: Configuring as keyboard
[ 24.969] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input4/event4"
[ 24.969] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
[ 24.969] (**) Option "xkb_rules" "evdev"
[ 24.969] (**) Option "xkb_model" "pc105"
[ 24.969] (**) Option "xkb_layout" "us"
[ 24.969] (**) Option "xkb_variant" "intl"
[ 24.969] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event6)
[ 24.969] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[ 24.969] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[ 24.969] (II) LoadModule: "synaptics"
[ 24.970] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 24.970] (II) Module synaptics: vendor="X.Org Foundation"
[ 24.970] compiled for 1.10.4, module version = 1.4.1
[ 24.970] Module class: X.Org XInput Driver
[ 24.970] ABI class: X.Org XInput driver, version 12.3
[ 24.970] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[ 24.970] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 24.970] (**) SynPS/2 Synaptics TouchPad: always reports core events
[ 24.970] (**) Option "Device" "/dev/input/event6"
[ 25.100] (--) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5398
[ 25.100] (--) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4728
[ 25.100] (--) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[ 25.100] (--) SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[ 25.100] (--) SynPS/2 Synaptics TouchPad: buttons: left right double triple
[ 25.224] (--) SynPS/2 Synaptics TouchPad: touchpad found
[ 25.224] (**) SynPS/2 Synaptics TouchPad: always reports core events
[ 25.328] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input6/event6"
[ 25.330] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
[ 25.330] (**) SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[ 25.330] (**) SynPS/2 Synaptics TouchPad: MaxSpeed is now 1.75
[ 25.330] (**) SynPS/2 Synaptics TouchPad: AccelFactor is now 0.039
[ 25.330] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[ 25.330] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[ 25.330] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[ 25.330] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[ 25.331] (--) SynPS/2 Synaptics TouchPad: touchpad found
[ 25.331] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[ 25.331] (II) No input driver/identifier specified (ignoring)
[ 25.334] (II) config/udev: Adding input device Dell WMI hotkeys (/dev/input/event5)
[ 25.334] (**) Dell WMI hotkeys: Applying InputClass "evdev keyboard catchall"
[ 25.334] (II) Using input driver 'evdev' for 'Dell WMI hotkeys'
[ 25.334] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 25.334] (**) Dell WMI hotkeys: always reports core events
[ 25.334] (**) Dell WMI hotkeys: Device: "/dev/input/event5"
[ 25.334] (--) Dell WMI hotkeys: Found keys
[ 25.334] (II) Dell WMI hotkeys: Configuring as keyboard
[ 25.334] (**) Option "config_info" "udev:/sys/devices/virtual/input/input5/event5"
[ 25.334] (II) XINPUT: Adding extended input device "Dell WMI hotkeys" (type: KEYBOARD)
[ 25.334] (**) Option "xkb_rules" "evdev"
[ 25.334] (**) Option "xkb_model" "pc105"
[ 25.334] (**) Option "xkb_layout" "us"
[ 25.334] (**) Option "xkb_variant" "intl"
[ 80.635] (II) XKB: reuse xkmfile /var/lib/xkb/server-CA82093D38BFEAEF36BB4318AC0909BE2F4873AE.xkm
[ 81.145] (II) intel(0): EDID vendor "CMO", prod id 5912
[ 81.145] (II) intel(0): Printing DDC gathered Modelines:
[ 81.145] (II) intel(0): Modeline "1600x900"x0.0 107.96 1600 1687 1745 1900 900 905 914 947 +hsync -vsync (56.8 kHz)
[ 83.072] (II) intel(0): EDID vendor "CMO", prod id 5912
[ 83.072] (II) intel(0): Printing DDC gathered Modelines:
[ 83.072] (II) intel(0): Modeline "1600x900"x0.0 107.96 1600 1687 1745 1900 900 905 914 947 +hsync -vsync (56.8 kHz)
 
Old 02-24-2012, 05:36 PM   #5
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Please use [code][/code] tags in the future. Or, even better, a service like http://pastebin.com/

Your laptop has two GPUs, one from Intel and one from nVidia. If you are unable to disable the intel GPU, you will not be able to use the nvidia GPU at all (either with nouveau or the proprietary driver) without using a software project called Bumblebee: http://forums.nvidia.com/index.php?showtopic=203600 This still seems to be hit or miss.

Anyway, you are using the intel GPU at the moment, but you still clearly have part of the nvidia driver installed:

Code:
[ 23.881] (II) Module glx: vendor="NVIDIA Corporation"
What does "dpkg -S /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so" return?

Adam
 
Old 02-24-2012, 06:55 PM   #6
starkid
LQ Newbie
 
Registered: Jan 2012
Location: California
Distribution: Ubuntu 11.10 x64/Debian 7.3.0 x64
Posts: 24

Original Poster
Rep: Reputation: Disabled
Code:
dpkg-query: no path found matching pattern /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so.
 
Old 02-24-2012, 07:05 PM   #7
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
You've managed to create quite a mess of your system. The nvidia drivers are at least partially installed, but they aren't registered with your package manager.

Please show us your /etc/X11/xorg.conf file.
 
Old 02-24-2012, 07:13 PM   #8
starkid
LQ Newbie
 
Registered: Jan 2012
Location: California
Distribution: Ubuntu 11.10 x64/Debian 7.3.0 x64
Posts: 24

Original Poster
Rep: Reputation: Disabled
Code:
Section "Device"
	Identifier	"Default Device"
	Option	"NoLogo"	"True"
EndSection
 
Old 02-24-2012, 07:19 PM   #9
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Ahhh, I forgot that Ubuntu sets your ModulePath to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules" by default.

Alright, it looks like you'll have to go through your system bit by bit and remove whatever parts of the nvidia driver remain. I'd start by removing /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so and reinstalling your xserver-xorg-core package via synaptic (or apt-get). Then restart X and see if 'glxinfo' works.

Adam
 
Old 02-24-2012, 07:33 PM   #10
starkid
LQ Newbie
 
Registered: Jan 2012
Location: California
Distribution: Ubuntu 11.10 x64/Debian 7.3.0 x64
Posts: 24

Original Poster
Rep: Reputation: Disabled
I deleted the file, but I already had the latest version of xserver-xorg-core installed (you didn't mean uninstall then reinstall, did you?). I logged out and then back in; here is the output of

Code:
glxinfo
:

http://pastebin.com/pRHsBxLu
EDIT: and the game works now!

Last edited by starkid; 02-24-2012 at 07:40 PM.
 
Old 02-24-2012, 08:11 PM   #11
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Yeah, but your drivers still aren't working properly. You're using the nvidia GL library.

What's the output of 'ldd /usr/bin/glxinfo'?

Adam
 
Old 02-24-2012, 08:15 PM   #12
starkid
LQ Newbie
 
Registered: Jan 2012
Location: California
Distribution: Ubuntu 11.10 x64/Debian 7.3.0 x64
Posts: 24

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by adamk75 View Post
What's the output of 'ldd /usr/bin/glxinfo'?
Code:
	linux-vdso.so.1 =>  (0x00007fffdbb87000)
	libGL.so.1 => /usr/lib/nvidia-current/libGL.so.1 (0x00007f78a0922000)
	libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f78a05ea000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f78a024a000)
	libnvidia-tls.so.280.13 => /usr/lib/nvidia-current/tls/libnvidia-tls.so.280.13 (0x00007f78a0047000)
	libnvidia-glcore.so.280.13 => /usr/lib/nvidia-current/libnvidia-glcore.so.280.13 (0x00007f789e1fb000)
	libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f789dfe7000)
	librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f789dddf000)
	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f789dbdb000)
	libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f789d9be000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f78a0c59000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f789d73a000)
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f789d51d000)
	libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f789d319000)
	libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f789d113000)
 
Old 02-24-2012, 08:45 PM   #13
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Code:
libGL.so.1 => /usr/lib/nvidia-current/libGL.so.1
Somewhere your LD_LIBRARY_PATH is getting set to include /usr/lib/nvidia-current. I don't know where this is happening (perhaps in some file under /etc/profile.d/). You'll want to remove the files in /usr/lib/nvidia-current/ and you should also see if you can find where that variable is getting set.

Adam
 
Old 02-24-2012, 09:01 PM   #14
starkid
LQ Newbie
 
Registered: Jan 2012
Location: California
Distribution: Ubuntu 11.10 x64/Debian 7.3.0 x64
Posts: 24

Original Poster
Rep: Reputation: Disabled
Ok, I will do some looking around...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xlib: extension "GLX" missing on display ":0.0". nolrai Linux - Desktop 5 06-21-2008 01:29 AM
Xlib: extension "GLX" missing on display ":0.0". jrk5050 Linux - Hardware 5 05-09-2008 12:19 AM
Video Card Nvidia Driver Xlib: extension "GLX" missing on display ":0.0". HELP! badgerbox76 Linux - Newbie 35 03-08-2007 03:27 AM
Video Card Nvidia Driver Xlib: extension "GLX" missing on display ":0.0". badgerbox76 Linux - Games 13 01-11-2006 05:47 PM


All times are GMT -5. The time now is 06:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration