LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-27-2003, 07:34 PM   #1
kazuni
Member
 
Registered: May 2003
Location: Hong Kong
Distribution: Android on HTC Hero
Posts: 256

Rep: Reputation: 30
Question Xine + Xvid + SuSE 8.2 = no go?


I was wondering, due to the GPL licensing or something like that, is XVID totally not supported in SuSE 8.2? because when i tried to play an xvid video under xine it just won't work - the sound comes up but the video is not. i remember in my xine window it mentioned about licensing so that "some features" will not work - i guess now xvid codec is under those mentioned - anyways, is there any way to play an xvid video under xine / mplayer in suse 8.2? i tried installing the xvid codec but i don't think xine is recognizing it (installed it from rpm.pbone.net - searched for xvid and *only* for suse 8.x distribution - i found the rpm and installed it - still no go)

anyone can give me a hand here? thanks in advance

kazuni, abs0lute :newbie
 
Old 05-27-2003, 09:36 PM   #2
kazuni
Member
 
Registered: May 2003
Location: Hong Kong
Distribution: Android on HTC Hero
Posts: 256

Original Poster
Rep: Reputation: 30
and i also tried to copmile the tarballs on the xine website for the xine-ilb and it gives me errors:
./configure has no problems, but
make install:
....
....
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../.. -I../.. -I../../src -I../../src -I../../src/xine-engine -I../../src/xine-engine -I../../src/xine-utils -I../../src/xine-utils -g -O2 -Wall -D_REENTRANT -D_FILE_OFFSET_BITS=64 -DXINE_COMPILE -O3 -pipe -fomit-frame-pointer -falign-functions=4 -falign-loops=4 -falign-jumps=4 -mpreferred-stack-boundary=2 -fexpensive-optimizations -fschedule-insns2 -fno-strict-aliasing -ffast-math -funroll-loops -finline-functions -mcpu=athlon -I/usr/X11R6/include -DXINE_COMPILE -I../../src/video_out/vidix -I../../src/video_out/vidix -c deinterlace.c -DPIC -o deinterlace.lo
{standard input}: Assembler messages:
{standard input}:1009: Error: suffix or operands invalid for `pcmpgtw'
make[3]: *** [deinterlace.lo] Error 1
make[3]: Leaving directory `/root/xine-lib-0.9.13/src/video_out'
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory `/root/xine-lib-0.9.13/src/video_out'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/root/xine-lib-0.9.13/src'
make: *** [install-recursive] Error 1
linux:~/xine-lib-0.9.13 #

i have no idea what this means, but i guess it wouldn't compile properly.

anyone got any idea?
 
Old 05-28-2003, 07:31 AM   #3
kazuni
Member
 
Registered: May 2003
Location: Hong Kong
Distribution: Android on HTC Hero
Posts: 256

Original Poster
Rep: Reputation: 30
ok, so i wandered around and found another 2 rpm packages on the net - namely the one from http://packman.links2linux.org/?action=175

xine-ui-0.9.21-0.pm.0.i686.rpm (xine-ui)
and xvid-0.9.1-1.pm.0.i586.rpm (xvid)

now the problem is, i cannot have any display! - the sound plays fine in xine, but no screen - and it also made the other formats (divx is already not supported) mpeg, vcd, etc not playable - all i get is a black screen. when i drag the video screen around it shows blue traces - the funny thing is the video screen does resize to the movies' original size (say, my video is 512x300 it will resize to that but no display whatsoever)

i tried different display plugins (auto, xv, xshm, vidixfb, vidix, fb, none) and still no go - i even tried uninstalling the display drivers of my video card (nvidia official drivers - tried reverting to the original drivers (without acceleration) by suse) and still no go...

(mplayer has the same problem - sound but no screen, kmplayer as well)

argh! please! can someone help me!
 
Old 05-28-2003, 07:22 PM   #4
aherm
Member
 
Registered: Jan 2003
Location: upNorth
Distribution: openSuSE/uBuntu
Posts: 410

Rep: Reputation: 30
Remove (uninstall) your MPlayer and Xine.

Download everything from e.g.:
http://packman.links2linux.org/index.php4?action=128
You may need (among others):

libdvdcss2-1.2.6-0
libdvdread-0.9.4-2
libxine1-dvd-1_beta12-0
libdvdnav-0.1.9-0
libxine1-w32dll-1_beta12-0
kdemultimedia3-video-xine-3.1.2-3
libxine1-dvd-1_beta12-0
kxine-cvs-200305110026
libxine1-1_beta12-0
xine-ui-0.9.21-0
mplayerplug-in-0.80-1
kmplayer-0.7.4a-3
MPlayer-0.90-1
divx4linux-20020418-1


Have fun :-)
 
Old 05-28-2003, 07:25 PM   #5
iceman47
Senior Member
 
Registered: Oct 2002
Location: Belgium
Distribution: Debian, Free/OpenBSD
Posts: 1,123

Rep: Reputation: 47
Happy bitrhday btw kazuni
 
Old 05-28-2003, 08:54 PM   #6
kazuni
Member
 
Registered: May 2003
Location: Hong Kong
Distribution: Android on HTC Hero
Posts: 256

Original Poster
Rep: Reputation: 30
iceman47: thanks dude

oh yeah, i tried that... still won't work - the great black screen still stays hovering my computer !! ARGH

i guess that's the only thing that turned me back to mandrake - and now i love it! (mandrake - i have suse and mandrake as dual boot - i occasionally flip back and forth for files and watching movies - ain't linux a great system? i totally forgot about windows - except playing warcraft perhaps

btw any tutorial to get wine working with warcraft3? i heard about winex but they are not opensource for download - i downloaded the redhat 8.x version of winex and it won't exec :|
 
Old 05-31-2003, 09:21 AM   #7
aherm
Member
 
Registered: Jan 2003
Location: upNorth
Distribution: openSuSE/uBuntu
Posts: 410

Rep: Reputation: 30
That's weird. I got it working right away after uninstalling MPlayer (and using the one from repo.). Xine is fine too using libxine and xine-ui. I grabbed those packages using apt-get though ;-)

I think you missed the first step (rpm -e MPlayer). I wonder why SuSE insists installing this crippled package ;-)

Else you should try apt for SuSE.


Have more fun :-)
 
Old 06-01-2003, 07:54 PM   #8
kazuni
Member
 
Registered: May 2003
Location: Hong Kong
Distribution: Android on HTC Hero
Posts: 256

Original Poster
Rep: Reputation: 30
hehe. thanks tho dude. i kinda gave up on SuSE... now i am on the hardcore slackware
 
Old 06-02-2003, 10:20 AM   #9
Jafar
LQ Newbie
 
Registered: May 2003
Posts: 11

Rep: Reputation: 0
kxine-cvs-200305110026

Hi, I'm a newbie

How can install kxine cvs?
 
Old 06-02-2003, 10:31 AM   #10
iceman47
Senior Member
 
Registered: Oct 2002
Location: Belgium
Distribution: Debian, Free/OpenBSD
Posts: 1,123

Rep: Reputation: 47
Hi Jafar, don't dig up old finished threads but make a new one.
And be a little more specific on your problem when you do that.
Nobody has a clue what you problem is with "How can install kxine cvs?".
An answer to that question could be "get it from the cvs and configure, make and make install it", get my point?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xvid installed successfully but xine ... g-string 3 Linux - Software 2 08-16-2005 10:32 AM
problem with Xine and XviD Sako73 Linux - Software 1 11-28-2004 09:32 PM
XviD and Xine/Kaffeine? zenith_zth Linux - Software 1 10-26-2004 07:21 AM
prob xvid with xine cheyrek Linux - Software 5 07-19-2004 07:28 AM
Xine/Mplayer and Xvid 1.0 playback? yautja666 Linux - Newbie 3 05-24-2004 04:59 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration