LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-10-2006, 03:01 PM   #1
blackdragonblood
Member
 
Registered: May 2005
Location: Minneapolis, MN
Distribution: Debian
Posts: 217

Rep: Reputation: 30
xine gui install doesn't find xine-lib


I'm trying to install a zine gui after compiling the xine-lib. When I run ./configure for the gui, I get the following.
Quote:
*** Could not run XINE test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding XINE or finding the wrong
*** version of XINE. If it is not finding XINE, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
*** to the installed location Also, make sure you have run ldconfig if that
*** is required on your system
***
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
***
configure: error: *** You should install xine-lib first ***
Any ideas?
 
Old 02-10-2006, 03:51 PM   #2
blackdragonblood
Member
 
Registered: May 2005
Location: Minneapolis, MN
Distribution: Debian
Posts: 217

Original Poster
Rep: Reputation: 30
ok, I got around the above my typing what it asks me to. Now I get this from ./configure

Quote:
configure: error: *** libpng is needed (PNG library not found) - try to use --with-png-prefix option ***
Where is libpng? Do I need to install it?
 
Old 02-10-2006, 04:23 PM   #3
Boow
Member
 
Registered: Feb 2004
Distribution: Slackware 10.2
Posts: 669

Rep: Reputation: 32
what distro are you using why not just use rpms instead of trying to compile.
 
Old 02-10-2006, 04:33 PM   #4
blackdragonblood
Member
 
Registered: May 2005
Location: Minneapolis, MN
Distribution: Debian
Posts: 217

Original Poster
Rep: Reputation: 30
I'm using Fedora Core 4. I tried the rpms but I get dependency failures. I thought it I would have better luck compiling from source. I should have mentioned it eariler. Here is what I get from rpm.

Quote:
warning: xine-lib-1.1.1-1.2.fc4.i386.rpm: Header V3 DSA signature: NOKEY, key ID e42d547b
error: Failed dependencies:
libXvMCW.so.1 is needed by xine-lib-1.1.1-1.2.fc4.i386
libaa.so.1 is needed by xine-lib-1.1.1-1.2.fc4.i386
libdvdcss is needed by xine-lib-1.1.1-1.2.fc4.i386
libfame-0.9.so.1 is needed by xine-lib-1.1.1-1.2.fc4.i386
How do I go about solving these dependencies? Should I still compile from source?
 
Old 02-10-2006, 05:19 PM   #5
jlo_sandog
Member
 
Registered: Jul 2005
Location: USA
Distribution: F10 (x86_64)
Posts: 549

Rep: Reputation: 31
http://heidelberg.freshrpms.net/

While you're there download mplayer rpms. If you choose mplayer you have to install the win32 codecs before the mplayer files.

you can set up yum to do the install from freshrpms just read on the website for details.
 
Old 02-10-2006, 07:19 PM   #6
blackdragonblood
Member
 
Registered: May 2005
Location: Minneapolis, MN
Distribution: Debian
Posts: 217

Original Poster
Rep: Reputation: 30
That did the trick. Thx.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Conflicts when trying to install xine-lib steffendenize Suse/Novell 16 11-05-2005 06:39 PM
How can I get a frontend to find the xine lib? LinuxPadawan Linux - General 17 04-16-2005 08:39 PM
compatability between xine lib and xine ui b0nd Linux - Newbie 1 01-30-2005 07:13 AM
xine.de is under construction - how to install - xine-lib-1-rc3a.tar.gz sanjaya Linux - Software 1 02-13-2004 09:36 PM
anybody know how to install - xine-lib-1-rc3a.tar.gz sanjaya Linux - Software 1 02-12-2004 11:16 PM


All times are GMT -5. The time now is 08:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration